metadata service does not provide sub-directory lists for root and api level

Bug #453416 reported by Scott Moser on 2009-10-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Undecided
chris grzegorczyk
eucalyptus (Ubuntu)
Low
Dustin Kirkland 

Bug Description

in an ec2 instance:

$ wget http://169.254.169.254/ -O - -q
1.0
2007-01-19
2007-03-01
2007-08-29
2007-10-10
2007-12-15
2008-02-01
2008-09-01
2009-04-04
latest

$ wget http://169.254.169.254/latest/ -O - -q
dynamic
meta-data
user-data

In a uec instance, version eucalyptus-cloud:1.6~bzr931-0ubuntu2
$ wget http://169.254.169.254/ -O -
--2009-10-16 19:36:51-- http://169.254.169.254/
Connecting to 169.254.169.254:80... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2009-10-16 19:36:51 ERROR 500: Internal Server Error.

$ wget http://169.254.169.254/latest/ -O -
--2009-10-16 19:37:38-- http://169.254.169.254/latest/
Connecting to 169.254.169.254:80... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2009-10-16 19:37:38 ERROR 500: Internal Server Error.

Attached is 'crawl-user-data' that just mirrors the http to local filesytem. It relies on the list output shown above.

I'll attach the output when run in a EC2 instance also.

Scott Moser (smoser) wrote :

attaching output of crawl-user-data

Changed in eucalyptus:
assignee: nobody → chris grzegorczyk (chris-grze)
status: New → Confirmed
Thierry Carrez (ttx) wrote :

Setting importance to "Low", since I assume this is a "you don't act exactly like EC2" type of bugs. Please increase importance if key functionality relies on being able to crawl the metadata service like this.

Changed in eucalyptus (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

> Setting importance to "Low", since I assume this is a "you don't act
> exactly like EC2" type of bugs. Please increase importance if key
> functionality relies on being able to crawl the metadata service like
> this.

The importance of 'low' is fine as long as it doesn't mean "this will
never get fixed".

I've considered changing ec2-init to crawl the metadata service early on
and then make the data available in files in /var. This would be both
faster and more secure. Right now any process has access to the entire
metadata service, which possibly contains sensitive information.

Thierry Carrez (ttx) on 2009-10-26
Changed in eucalyptus (Ubuntu):
status: Confirmed → Triaged
Dustin Kirkland  (kirkland) wrote :

Scott-

Could you re-run these commands against Lucid, as Dan would like to see what's there, and what your current expectations are?

Changed in eucalyptus (Ubuntu):
status: Triaged → Incomplete
assignee: nobody → Scott Moser (smoser)
Changed in eucalyptus:
status: Confirmed → In Progress
chris grzegorczyk (chris-grze) wrote :

See -n0 log for more details.
------------------------------------------------------------
revno: 1186 [merge]
committer: decker <decker@hawaii>
branch nick: 1.6.2
timestamp: Tue 2010-02-09 19:22:47 -0800
message:
  merge metadata fixes plus fix to db connection pool housekeeping
------------------------------------------------------------

Changed in eucalyptus:
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu):
status: Incomplete → In Progress
assignee: Scott Moser (smoser) → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2~bzr1189-0ubuntu1

---------------
eucalyptus (1.6.2~bzr1189-0ubuntu1) lucid; urgency=low

  [ Thierry Carrez ]
  * debian/rules: Start publication jobs on package install (LP: #504326)
  * debian/*publication.upstart: Do not advertise Walrus, SC, CC or NC if
    eucalyptus authorized_keys is missing, since autoregistration would then
    partially fail (LP: #513722)

  [ Dustin Kirkland ]
  * Merge from upstream bzr revision, should fix:
    - LP: #453416 - fix metadata subdirectory lists
    - LP: #513842 - fix metadata ephemeral verbage
 -- Dustin Kirkland <email address hidden> Thu, 11 Feb 2010 16:32:06 -0600

Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers