authentication fails in certain cases for tools which assume UTC and do not include time zone data

Bug #437026 reported by chris grzegorczyk on 2009-09-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
Critical
Unassigned
1.6
Fix Released
Critical
Unassigned
eucalyptus (Ubuntu)
High
Dustin Kirkland 

Bug Description

Certain clients send timestamps in a format which only includes UTC time. In certain cases this causes the cloud to report that the message has expired.

chris grzegorczyk (chris-grze) wrote :

------------------------------------------------------------
revno: 895
committer: decker <decker@personal-army>
branch nick: 1.6
timestamp: Fri 2009-09-25 20:40:15 -0700
message:
  fix lp:437026, registration in CEST confirmed.
------------------------------------------------------------

Changed in eucalyptus:
status: New → Fix Committed
Daniel Nurmi (nurmi) on 2009-09-26
Changed in eucalyptus:
importance: Undecided → Critical
Changed in eucalyptus (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6.2-0ubuntu26

---------------
eucalyptus (1.6.2-0ubuntu26) lucid; urgency=low

  * Cherry-pick merge from upstream 1.6.2, now on revision 1217
    - LP: #534877 - fix potential db connection leak when no
      default kernel/ramdisk set
    - LP: #534868 - update expiration deadline
    - LP: #534869 - correct misleading error message
    - LP: #437026 - fix auth failures due to timezone
    - LP: #535335 - fix display of failed volumes
    - LP: #537058 - fix creation of large numbers of volumes
    - LP: #538604 - remember storage stats across sc restarts
    - LP: #547059 - fix euca-describe-snapshots
    - LP: #544992 - fix get-all-keys
 -- Dustin Kirkland <email address hidden> Mon, 29 Mar 2010 12:48:13 -0500

Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers