SC registration through web UI fails

Bug #436313 reported by Daniel Nurmi on 2009-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Fix Released
High
Neil Soman
1.6
Fix Released
High
Unassigned
eucalyptus (Ubuntu)
High
Unassigned

Bug Description

The web UI format change causes the registration of an SC (associated with a CC) to fail. The problem has been diagnosed and a fix is on its way.

Neil Soman (neilsoman) on 2009-09-25
Changed in eucalyptus:
assignee: Dmitrii Zagorodnov (dmitrii) → Neil Soman (neilsoman)
Neil Soman (neilsoman) wrote :

This is a regression and has been addressed in revno 876.

Changed in eucalyptus:
status: In Progress → Fix Committed
Changed in eucalyptus (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Thierry Carrez (ttx)
Thierry Carrez (ttx) wrote :

I had to apply the changes from rev867 before rev876 (since rev876 builds upon the fixes from rev867, apparently).

Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Committed
Daniel Nurmi (nurmi) wrote :

fully addressed in revno 593

Neil Soman (neilsoman) wrote :

Uhh, in revno 893, not 593 :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eucalyptus - 1.6~bzr854-0ubuntu6

---------------
eucalyptus (1.6~bzr854-0ubuntu6) karmic; urgency=low

  [ Thierry Carrez ]
  * Apply upstream rev867 and rev876 diffs to fix SC registration through
    Web UI, LP: #436313
  * tools/eucalyptus-java-ws.in: Reapply fix on boot messages that was lost
    on a merge, LP: #435766

  [ Dustin Kirkland ]
  * debian/80-eucalyptus-url: add an update-motd script that
    displays the administration URL in the MOTD at position 80, LP: #436199
  * debian/eucalyptus-nc.preinst: echo a warning message if a system
    installing the -nc does not have VT, LP: #426830
  * debian/rules: don't fail package installation due to init script
    failures, LP: #430075, #418473
  * tools/euca_conf.in: vastly improve the output of
    'euca_conf --register-nodes', which was missing some pertinent
    information, LP: #424457
  * clc/modules/www/src/main/java/edu/ucsb/eucalyptus/admin/server/ServletUtils.java:
    if we're going to use the local host to send email, use 'localhost' as
    the hostname, rather than the externally resolvable hostname which
    breaks in the default ubuntu postfix configuration, LP: #412676
  * debian/control:
    - have eucalyptus-common depend on openssh-server and openssh-client,
      as these should really be installed on most any Eucalyptus system,
      LP: #411656
    - have eucalyptus-common recommend unzip, since Eucalyptus uses zip
      files for credentials, which may be needed on various systems,
      LP: #436876
    - recommend libpam that provides pam_motd, LP: #436199
    - conflict with apache2-mpm-itk, LP: #338344
  * debian/eucalyptus-common.postinst: configure VNET_DHCPDAEMON and
    VNET_DHCPUSER appropriately for default Ubuntu on initial install,
    LP: #364938

  [ Colin Watson ]
  * debian/control:
    - Make eucalyptus-nc explicitly depend on apache2-mpm-worker |
      apache2-mpm-prefork, since the NC requires that Apache be configured
      to only start a single child (LP: #338344).

 -- Dustin Kirkland <email address hidden> Fri, 25 Sep 2009 18:01:29 -0700

Changed in eucalyptus (Ubuntu):
status: Fix Committed → Fix Released
Thierry Carrez (ttx) wrote :

rev893 was not applied, see comment 2. Reopening for a more complete fix.

Changed in eucalyptus (Ubuntu):
status: Fix Released → Triaged
Thierry Carrez (ttx) wrote :

The part of rev893 that seems to apply to this problem looks the same as rev867 + rev876, so I'd consider this fixed (the GUI looks alright). Neil, could you confirm with a recent daily CD ?

Changed in eucalyptus (Ubuntu):
status: Triaged → Fix Released
Changed in eucalyptus (Ubuntu):
status: Fix Released → In Progress
assignee: Thierry Carrez (ttx) → Dustin Kirkland (kirkland)
Changed in eucalyptus (Ubuntu):
status: In Progress → Fix Released
assignee: Dustin Kirkland (kirkland) → nobody
Andy Grimm (agrimm) on 2011-10-05
Changed in eucalyptus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers