euca-bundle-vol uses mkfs.ext3 options that don't exist on CentOS 5

Bug #771498 reported by Garrett Holmstrom
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
euca2ools
Fix Released
Undecided
Mitch Garnaat
1.3
Fix Released
Undecided
Unassigned
2.0
Fix Released
Undecided
Mitch Garnaat

Bug Description

euca-bundle-vol in euca2ools-main passes a -U option to mkfs.ext3 in an attempt to preserve the filesystem UUID as requested in LP #672986. This parameter does not exist on CentOS 5.

Scott Moser (smoser)
Changed in euca2ools:
status: New → Confirmed
Revision history for this message
Scott Moser (smoser) wrote :

@Garrett,
  Could you verify whether or not this patch fixes the problem?

Daniel Nurmi (nurmi)
Changed in euca2ools:
assignee: nobody → Mitch Garnaat (mitch-garnaat)
Revision history for this message
Garrett Holmstrom (gholms) wrote :

No, it doesn't, because it forgets to hand image_path to tunecmd. In fact, that problem already existed for xfs but was never reported. This patch seems to fix both problems.

Revision history for this message
Garrett Holmstrom (gholms) wrote :

Fixed in euca2ools-main rev 413

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers