euca2ools should include --region support

Bug #485113 reported by Scott Moser on 2009-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
euca2ools
Confirmed
Undecided
Mitch Garnaat
euca2ools (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: euca2ools

none of the euca2ools commands support '--region' flag.

This is less relevant to eucalyptus than it is to ec2, and arguably not at all
relevant to eucalyptus. That said, most ec2-* commands take '--region', which
essentially sets the EC2_URL flag accordingly. For example:

ec2-describe-instances <no-flag>
  uses ec2.amazonaws.com

ec2-describe-instaces --region us-east-1
  uses us-east-1.ec2.amazonaws.com

passing --region is more convienent than having to change EC2_URL for each.

Neil Soman (neilsoman) wrote :

"none of the euca2ools commands support '--region' flag."

euca-describe-availability-zones supports the --region flag.

Sure, this can be added to other commands.

It cannot be used in a consistent way with Eucalyptus and Amazon, however, since "--region" only supplies part of the EC2_URL. The rest is implicitly assumed to be "ec2.amazonaws.com"

Sure, we could make hack-ish assumptions (for instance, if the region contains /services/Eucalyptus, use the entire URL, if not, append ec2.amazonaws.com).

Scott Moser (smoser) wrote :

it might be reasonable to allow the user to define a "url_base", and then the euca2ools would use this base and insert the region as ec2 does.

ie, by default 'url_base' would be 'ec2.amazonaws.com'.
When the user passes '--region us-east-1', then 'us-east-1.ec2.amazonaws.com' would be used.

This would allow the user (in a possibly contrived example) to use "regions" for Eucalyptus also, by simply setting up their dns entries for their separate cloud controllers.

Example:
  url_base: cc.domain.com
  no region flag: cc.domain.com
  --region foo: foo.cc.domain.com
  --region bar: bar.cc.domain.com

Chuck Short (zulcss) on 2009-11-26
Changed in euca2ools (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Scott Moser (smoser) wrote :

above, 'url_base' could include a "%s" to indicate where 'region' would be plugged in:
ec2 url_base: %s.ec2.amazonaws.com
my-uec url_base: my-uec.example.com/%s

Neil Soman (neilsoman) on 2010-10-12
Changed in eucalyptus:
status: New → Confirmed
assignee: nobody → Mitch Garnaat (mitch-garnaat)

This I believe is a euca2ools issue.

affects: eucalyptus → euca2ools
Scott Moser (smoser) wrote :

This was fixed in upstream euca2ools in the 2.0 branch. It is present in precise now.

Changed in euca2ools (Ubuntu):
status: Confirmed → Fix Released
Andy Grimm (agrimm) wrote :

This issue is now being tracked upstream at http://eucalyptus.atlassian.net/browse/TOOLS-96

Please watch that issue for further updates.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers