Hanging spheres

Bug #442881 reported by Anton Gladky
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ESyS-Particle
Fix Released
High
Unassigned

Bug Description

After playing with some ESyS simulations. I have found that in some cases spheres hang and tremble on mesh-generated surfaces (see screenshots). I think it is an abnormal behavior.

Revision history for this message
Anton Gladky (gladky-anton) wrote :
Revision history for this message
Anton Gladky (gladky-anton) wrote :
Revision history for this message
Diego Peinado Martín (diego-peinado) wrote :

I did not find this behaviour yet. I'm experimenting with viscous walls, and having other problems. I also modified the standard behaviour of one sided walls to two sides walls, and with this behaviour, can occur what you relates.

Please can you post your script to reproduce it?
THanks,

Revision history for this message
Anton Gladky (gladky-anton) wrote :

I have attached the script. It takes a little bit long to finish the script.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

I have the same picture after "night simulation"

Revision history for this message
Dion Weatherley (d-weatherley) wrote :

Hi Anton,

Thanks for the comprehensive bug report. This looks very similar to the problem we encountered with the funnel flow exercise at the workshop in Aachen.

Steffen and I have discussed this issue and will give it high priority for a bugfix before the next release. The first thing will be to identify a small test case that displays this behaviour so we can more easily probe what exactly is happening to the hanging particles. If you can think of a test case or are able to learn some more about the forces etc. experienced by the hanging particles in your simulation, please post it here. Would be enlightening to know if hanging particles are touching edges, corners or faces of triangles.

Cheers,

Dion.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Ok, I will try to "localize" the problem, using just 2-3 triangles and 1 sphere.

Changed in esys-particle:
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Anton Gladky (gladky-anton) wrote :

I have created a small script with this problem

http://geom.com.ua/bug.tgz

Hope it will help to fix it.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Archive is in attachment

Revision history for this message
SteffenAbe (s-abe) wrote :

Fixed in svn trunk (r1278).

Changed in esys-particle:
status: Confirmed → Fix Committed
Revision history for this message
Anton Gladky (gladky-anton) wrote :

I can confirm, that the problem is completely resolved in r1278. Thanks a lot!

Vince Boros (v-boros)
Changed in esys-particle:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers