Show the touch overlay PPA in the package versions table

Bug #1479465 reported by Pat McGowan on 2015-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Errors
High
Brian Murray

Bug Description

The phone landings now target a vivid based overlay PPA and no longer use the RTM-14.09 derived distro. It would be helpful to update errors to reflect this, removing 14.09 and replacing it with this overlay.

Related branches

Brian Murray (brian-murray) wrote :

If we are talking a page like the following, https://errors.ubuntu.com/bucket/?id=/usr/bin/mediascanner-service-2.0%3A6%3A__gnu_cxx%3A%3A__verbose_terminate_handler%3A__cxxabiv1%3A%3A__terminate%3Astd%3A%3Aterminate%3A__cxxabiv1%3A%3A__cxa_throw%3Astep, then the columns are releases of Ubuntu and the rows are package versions. Given that the phone is not a different release, I'm not certain that we should have a separate column for it nor do I have an idea how we would technically accomplish that. (We are currently looking at counters for the release and package version, so crashes from phones would appear under the Ubuntu 15.04 column.)

What is the goal of this change? There may be a way we can identify PPA package versions in the rows.

Changed in errors:
status: New → Incomplete
Pat McGowan (pat-mcgowan) wrote :

It seems the crashes are reported under 15.04 now, I was hoping to be able to see the touch specific 15.04+overlay separately since it somewhat is a different release Then phone specific crashes would be shown apart from desktop ones

Brian Murray (brian-murray) wrote :

Yes, the crashes are reported under 15.04 now because that is the value of the DistroRelease field on those systems, where RTM 14.09 had a different DistroRelease field.

What exactly is that you want? Is it to figure out if a particular crash occurs with a package from the overlay PPA?

Pat McGowan (pat-mcgowan) wrote :

Right, the software is quite different from base vivid.

Brian Murray (brian-murray) wrote :

Updating the rows to show where the package came from should be sufficient to help identify if the package is from the overlay PPA.

Changed in errors:
status: Incomplete → Triaged
importance: Undecided → High
Changed in errors:
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Brian Murray (brian-murray) wrote :

I've modified the Error Tracker to show the pocket from which a package originated by querying Launchpad for the package version and release, subsequently packages from an unknown origin, including the overlay PPA, will appear as "(?)".

I'll get this landed as soon as possible.

Brian Murray (brian-murray) wrote :

This has landed now.

Changed in errors:
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

There was an issue with Ubuntu RTM 14.09 packages always having a (?) appended to them, but I've fixed that in r550 which has now landed on production.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers