expose user parameter on front page of errors.ubuntu.com

Bug #1122511 reported by Brian Murray
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Errors
Medium
Brian Murray

Bug Description

Its possible to supply a user parameter to errors.ubuntu.com like errors.ubuntu.com/?user=brian-murray which will display error reports regarding packages to which brian-murray is subscribed in Launchpad. However, there is no way for setting in the user interface - you can only modify the url to set it.

There should be a text input box where one can provide the name of a Launchpad user or team which will then change the errors presented.

<https://wiki.ubuntu.com/ErrorTracker#Front_page>: "The package combo box should have menu items for ... “packages subscribed to by…”. The text field should accept any of ... (c) the character “~” followed by a valid Launchpad ID, or (d) the URL of a valid Launchpad profile, which should be auto-converted to the character “~” followed by the Launchpad ID. If you choose “packages subscribed to by…” from the menu, the field should be pre-filled with “~” and the caret placed after it, ready for you to type the Launchpad ID."

Related branches

Revision history for this message
Brian Murray (brian-murray) wrote :

Matthew - could you tell me where you think this would best fit and perhaps provide some text around the box?

Changed in errors:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Brian Murray (brian-murray) wrote :

Perhaps 'users of all binary packages all installed versions subscribed to by Launchpad user brian-murray', where subscribed to by is the additional text. However, inputting a binary package and a Launchpad user would not work too well at this point in time.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Is there any reason you'd need to specify both at once -- a package name/set, and a subscriber? If not, it's possible we could present them in the same control.

Changed in errors:
assignee: nobody → Matthew Paul Thomas (mpt)
status: Triaged → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

It is possible that the Launchpad user may not be subscribed to all the packages one is interested in, in which case you may want to see packages for the user and another package. However, this seems like a rare situation to me and not being able to specify both at the same time would work for most cases.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :
Changed in errors:
assignee: Matthew Paul Thomas (mpt) → nobody
status: Confirmed → Triaged
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote :

"The text field" does not appear in the mock-up and it isn't clear to me what the settings would be to view errors just about ubiquity as ubiquity would not appear in the package combo box.

Would it be:

all users "of the package" "ubiquity"?

where the first part is the package combo box and the second part the text field.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

A combo box is called a combo box because it is a combo of a text field plus a menu. That's the text field I'm referring to. (Unfortunately browsers don't yet render HTML's <datalist> as a combo box, so this will need a <select> fallback.)

I understood you to say that it would be okay for people to be able to specify either a package name,

    Showing error reports from [all users :^] of [ubiquity |v]

a package set,

    Showing error reports from [all users :^] of [Ubuntu server |v]

or the packages subscribed to by a particular user,

    Showing error reports from [all users :^] of [~brian-murray |v]

without being able to specify two of those simultaneously. If I misunderstood, or if that design turns out not to be discoverable enough, I'll draw up something that involves a separate control.

Changed in errors:
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote :

This landed with r285 which has been rolled out.

Changed in errors:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers