Can't open Epidermis 0.4: /boot/grub/installed-version not found

Bug #469655 reported by MaTi on 2009-11-01
102
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Epidermis
Critical
David D Lowe

Bug Description

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/epidermis/epidermis.py", line 39, <module>()
                               # but it throws off pychecker
    import const
    from const import DEBUG, MY_CACHE_HOME, MY_DATA_HOME, PIGMENT_TYPES
  variables: {'const': (None, None)}
  File "/usr/share/pyshared/epidermis/const.py", line 55, <module>()
    # is grub2 installed, if yes, don't use themes
    __ff = open("/boot/grub/installed-version","r")
    __line = __ff.readlines()[0].strip()
  variables: {'__ff': (None, None), 'open': ('builtin', <built-in function open>)}
IOError: [Errno 2] No existe el fichero ó directorio: '/boot/grub/installed-version'

debuginfo.debuginfo error, traceback:

Traceback (most recent call last):
  File "/usr/share/pyshared/epidermis/gtkexcepthook.py", line 176, in _info
    import debuginfo
  File "/usr/share/pyshared/epidermis/debuginfo.py", line 6, in <module>
    import const
  File "/usr/share/pyshared/epidermis/const.py", line 55, in <module>
    __ff = open("/boot/grub/installed-version","r")
IOError: [Errno 2] No existe el fichero ó directorio: '/boot/grub/installed-version'

--End of debuginfo traceback.

David D Lowe (flimm) wrote :

Thanks for the bug report. To narrow down the problem, could you post the results of these commands:

apt-cache policy grub grub2
cat /boot/grub/installed-version

Changed in epidermis:
status: New → Incomplete
MaTi (mativillagra) wrote :

Hi. thanks for quick respon.

Here I go.

apt-cache policy grub grub2
grub:
  Instalados: (ninguno) //// ninguno means none.
  Candidato: 0.97-29ubuntu59
  Tabla de versión:
     0.97-29ubuntu59 0
        500 http://ar.archive.ubuntu.com karmic/main Packages
grub2:
  Instalados: (ninguno)
  Candidato: 1.97~beta4-1ubuntu3 /////candidato means candidate.
  Tabla de versión:
     1.97~beta4-1ubuntu3 0
        500 http://ar.archive.ubuntu.com karmic/universe Packages

cat /boot/grub/installed-version
cat: /boot/grub/installed-version: No existe el fichero ó directorio ///// File or directory dosent exist.

explain. I have to SATA disk, the grub is install on the non ubuntu / mount point.

Marius Nestor (marius-nestor) wrote :

Same error here. I also have 2 SATA disks, if that's the issue...

dervish (dervish666) wrote :

I'm having the same thing exactly,

I'm using my laptop so one SATA disk. Just Ubuntu 9.10 64bit installed.

thunderbear (davewendydan) wrote :

same here

same error & 9.10 64bit single sata on laptop

David D Lowe (flimm) wrote :

I'm unfamiliar with unusual grub configurations, so I'll need you to help me out here. Where would installed-version be? On my system it's here: /boot/grub/installed-version

Meanwhile, I've got a patch that should fix the problem temporarily. Download the patch into your home directory and run:
cd /usr/lib/python2.6/dist-packages/epidermis; sudo patch < ~/patch.diff

David D Lowe (flimm) wrote :

About the previous comment: that command is all one line, Launchpad automatically added a line break in the middle.

MaTi (mativillagra) wrote :

root@xxxx-desktop:/usr/lib/python2.6/dist-packages/epidermis# cd /usr/lib/python2.6/dist-packages/epidermis; sudo patch < ~/patch.diff
patching file const.py
Reversed (or previously applied) patch detected! Assume -R? [n] -R
Apply anyway? [n] y
Hunk #1 FAILED at 52.
1 out of 1 hunk FAILED -- saving rejects to file const.py.rej

--- No epirdermis running.

Thanks!!!!

David D Lowe (flimm) wrote :

Don't know what went wrong there. It shouldn't have asked you that question, unless const.py has been modified for some reason.
I've packaged a version of Epidermis 0.4 with the patch included, I hope that fixes it for you. I still need to know where /boot/grub/installed-version is on your system, though.

MaTi (mativillagra) wrote :

Fix Works!!!

Thanks!!! Users should downloand this .deb files.

Soon, I will give you and update on my grub version.

Thanks from Corrientes, Argentina!!

Marius Nestor (marius-nestor) wrote :

It works here also! Thanks a lot guys!

bkberger (bkberger) wrote :

user@System:~$ apt-cache policy grub grub2
grub:
  Installed: (none)
  Candidate: 0.97-29ubuntu59
  Version table:
     0.97-29ubuntu59 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
grub2:
  Installed: 1.97~beta4-1ubuntu4
  Candidate: 1.97~beta4-1ubuntu4
  Version table:
 *** 1.97~beta4-1ubuntu4 0
        500 http://us.archive.ubuntu.com karmic-proposed/universe Packages
        100 /var/lib/dpkg/status
     1.97~beta4-1ubuntu3 0
        500 http://us.archive.ubuntu.com karmic/universe Packages

Deb with temporary fix worked fine for this error.

David D Lowe (flimm) on 2009-11-07
summary: - Cant open Epidermis 0.4 on Ubuntu 9.10
+ Can't open Epidermis 0.4: /boot/grub/installed-version not found
David D Lowe (flimm) on 2009-11-08
Changed in epidermis:
importance: Undecided → Critical
daizuke (daizukeforever) wrote :

deb with temporay fix works! thanks you!

Luke (luke-mrmcdaniel) wrote :

I didn't try the patch, but the .deb works for me.
Ubuntu 9.10 64bit (clean def install so ext4 and grub2)
I have 1 PATA and 2 SATA hd's if that helps.

Also having the same problem on a clean default install of 9.10 64-bit. As you can see, the PPA is failing to build because of this error as well: http://launchpadlibrarian.net/35335287/buildlog_ubuntu-karmic-i386.epidermis_0.4-0ubuntu0_FAILEDTOBUILD.txt.gz

I'm having the same problem. I installed the file as above and it works for me now (Deb with temporary fix )

Thank you.

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/epidermis/epidermis.py", line 39, <module>()
                               # but it throws off pychecker
    import const
    from const import DEBUG, MY_CACHE_HOME, MY_DATA_HOME, PIGMENT_TYPES
  variables: {'const': (None, None)}
  File "/usr/share/pyshared/epidermis/const.py", line 55, <module>()
    # is grub2 installed, if yes, don't use themes
    __ff = open("/boot/grub/installed-version","r")
    __line = __ff.readlines()[0].strip()
  variables: {'__ff': (None, None), 'open': ('builtin', <built-in function open>)}
IOError: [Errno 2] No such file or directory: '/boot/grub/installed-version'

debuginfo.debuginfo error, traceback:

Traceback (most recent call last):
  File "/usr/share/pyshared/epidermis/gtkexcepthook.py", line 176, in _info
    import debuginfo
  File "/usr/share/pyshared/epidermis/debuginfo.py", line 6, in <module>
    import const
  File "/usr/share/pyshared/epidermis/const.py", line 55, in <module>
    __ff = open("/boot/grub/installed-version","r")
IOError: [Errno 2] No such file or directory: '/boot/grub/installed-version'

--End of debuginfo traceback.

David D Lowe (flimm) on 2009-11-09
Changed in epidermis:
status: Incomplete → Fix Committed
David D Lowe (flimm) on 2009-11-09
Changed in epidermis:
assignee: nobody → David D Lowe (flimm)
milestone: none → 0.4.1
David D Lowe (flimm) on 2009-11-09
Changed in epidermis:
status: Fix Committed → Fix Released

Strangely enough it's started working without issue.
------Original Message------
From: Launchpad Bug Tracker
Sender: <email address hidden>
To: Timothy Owings
Subject: [Bug 469655] Re: Can't open Epidermis 0.4:/boot/grub/installed-version not found
Sent: Nov 9, 2009 12:46

** Branch linked: lp:epidermis

--
Can't open Epidermis 0.4: /boot/grub/installed-version not found
https://bugs.launchpad.net/bugs/469655
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in Epidermis theme manager: Fix Committed

Bug description:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/epidermis/epidermis.py", line 39, <module>()
                               # but it throws off pychecker
    import const
    from const import DEBUG, MY_CACHE_HOME, MY_DATA_HOME, PIGMENT_TYPES
  variables: {'const': (None, None)}
  File "/usr/share/pyshared/epidermis/const.py", line 55, <module>()
    # is grub2 installed, if yes, don't use themes
__ff = open("/boot/grub/installed-version","r")
__line =__ff.readlines()[0].strip()
  variables: {'__ff': (None, None), 'open': ('builtin', <built-in function open>)}
IOError: [Errno 2] No existe el fichero ó directorio: '/boot/grub/installed-version'

debuginfo.debuginfo error, traceback:

Traceback (most recent call last):
  File "/usr/share/pyshared/epidermis/gtkexcepthook.py", line 176, in_info
    import debuginfo
  File "/usr/share/pyshared/epidermis/debuginfo.py", line 6, in <module>
    import const
  File "/usr/share/pyshared/epidermis/const.py", line 55, in <module>
__ff = open("/boot/grub/installed-version","r")
IOError: [Errno 2] No existe el fichero ó directorio: '/boot/grub/installed-version'

--End of debuginfo traceback.

Sent from my BlackBerry® smartphone with SprintSpeed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers