epicsTimeGetEvent() / generalTime bug

Bug #1747091 reported by Till Straumann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
EPICS Base
Status tracked in 7.0
3.14
Fix Released
Low
Andrew Johnson
3.15
Fix Released
Low
Andrew Johnson
3.16
Fix Released
Low
Andrew Johnson
7.0
Fix Released
Low
Andrew Johnson

Bug Description

When changes in epicsGeneralTime.c were made (fetch time provider's eventTime into a local copy) an inconsistency resulted.

Revision history for this message
Till Straumann (strauman) wrote :
Revision history for this message
Till Straumann (strauman) wrote :

Forgot to mention that I found this in base-3.15.5; seems to still be present in the 3.15 head

Revision history for this message
mdavidsaver (mdavidsaver) wrote :

Till, can say a few words about the symptoms you see so that others can decide if they are seeing the same issue?

Revision history for this message
mdavidsaver (mdavidsaver) wrote :

It looks like the issue was introduced by 80eaad41183e5f3eb54509bea17a91b52daef27d and effects 3.14.12.6, 3.15.5, 3.16.1, and 7.0.1.

Revision history for this message
Andrew Johnson (anj) wrote :

Agreed, this change was missed, I will apply it and merge up.

Revision history for this message
Andrew Johnson (anj) wrote :

This may have come from a bad merge, the IFDEBUG(10) block below appears in the wrong place (the indentation is correct, but it's below the closing brace of the block that it should appear inside).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Patches