SVG images look blurry when zoomed in

Reported by Trouilliez vincent on 2007-03-14
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Wishlist
eog (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: eog

See attached screenshot for an example.
I picked up an icon in /usr/share/icons/gnome/scalable, and picked the desktop icon as an example.
I wanted to verifiy that SVG/vector graphics look perfectly clean when scaled up significantly, to satisfy my curiosity, and discovered with horror that, well, it looked blurry, just like bitmaps do ! :o(

Hopefully it's just a problem with EOG not displaying them correctly, rather than a particular problem with the Gnome SVG icons, or worse, a problem with SVG images in general...

ProblemType: Bug
Architecture: i386
Date: Wed Mar 14 04:30:20 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/eog
Package: eog 2.18.0.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: eog file:///home/vincent/Desktop/Screenshot-user-desktop.svg.png
ProcCwd: /home/vincent
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: eog
Uname: Linux Lotus-Esprit 2.6.20-10-generic #2 SMP Mon Mar 12 00:02:49 UTC 2007 i686 GNU/Linux

Andreas Simon (andreas-w-simon) wrote :

Yes, this is a problem with eog which doesn't scale vector graphics right.

Changed in eog:
status: Unconfirmed → Confirmed
Changed in eog:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Changed in eog:
status: Unknown → Confirmed
djr013 (djr013) wrote :

I have the same problems with stretching SVG icons on the desktop. At first I thought it there was a small chance the problem could be an embedded image, but in Inkscape the files scale perfectly. At least menus and toolbars work right.

djr013 (djr013) wrote :

Update: Also doesn't seem to scale/zoom/fit properly for the background! I was convinced it was working since I used an SVG file for my background already, but when I changed it to one with sharper lines (non-abstract), it was blurry.

Changed in eog:
status: Confirmed → Triaged
Warbo (warbo) wrote :

I'd like to see this fixed, since it is kind of annoying to open Inkscape just to view an image in detail. It could be fixed by rendering vector images every time they are zoomed in or out, rather than the current behaviour of rendering once when it is loaded then zooming in the rendered image (which makes it blurry).

Martin Owens (doctormo) wrote :

This is still a problem in Jaunty 9.04, it's a big problem with vector handling and isn't hard to fix if it's using cairo rendering already for pdf files. It's just a matter of rendering vs rasterising ordering.

Alex Valavanis (valavanisalex) wrote :

Still in lucid alpha 3.

$ apt-cache policy eog
eog:
  Installed: 2.29.91-0ubuntu1
  Candidate: 2.29.91-0ubuntu1
  Version table:
 *** 2.29.91-0ubuntu1 0
        500 http://gb.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

dinamic (dinamic6661) wrote :

i have the same bug in 10.04 alpha3 http://i43.tinypic.com/msi2wo.jpg

it seems it's a 2year old bug https://bugzilla.gnome.org/show_bug.cgi?id=108435

dinamic (dinamic6661) on 2010-03-17
Changed in eog (Ubuntu):
status: Triaged → Confirmed
Alex Valavanis (valavanisalex) wrote :

Looks like this is fixed upstream in commit 21caf5f03041e236157e967bf2c07832b5ba551b

http://git.gnome.org/browse/eog/diff/?id=21caf5f03041e236157e967bf2c07832b5ba551b&id2=e89ebc3220f2cab15c998af8891d93c2499afe72

Upstream patch attached

tags: added: patch
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now but the change are not trivial and will not go in lucid now

Changed in eog (Ubuntu):
status: Confirmed → Fix Committed
Changed in eog:
status: Confirmed → Fix Released
Philip Muškovac (yofel) wrote :

Tagging as fixed upstream an unsubscribing reviewers.

tags: added: patch-accepted-upstream
Philip Muškovac (yofel) on 2010-05-08
tags: removed: patch
Sebastien Bacher (seb128) wrote :

the new version has been uploaded now

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in eog:
importance: Unknown → Wishlist
Frank Rivera (frivera-d) wrote :

i'm not familiar with all the coding mentioned on this thread. I have this same issue. Converted JPEG to SVG in Inkscape & the SVG is blurry. How can I fix it? thanks in advance.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.