eog window size exceeds screen height

Bug #646798 reported by Mahendra Tallur on 2010-09-24
198
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
One Hundred Papercuts
Low
Papercuts Ninjas
eog (Ubuntu)
Low
Leonardo Donelli
Raring
Low
Unassigned

Bug Description

* IMPACT *
Eye of gnome (eog), sometimes has a window size that exceeds the screen height, which makes the bottom of the window (mostly the status bar) invisible.

* HOW TO REPRODUCE *
1. Open this image with eye of gnome:
   http://pinkie.ponychan.net/chan/files/src/136745379914.png

(Note: it is not guaranteed to trigger the bug on every resolution, but should work for the most common screen resolutions)

* REGRESSION POTENTIAL *
The patch is short and simple, has a limited (if not null) potential to regression.
But it could:
 - Generate strange / inadequate window size when viewing an image in eye of gnome
 - Other problems related to window/view/image size when viewing an image in eye of gnome

Mahendra Tallur (mahen) wrote :
Mahendra Tallur (mahen) wrote :

It turned out this issue only occurs when Compiz is enabled.

Maybe I shouldn't have filed a report against eog upstream then. I still haven't noticed any other app affected by this behaviour though.

Changed in eog:
importance: Unknown → Medium
status: Unknown → Incomplete
Mahendra Tallur (mahen) wrote :

See below a screenshot of what occurs when compiz is enabled in Maverick beta : the eog window is oversized, thus one cannot see the bottom of the picture nor its status bar. It happens with all pictures that do not fit the screen and have to be resized by eog.

Should I file a bug against Compiz also ? I don't know if Compiz or eog is the culprit... I reported it upstream (eog) but no one seems aware of this bug.

bc81 (bc81) wrote :

i came across this bug today in ubuntu 10.10 32-bit desktop edition and can confirm. a quick and dirty workaround is to use the CompizConfig Settings Manager (ccsm) to enable the Window Rules Plugin, then add "name-eog" in the maximized dialogue.

This is obviously not the desired behavior, but for now it's much better than the image falling off the bottom of the screen.

bc81 (bc81) wrote :

sorry, i meant to type name=eog (equals instead of hyphen)

Hagen (hagenf) wrote :

confirmed on Maverick 64-bit with Compiz

Changed in eog:
status: Incomplete → New
emas (vugene) wrote :

Encountered with eog on Maverick 32-bit with compiz on a screen resolution of 1024x600.

Also occurred for gthumb and something else that I can't remember right now.

gmcd (gmcd) wrote :

confirmed on Maverick 64-bit without Compiz or any other compositing manager, installed latest system updates

Changed in eog:
status: New → Confirmed

this bug is gone in Natty with compiz downgraded back to 0.8.6 and no
Unity and no Ubuntu Desktop ..just Ubuntu base

BWT ..in this configuration work as fast as 10.10 ..but with Unity
hmm slow (in a high speed machine)

2011/5/28 Bug Watch Updater <email address hidden>:
> ** Changed in: eog
>       Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (695896).
> https://bugs.launchpad.net/bugs/646798
>
> Title:
>  eog window size exceeds screen height
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/eog/+bug/646798/+subscribe
>

--
Nemes Ioan Sorin

Changed in eog (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Ahmed Shams (ashams) wrote :

Confirmed in Papercuts.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → precise-6-photos

It's been a while since this bug was reported. Is this still an issue in 12.04?

Changed in hundredpapercuts:
milestone: precise-6-photos → none
status: Confirmed → Incomplete
MartinMario (martins1995) wrote :

It still happens in my 64bit install of Precise with Unity (so, Compiz is used), as you can see on the screenshot.

Changed in hundredpapercuts:
status: Incomplete → Confirmed
milestone: none → quantal-7-photo
Nemes Ioan Sorin (nemes-sorin) wrote :

...hmm I was thinking that for GNOME 3 technology they will improve
the toolkit, at least the basic functionality of the window layers ;)
Should be trivial to fix such problem in a windows 32/64 environment
but seems that is impossible with GNU tools ;)
now I'm really curios if EOG developers can fix this long standing
bug, which really make me to stop using EOG.

2012/7/4 Chris Wilson <email address hidden>:
> ** Changed in: hundredpapercuts
> Status: Incomplete => Confirmed
>
> ** Changed in: hundredpapercuts
> Milestone: None => quantal-7-photo
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (695896).
> https://bugs.launchpad.net/bugs/646798
>
> Title:
> eog window size exceeds screen height
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/eog/+bug/646798/+subscriptions

--
Nemes Ioan Sorin

Robert Roth (evfool) wrote :

Question in upstream bug:
"This bug was reported against a version which is not supported any more.
Developers are no longer working on this version so there will not be any bug
fixes for it.
Can you please check again if the issue you reported here still happens in a
recent version of GNOME and update this report by adding a comment and
adjusting the 'Version' field?

Again thank you for reporting this and sorry that it could not be fixed for the
version you originally used here.

Without feedback this report will be closed as INCOMPLETE after 6 weeks."
Please someone who is experiencing this bug, confirm this upstream on a more recent version of EOG if this still exists.

Nemes Ioan Sorin (nemes-sorin) wrote :

"
It still happens in my 64bit install of Precise with Unity (so, Compiz
is used), as you can see on the screenshot.

** Attachment added: "Eye of GNOME window too big"
   https://bugs.launchpad.net/ubuntu/+source/eog/+bug/646798/+attachment/3212282/+files/eog_bug_precise.png
"
the previous text is a copy / paste from a message of MartinMario ✆
<email address hidden>
he send this message to the list on 4 July
that mean Gnome 3

2012/7/29 Robert Roth <email address hidden>:
> Question in upstream bug:
> "This bug was reported against a version which is not supported any more.
> Developers are no longer working on this version so there will not be any bug
> fixes for it.
> Can you please check again if the issue you reported here still happens in a
> recent version of GNOME and update this report by adding a comment and
> adjusting the 'Version' field?
>
> Again thank you for reporting this and sorry that it could not be fixed for the
> version you originally used here.
>
> Without feedback this report will be closed as INCOMPLETE after 6 weeks."
> Please someone who is experiencing this bug, confirm this upstream on a more recent version of EOG if this still exists.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (695896).
> https://bugs.launchpad.net/bugs/646798
>
> Title:
> eog window size exceeds screen height
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/eog/+bug/646798/+subscriptions

--
Nemes Ioan Sorin

Martin Thorsager (thorsager84) wrote :

Just thought I'd like to add, that it doesn't work in 12.04 32-bit as well (eog version 3.4.2)

shclim (shclim) wrote :

I'm also having this problem in 12.10 (eog version 3.6.0)

Changed in hundredpapercuts:
milestone: quantal-7-photo → raring-misc
chag (chagam) wrote :

Hi,

I have the same problem. I'm using a Matrox TripleHead so I have 3 screens. EOG open on the center screen and uses the width of both right screens. Ubuntu 12.10, fresh install

Changed in hundredpapercuts:
milestone: none → misc
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Leonardo Donelli (learts92) wrote :

Confirming the bug on default Ubuntu 13.04 installation, eog 3.6.2-0ubuntu1.

Leonardo Donelli (learts92) wrote :

I provided Felix Riemann (eog developer) the output he requested. Hopefully it will help him (or anyone) fix the bug.
The upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=630512

description: updated
Changed in eog (Ubuntu):
assignee: nobody → Leonardo Donelli (learts92)
status: Triaged → Fix Committed

This isn't Fix Committed though, since it's not in the Ubuntu queue or anything -- resetting to Triaged .

Changed in eog (Ubuntu):
status: Fix Committed → Triaged
Leonardo Donelli (learts92) wrote :

Ops, sorry, I forgot to update.
Immediately after my last message I started working on a patch. Turns out it was quite trivial, and I've produced one I proposed upstream (which already has a positive review) and I asked what to do downstream in IRC (#unbutu-desktop).
cyphermox and robru reviewed my patch, considered it good enough and suitable to SRU, and cyphermox is currenly packaging it.

Changed in eog (Ubuntu):
status: Triaged → In Progress
Changed in eog (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.6.2-0ubuntu2

---------------
eog (3.6.2-0ubuntu2) saucy; urgency=low

  * debian/patches/0001-Set-better-window-size.patch: better figure out a scale
    factor for images that have a bigger height than screen size when taking
    into account window decoration. Thanks Leonardo Donelli!. (LP: #646798)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 09 May 2013 20:37:22 -0400

Changed in eog (Ubuntu):
status: In Progress → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in eog:
status: Confirmed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in eog (Ubuntu Raring):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.