Doesn't display animated GIFs

Reported by Trouilliez vincent on 2006-03-19
170
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Wishlist
eog (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

I just started to play with the "byzanz" desktop recorded, which creates animated GIFs. I opened the file with eog to look at it, and was disappointed/surprised that it didn't "play" the animation.
I could play it with Gthumb, but I think it's reasonable to expect eog to be able to "play" an animated GIF as well.

Corey Burger (corey.burger) wrote :

I have reported this upstream as #335093

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you have an example to attach or an URL?

Changed in eog:
assignee: nobody → desktop-bugs
Sebastien Bacher (seb128) wrote :
Changed in eog:
status: Unconfirmed → Confirmed

Yes that's the movie I made with Byzanz.

I also uploaded a few (non-Byzanz) more GIFs there:

http://www.007.org.uk/~vtrouilliez/tmp/

a-r-k-i-b-o-t-t (arkibott-ray) wrote :

I also wanted to report this as a Bug. I didn't expect it to be a Bug in a tool called 'Byzanz'. My solution to this Problem would be this: Gif files should be opened with gthumb because the normal viewer does not display the animations. So easy. :)

Workaround: Edit the Nautilus Settings of a Gif-File and choose Open With: gthumb

a-r-k-i-b-o-t-t (arkibott-ray) wrote :

( Question on Bug-Reporting: Do i have to add gthumb or nautilus via 'Also affects distribution' ? )

Gerhard Klünger (g-kluenger) wrote :

Ubuntu 7.04, german version - still same situation.

Find example-file attached.

Gruß, Gerhard

Changed in eog:
status: Confirmed → Triaged
tlvince (tlvince) wrote :

Same "Bug" here, with any animated GIFs

Christoph Langner (chrissss) wrote :

Still the case for eog 2.20.0-0ubuntu3

komputes (komputes) wrote :

This is still the case for Eye of GNOME 2.20.1, does not play animated gifs.

Murat Gunes (mgunes) wrote :

This bug is now more important, since with the removal of gThumb, there's now no application in the default install for handling animated GIFs.

Changed in eog:
importance: Wishlist → Medium
Sebastien Bacher (seb128) wrote :

still a wishlist

Changed in eog:
importance: Medium → Wishlist
Termina (termina) wrote :

Wow, almost two years and still not fixed?

> Murat Güneş wrote on 2008-02-25
> This bug is now more important, since with the removal of gThumb, there's now no application
> in the default install for handling animated GIFs.

Actually, I found that Firefox, which is in the default install, can display animated GIF's just fine, so that's the workaround I use... but still hoping EOG will handle them some day, 'cause using a web browser to view an image file isn't exactly intuitive ! ;-)

end-user (end-user) wrote :

I'm curious why this is considered a wishlist and not a bug. Isn't the expected behaviour for viewing a gif to see the animation?

Anyway, I think as the default image viewer it should be able to fully view a gif, even more so now in Hardy, since gThumb has been removed.

> I'm curious why this is considered a wishlist and not a bug.
>Isn't the expected behaviour for viewing a gif to see the animation?

I am curious too !
I would understand if the devs told us they don't have time to work on it, or there are more important things to do first, but considering this bug as a wishlist, does escape me, in all honesty.

Sebastien Bacher (seb128) wrote :

you should not focus on the bug settings so much, what difference does it make it being a wishlist or low priority issue? the ubuntu team is small and doesn't have the ressources to work on that issue, you can either consider it as something which should be implemented and is not yet, in which case it's a wishlist, or as a bug in a feature already available, either case will not change the fact that the team as other priority to work on right now

end-user (end-user) wrote :

> you should not focus on the bug settings so much, what difference does it make it being a wishlist or low priority issue?
> the ubuntu team is small and doesn't have the ressources to work on that issue,
> you can either consider it as something which should be implemented and is not yet,
> in which case it's a wishlist, or as a bug in a feature already available, either case will not
>change the fact that the team as other priority to work on right now

I meant no offence by asking - in this case curious really just meant curious. Some of us who are new to the process might not realize what is apparent now - that the priority is a very minor distinction.

Respectfully, I would only add that to someone not familiar with the inner workings of something like this, the difference can seem quite substantial. "Low priority" suggests that there is in fact a problem with something not working as it should/was intended to, but is not a pressing issue, whereas "wishlist" implies that it is a feature request, and therefore debatable.

I know this has got to be an ultra busy time and I certainly don't expect anyone to drop anything to work on this - I know it is a very minor issue.

Sebastien Bacher (seb128) wrote :

right the distinction between feature request or a bug might not be easy, as written something which is supposed to work and is broken is usually a bug, something which has not been coded yet is a feature request

Isn't it implemented by any particular reason?? I haven't found any responde from a developer. :?

I don't think the lack of support is considered a "feature", otherwise we would have told so, and the bug would have been rejected.
So assuming the devs consider it as valid, I guess it will get fixed one day !

I hope it will anyway, because I found it really, really weird thazt EOG failed to play naimated GIF, so weird that I really didn't think twioce before filng this bug report.

So maybe one day.

In the meantime, here is hoping your comment and mine will breathe some life into the report, and put it back from the bottom of the pile, towards somewhere nearer the top hopefully ! ;-)

Christoph Langner (chrissss) wrote :

GNOME 2.24 with eog 2.24.0 is out...

$ eog --version
GNOME eog 2.24.0

Still no support for animated gifs. So this bug is still an issue with intrepid.

Yep, I can confirm.
I just tried it in the latest Intrepid.. animated GIF still won't play...

Sebastien Bacher (seb128) wrote :

there is no need to confirm that triager bugs are still hapenning several times, one comment saying it's still there on intrepid is enough

Paul Brando (paulbrando) wrote :

Can't someone just pull the code for gifs from gThumb and modify it to work in EOG?

Raoul B. (rb75) wrote :

Hi, you'll find a patch here : http://raoulito.info/eog_animagifs/

Oleg Vaskevich (olegv) wrote :

Come on, one of the most basic programs in an operating system is the image viewer. If even that doesn't work properly then it's not a good OS... If the developers of EOG don't have time to implement this, then use some other program as a default image viewer, like GThumb.

Even a patch has been submitted, doesn't matter if it's temporary, it's better than nothing.

Oleg Vaskevich (olegv) wrote :

Mirage is also a great image viewer.

Xero Xenith (xero-xenith) wrote :

On Jaunty Alpha 6, EOG 2.26.0. Still no animated GIFs.

I know that as someone with no skill in coding I shouldn't say this, but... this is getting kind of ridiculous. Every other image viewer has it, why not the default one?

Pedro Villavicencio (pedro) wrote :

Is not implemented yet and such comments don't help the bug to get fixed at all, you're welcome to test the patches that are being submitted upstream at http://bugzilla.gnome.org/show_bug.cgi?id=335093 and give feedback (works/or it doesn't/etc) or submit a new and better one there, but just complaining doesn't help at all, please bear that in mind, thanks in advance.

Andreas Moog (amoog) wrote :

I have included the patch from upstream in a package for jaunty. You can find it in my PPA (https://edge.launchpad.net/~andreas-moog/+archive/ppa) Please test and comment in the upstream bug-report. This will higher the chance that the patch gets included. Thanks.

antistress (antistress) wrote :

i tried http://librarian.launchpad.net/1785060/movie.gif & optische_illusion_kreis_animated.gif with the package from Andreas Moog PPA.
They both work on Jaunty except that optische_illusion_kreis_animated.gif animation stops briefly at 11/12 with that eog version whereas Firefox don't.

Andreas Moog (amoog) wrote :

I also have built an intrepid-version with the patch applied, available in my PPA. Please test and report back HERE if there are any problems as Upstream would not accept problem-reports on version 2.24.1. Thanks.

Thanks for the PPA, this makes it much more efficient to test.

I made a video of a gif playing in firefox and the same in eog, it seems
that eog plays it back a bit faster but stops periodically.

Here it is of one "sync" cycle with eog running ahead (they are in sync at
the beginning and end):
http://dl.getdropbox.com/u/84880/unsynced-animation.ogv

Andreas' PPA version works fine for me. Thanks :)

Donarsson (benjamin-schwarz) wrote :
Donarsson (benjamin-schwarz) wrote :

The above posted file should work as a patch, but i haven't tested it jet.
If it works pleeeeeease someone bring it into the next eog version!

Pedro Villavicencio (pedro) wrote :

patch needs to be reviewed/committed by the upstream developers, then we can integrate that package into Ubuntu, there's no hurry for enhancement requests.

Vadim Peretokin (vperetokin) wrote :

I'd consider being able to display animated gif's that were introduced in
'87 rather vital, if not even completely backward for not being able to.

Sebastien Bacher (seb128) wrote :

those comments are neither useful nor constructive

Raoul B. (rb75) wrote :

Patch was updated (see http://bugzilla.gnome.org/show_bug.cgi?id=335093#c37), it should fix the "lagging" problems (reported by antistress and Vadim, thanks to them).

Like Pedro said, the upstream developers must review the patch first, to make sure it is bug free.... this can take some time ;-) And I think the "file->print" dialog must be modified too. Currently, if you try to print an animation, the displayed frame will be printed out... not sure this is what we want. Until a better solution is found, I wrote a small plugin that allow you to pause an animation (http://raoulito.info/eog_animagifs/eog-pause-plugin.tar.bz2), then you can print the frame you want more easily. This plugin is heavily copied from the "refresh" plugin.

LAZA (laza74) wrote :

*push*
Any news about this 'bug'?

tyle (tyle7) wrote :

Patch is committed upstream. http://git.gnome.org/cgit/eog/commit/?id=a8133caa982f783c615eec8c8aa7eb6b0e5a9a95

Upstream bug has been closed.

Changed in eog (Ubuntu):
status: Triaged → Fix Committed
Vadim Peretokin (vperetokin) wrote :

It is a miracle!

Donarsson (benjamin-schwarz) wrote :

Wow, finally my dreams come true... =D
Is there a chance to see it in the next Ubuntu release???

Sebastien Bacher (seb128) wrote :

the change will be in GNOME 2.29 and lucid

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 2.29.1-0ubuntu1

---------------
eog (2.29.1-0ubuntu1) lucid; urgency=low

  * Sync on Debian
  * debian/control.in, debian/rules:
    - build with python
  * debian/control.in,
    debian/patches/01_lpi.patch,
    debian/patches/99_autoconf.patch:
    - launchpad integration changes

  [ Robert Ancell ]
  * New upstream release: (LP: #475004)
    - Support for animated GIFs (LP: #35545)
    - Enhance statusbar translatability
    - Reverse Left/Right arrows action in RTL mode
    - Incorrect behavior when slideshow delay is set to 0 seconds
  * debian/control.in:
    - Bump Standards-Version to 3.8.3
 -- Sebastien Bacher <email address hidden> Thu, 05 Nov 2009 16:55:27 +0100

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
Ben (ben2talk) wrote :

Meantime, it's easy to install gthumb and set that to open your GIF's.

Nice to see I won't have to do this with Lucid. Thanks guys :) It's so easy to complain, but anyone using this can see that vast improvements are taking place - and most people just don't appreciate how huge this task is.

Gerhard Klünger (g-kluenger) wrote :

Maybe I misunderstood something ... but since Launchpad Janitor wrote on 2009-11-05: ... "Fix Committed → Fix Released" I expected that with my regular updates now all would work well. Alas my animated gif still won't move. On double-clicking the gif on my desktop, Eye of GNOME 2.28.1 opens, displays the gif - but without animation.

Well, my version is still 2.28.1 and not yet 2.29.1 - but what does it mean "fix released" 3 month ago? "Released" but not "delivered"? Not included in the automatic updates (Systemverwaltung > Aktualisierungsverwaltung)? What have I to do that EOG updates to V. 2.29.1?

Gruß, Gerhard

Savvas Radevic (medigeek) wrote :

> but what does it
> mean "fix released" 3 month ago? "Released" but not "delivered"?

Quote:
"This bug was fixed in the package eog - 2.29.1-0ubuntu1

eog (2.29.1-0ubuntu1) lucid; urgency=low"

"lucid" means "Future Ubuntu version 10.04" :)

Changed in eog:
status: New → Fix Released
Changed in eog:
importance: Unknown → Wishlist
Gerhard Klünger (g-kluenger) wrote :

Upgraded to 10.10 - and finally it works!

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.