Envy won't start at all in final Ubuntu 8.10 x64

Bug #292173 reported by Sami Olmari on 2008-11-01
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Envy
Undecided
Unassigned
envyng-core (Ubuntu)
Medium
Alberto Milone

Bug Description

Totally fresh installation of final Ubuntu Intrepid Ibex (8.10) 64-bit version (Ubuntu desktop), Envy won't start up at all, I get allways this same error when I try to run Envy:

sami@ninja:~$ sudo envyng -t
Traceback (most recent call last):
  File "interface.py", line 428, in <module>
    a = Interface()
  File "interface.py", line 126, in __init__
    self.abstract = abstraction.Abstraction(progress, True)
  File "/usr/lib/python2.5/site-packages/Envy/abstraction.py", line 39, in __init__
    self.driverDetails = self.hardware.selectDriver()
  File "/usr/lib/python2.5/site-packages/Envy/detection.py", line 248, in selectDriver
    if 173 in candidates['nvidia'] and 177 in candidates['nvidia']:
TypeError: list indices must be integers

I have 2 nVidia cards, 6600GT and 8600GT, envy in Hardy had work just flawlessly so I know this is new bug.

Related branches

Sami Olmari (olmari) on 2008-11-01
description: updated
Jefferson (jgmdev) wrote :

Im having the same problem only when two video cards are connected, here are my video cards:

01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)

It worked before with hardy. Also when installing the 177 driver with the 2 video cards plugged in, gdm wont start, but if i disconnect the secondary card it works. I had it working with sli but now it doesn't works.

It seems to be a serious problem. Im going to test with the 173 driver to see if it works, by installing it with the ubuntu restricted drivers installer since envyng is not working with 2 video cards connected...

Jefferson (jgmdev) wrote :

Tested with 173 driver and gdm also hangs, something that worked fine on Hardy version. I forgot to mention that I'm running the ubuntu intrepid i386 version, so the problem is not only for the 64bits version but for 32bits version also.

Maybe this is not an envy problem but ubuntu internal problem.

Alberto Milone (albertomilone) wrote :

Thanks for reporting the problem. It affects only systems with multiple cards. I'll fix it soon.

Changed in envy:
status: New → Invalid
Changed in envyng-core:
assignee: nobody → albertomilone
importance: Undecided → Medium
status: New → In Progress
Jefferson (jgmdev) wrote :

Hi for reference purpose and help here is a thread of many people having the same issue and some one posted a solution that may help on fixing the problem:

http://ubuntuforums.org/showthread.php?t=965180

Simple (jf-pirlet-kevers) wrote :

Thanks jgm,

This link helped me to have a working 177.80, with something else than the command prompt. Still no Compiz though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package envyng-core - 2.0.1ubuntu1

---------------
envyng-core (2.0.1ubuntu1) jaunty; urgency=low

  * envy/detection.py:
    - Treat candidates as a list in HardwareDetection.selectDriver()
      when more than one nvidia card is available (LP: #292173).
  * debian/rules
    - Remove DEB_PYTHON_INSTALL_ARGS_ALL for python2.6 transition (LP:#337858).

 -- Alberto Milone <email address hidden> Fri, 13 Mar 2009 11:46:20 +0100

Changed in envyng-core:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers