Envy: Unofficial ATI and NVIDIA driver installer for Ubuntu

EnvyNG problem with kernel 2.6.24-17

Reported by MountainX on 2008-05-03
2
Affects Status Importance Assigned to Milestone
Envy
Undecided
Unassigned

Bug Description

I am experiencing what seems to be a bug in EnvyNG. However, it may also be the result of me doing something wrong. Either way, I would like to solve the issue.

Here is the Ubuntu forum thread where I described my problem with EnvyNG:

http://ubuntuforums.org/showthread.php?p=4873423#post4873423

Here are my notes about exactly what happened to me:

I installed Ubuntu beta Hardy clean. I used EnvyNG to install nvidia drivers. I had to hand edit my xorg.conf to get my Twinview dual monitor setup working, but that wasn't a problem. Everything was working fine. However, Ubuntu System > Admin > Hardware Drivers (a.k.a. "jockey" I believe) always told me "No propriety drivers are in use on your system" even though they were in use and were working correctly. I just decided to live with that minor issue.

After the Hardy release, I removed older unused kernels (2.6.24-12, 2.6.24-14, 2.6.24-15) and left only 2.6.24-16. I didn't reboot immediately.
When I did reboot a couple days later, I had problems with X. There was no nvidia proprietary driver. (I suspected that might happen when I removed the older kernels. I don't know how to remove older kernel images without this messing up the nvidia restricted driver.)

At exactly the same time this happened, Ubuntu updater offered kernel 2.6.24-17. I accepted and installed the updated kernel. I figured that since I had to reinstall the nvidia drivers, I might as well do it on the latest kernel image.

However, when I tried to use EnvyNG to install the nvidia driver, it installed kernel image 2.6.24-16-386. I tried several times after several reboots and I always got the same result no matter what options I tried. I had to remove the -16 kernel after each try and go back to the -17 kernel. But then I was always without the nvidia drivers I needed for Twinview, etc.

In the end, I followed the advice at this thread (http://ubuntuforums.org/showthread.php?t=779716) and just installed nvidia drivers from nvidia's website without EnvyNG. But that's not an ideal solution nor one I want to live with for the long term.

MountainX (dave-mountain) wrote :

xorg.conf attached.

uname -r
2.6.24-17-generic

lspci -n | grep 300
01:00.0 0300: 10de:0402 (rev a1)

glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
    GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer,
    GLX_ARB_fbconfig_float, GLX_EXT_framebuffer_sRGB
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
[snip]

MountainX (dave-mountain) wrote :

The info below may not help given that I have already uninstalled everything I could and then performed a fresh install using nvidia's installer (and not EnvyNG). However, this is all that is shown in /var/log/envy-installer.log at this time.

$ cat /var/log/envy-installer.log
python pulse.py nvidia uninstall
# python pulse.py nvidia uninstall
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API not stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
EnvyNG - Version 1.1.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gimp-help-en debhelper intltool-debian libgda3-common python-gnome2-extras
  linux-headers-2.6.24-14-generic libflashsupport
  openoffice.org-hyphenation-en-us po-debconf libgdl-gnome-1-0
  gimp-help-common gettext nvidia-kernel-common dkms libtimedate-perl dpkg-dev
  libgda3-3 html2text patch linux-headers-2.6.24-14 dpatch libgdl-1-0
  libgdl-1-common
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 3 reinstalled, 0 to remove and 1 not upgraded.
Need to get 0B/13.5MB of archives.
After this operation, 0B of additional disk space will be used.
(Reading database ... 186094 files and directories currently installed.)
Preparing to replace libgl1-mesa-glx 7.0.3~rc2-1ubuntu3 (using .../libgl1-mesa-glx_7.0.3~rc2-1ubuntu3_i386.deb) ...
Unpacking replacement libgl1-mesa-glx ...
Preparing to replace libgl1-mesa-dri 7.0.3~rc2-1ubuntu3 (using .../libgl1-mesa-dri_7.0.3~rc2-1ubuntu3_i386.deb) ...
Unpacking replacement libgl1-mesa-dri ...
Preparing to replace libglu1-mesa 7.0.3~rc2-1ubuntu3 (using .../libglu1-mesa_7.0.3~rc2-1ubuntu3_i386.deb) ...
Unpacking replacement libglu1-mesa ...
Setting up libgl1-mesa-glx (7.0.3~rc2-1ubuntu3) ...
Setting up libgl1-mesa-dri (7.0.3~rc2-1ubuntu3) ...
Setting up libglu1-mesa (7.0.3~rc2-1ubuntu3) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
EnvyNG: Operation Complete

MountainX (dave-mountain) wrote :

I tried it one more time:

I logged out and used ctrl-alt-F1 to get to a virtual console. Then I issued these commands:
sudo /etc/init.d/gdm stop
sudo sh NVIDIA-Linux-x86-169.12-pkg1.run --uninstall

used nano to edit xorg.conf (changed driver from nvidia to nv)
sudo /etc/init.d/gdm start
logged back in without a problem -- but now without nvidia proprietary driver.

Then I ran EnvyNG with manual driver selection. The envy log is attached. Envy detects I'm using kernel -17 but it sets up kernel image -16.

EnvyNG: Ubuntu stock kernel detected (2.6.24-17-generic)
Setting up linux-image-2.6.24-16-386 (2.6.24-16.30)

Alberto Milone (albertomilone) wrote :

Shut down the Xserver and uninstall the driver from NVIDIA's website since it can cause serious problems with system updates.

Maybe the new restricted modules are not available yet and this doesn't depend on me. If you want a kernel independent solution you can try my new packages (which I hope to upload soon in Ubuntu).

try this:

Add these to your /etc/apt/sources.list:

deb http://ppa.launchpad.net/lrm-envy-hardy/ubuntu hardy main
deb-src http://ppa.launchpad.net/lrm-envy-hardy/ubuntu hardy main

then type:
sudo apt-get update

sudo apt-get install dkms linux-headers-$(uname -r)
sudo apt-get install nvidia-glx-new

(answer yes if it asks you to remove some packages).

Let me know how it goes.

MountainX (dave-mountain) wrote :

Everything went smoothly today went I upgraded to 2.6.24-23-generic.
Your tips seem to have resolved my issue.
The only thing I have not tested is what will happen if I delete an older image.
I have only a 200 MB boot partition. In there I now have images for:
2.6.24-23-generic
2.6.24-22-generic
2.6.24-21-generic

I will delete the oldest one. In the past, I suspect doing this may have been related to the issue I was seeing. If it is, I will report back here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers