Envy doesn't recognize GeForce 7100 / NVIDIA nForce 630i

Bug #224004 reported by Bob Kline on 2008-04-29
6
Affects Status Importance Assigned to Milestone
Envy
Low
Alberto Milone
envyng-core (Ubuntu)
Undecided
Alberto Milone
Hardy
Undecided
Unassigned
Intrepid
Undecided
Alberto Milone

Bug Description

The card ID lists in envyng don't contain any reference to the nVidia GeForce 7100 / NVIDIA nForce 630i card, even though it's on the list of supported cards at http://www.nvidia.com/object/IO_18897.html with ID 0x07E1.

This is envyng 1.1.1 on Ubuntu 8.04 (release).

Related branches

Alberto Milone (albertomilone) wrote :

If your card has that ID then it's not included in the compatibility list of the driver for Linux:
http://us.download.nvidia.com/XFree86/Linux-x86/169.12/README/appendix-a.html

1) Can you post the output of this command?
lspci -n | grep 300

2) Does EnvyNG's manual installation work with your card?

Bob Kline (bkline) wrote :

> ... not included in the compatibility list ...

Yes, but as that list says at the top, it's not "the most complete and accurate listing of supported GPUs" and and instructions are given for using the list to which I linked in my report.

> Can you post the output ...

00:10.0 0300: 10de:07e1 (rev a2)

> Does EnvyNG's manual installation work with your card?

It claims to have completed successfully, but I was still stuck in low resolution. However, when I ran the nVidia installer directly it worked. I tried digging into the envy source code to try and figure out why I succeeded when envy didn't, but I didn't have much luck. Now that I know I can get things working again I'll be happy to do any directed sleuthing that would help in tracking down the answer if you think that would be useful.

Do you want a patch for idcardlist.py?

Alberto Milone (albertomilone) wrote :

The problem is that I don't know how much I can trust that list. For example it says that these cards are supported:
GeForce 9800 GX2
GeForce 9800 GTX
GeForce 9600 GT
GeForce 9500M GS

However such cards are supported only by the beta driver (and not by 169.12). I'll (carefully) update the list of supported cards in EnvyNG.

As regards your problems with EnvyNG, I think they depend on the fact that (because of a misunderstanding) EnvyNG is using Ubuntu's packages instead of using its own packages of the drivers. This will be fixed ASAP. Have a look at this bugreport:
https://bugs.launchpad.net/ubuntu/+source/envyng-core/+bug/221304

Changed in envy:
assignee: nobody → albertomilone
importance: Undecided → Low
Changed in envyng-core:
assignee: nobody → albertomilone
status: New → In Progress
Changed in envy:
status: New → In Progress
Bob Kline (bkline) wrote :

OK, thanks. Here's a patch for the 7100, which I can confirm works with 169.12.

Alberto Milone (albertomilone) wrote :

I have pushed the update so as to add the support for a few more cards.

Thanks for reporting

Bob Kline (bkline) wrote :

You're most welcome; and thanks for the very useful tool.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in envyng-core:
status: New → Fix Committed
Bob Kline (bkline) wrote :

I tried to test, but I guess I don't know enough about the Ubuntu repository thing. I went into synaptic and turned on hardy-proposed (and hit "Reload"), then removed and reinstalled envyng-gtk. Then I ran the NVIDIA...run script with the --uninstall option. Then I exited gdm and ran envyng -t and got the same error message (card not supported). I had assumed that with the hardy-proposed repository enabled the package manager would find and pick up the later version, but apparently this is a more subtle system than that. Any tips on what steps I left out?

Also, I assume that after I've finished testing I'll want to disable hardy-proposed. Any gotchas I should look out for in that process?

Alberto Milone (albertomilone) wrote :

Bob:
it is true that the new envyng-core was uploaded today however it will be available tomorrow. Keep an eye on my blog for further details.

Bob Kline (bkline) wrote :

OK, I'll watch the blog [1] and hold off until you give the word. Are the steps to test this as described in my previous comment correct? Or do I need to jump through some additional hoops to entice the package manager to get the latest version from hardy-proposed, instead of just the first matching repository it finds in /etc/apt/sources.list? I've browsed through https://help.ubuntu.com/community/Repositories but if this subtlety is covered there I missed it. If there's a better source I should be reading I'd be grateful for the link.

[1] You're probably aware of the fact that Google brings up a link to a stale version of your blog at wordpress as its first hit, right?

Cristian Asenjo (apu2009) wrote :

I read on PlanetUbuntu that I'd be able to help testing this, so here's my report =)

Used EnvyNG (yes/no): Yes
Worked with Ubuntu’s default restricted modules (yes/no): No
Graphic card model: nVidia 9500M GS
Problem (solved/otherwise describe the problem): Card wasn't detected (I'm aware that the new beta driver supports my card though)

Output of console:
EnvyNG - Version 1.1.1
Ubuntu Hardy 32bit
Traceback (most recent call last):
  File "pulse.py", line 87, in <module>
    autoChoice(sys.argv[1])
  File "pulse.py", line 16, in autoChoice
    objects.nvidiainstallg(data1)
  File "/usr/lib/python2.5/site-packages/Envy/objects.py", line 75, in nvidiainstallg
    task.drivertype()#latest, middle, oldest driver
  File "/usr/lib/python2.5/site-packages/Envy/classes.py", line 792, in drivertype
    raise Exception(error)
Exception: EnvyNG ERROR: Envy does not recognise your card as compatible with any version of the driver.this might happen because either your card is not supported by the driver or Envy's hardwaredetection failed. You can try the manual installation at your risk.

Alberto Milone (albertomilone) wrote :

Cristian: your card is not supported by driver 169.12. The next release of the NVIDIA driver will support it.

Martin Pitt (pitti) wrote :

envyng-core copied to hardy-updates and intrepid.

Changed in envyng-core:
status: In Progress → Fix Released
status: Fix Committed → Fix Released
Bob Kline (bkline) wrote :

Upgraded the machine to Intrepid and the problem has been fixed; I no longer have to rebuild the proprietary driver by hand every time the kernel is upgraded. Thanks.

Changed in envy:
status: In Progress → Invalid
Bob Kline (bkline) wrote :

"Invalid" seems a puzzling status for a bug that was fixed years ago.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers