Crashes on start with pyclutter > 0.8

Reported by Julian Aloofi on 2009-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Entertainer Media Center
Critical
Matt Layman
Nominated for Entertainer-0.4 by Rhett Trappman
Nominated for Entertainer-0.5 by Rhett Trappman

Bug Description

When starting entertainer using a version of pyclutter > 0.8 it does not start.
The error occurs because clutter.Label() was replaced with clutter.Text() in later versions of pyclutter.
See https://bugzilla.redhat.com/show_bug.cgi?id=526035 for the original bug report.

Linux Distribution: Fedora Rawhide (Fedora 12)
Processor: I can confirm it on 32-bit
Python Version: 2.6.2, pyclutter version 0.9.2
Python Traceback: see attachment

Related branches

Julian Aloofi (nailuj24) wrote :
Matt Layman (mblayman) wrote :

Julian, thanks for the report. I was well aware that Entertainer would break with clutter > 0.8 because of API changes, but I was too lazy to file the bug since the currently released version primarily targeted Ubuntu 9.04 users. I'm pretty sure that this will be a problem in Karmic Koala and since it looks like 0.5 will actually release some time in the Karmic lifecycle, we will have to address the change before then. Thankfully, after that, the 1.* series of clutter will provide some API stability so we don't have to do this again (this process has happened from 0.4 -> 0.6 -> 0.8 and now 0.8 -> 1.0)

Thanks for reporting from Fedora! Entertainer has always been Ubuntu/Debian focused simply because that's what its developers use, but we would love to be more distro agnostic. After this bug is fixed, please let us know if you have more issues on Fedora as it would be a great help.

Paul, if you get a chance to fix up the clutter stuff from API changes before I get to it, please feel free to reassign to yourself.

Changed in entertainer:
assignee: nobody → Matt Layman (laymansterms)
importance: Undecided → Critical
milestone: none → entertainer-0.5
status: New → Triaged
Matt Layman (mblayman) on 2009-11-07
Changed in entertainer:
status: Triaged → In Progress
Julian Aloofi (nailuj24) wrote :

Due to some complications we have to release the broken entertainer in the Fedora 12 stable release. If you're desperately looking for bugs to fix, it would be very kind of you to get this one done as soon as you can :)
I'll start working on a patch myself tomorrow, but it would be cool if you can get this fixed, as I'm not a highly gifted Python hacker.

Greetings, and many thanks in advance :)
Julian

Jillian,
I know absolutely nothing about writing code.I am a Windows idiot who is
used to nothing but gui's. I wish I could help, but this is way beyond my
depth.
Sincerely, Thom Edmundson
On Mon, Nov 16, 2009 at 2:12 PM, Julian Aloofi <email address hidden>wrote:

> Due to some complications we have to release the broken entertainer in the
> Fedora 12 stable release. If you're desperately looking for bugs to fix, it
> would be very kind of you to get this one done as soon as you can :)
> I'll start working on a patch myself tomorrow, but it would be cool if you
> can get this fixed, as I'm not a highly gifted Python hacker.
>
> Greetings, and many thanks in advance :)
> Julian
>
>
> Crashes on start with pyclutter > 0.8
> https://bugs.launchpad.net/bugs/441515
> You received this bug notification because you are subscribed to
> Entertainer Media Center.
>
> Status in Entertainer: In Progress
>
> Bug description:
> When starting entertainer using a version of pyclutter > 0.8 it does not
> start.
> The error occurs because clutter.Label() was replaced with clutter.Text()
> in later versions of pyclutter.
> See https://bugzilla.redhat.com/show_bug.cgi?id=526035 for the original
> bug report.
>
> Linux Distribution: Fedora Rawhide (Fedora 12)
> Processor: I can confirm it on 32-bit
> Python Version: 2.6.2, pyclutter version 0.9.2
> Python Traceback: see attachment
>

Matt Layman (mblayman) wrote :

Julian, we've had some recent work to help fix some of these problems. Unfortunately, a simple patch won't resolve the issues because of the amount of API changes. Francesco Marella has some fixes that he has proposed for merging into the main development branch, but we haven't had time to review it because Paul is at the Ubuntu Developer Summit and I'm busy with school work. We also have to package python-cluttergtk for Debian because it's not packaged. This may not affect Fedora, but since all of our developers on Ubuntu, it impacts us.

This bug is being worked, albeit slowly. Thanks for your patience.

Julian Aloofi (nailuj24) wrote :

Dear Matt, thanks for commenting on this, dear Thomas thanks for offering your help,
I successfully merged Francesco's future-fixes branch to the entertainer/future branch and got entertainer running again with pyclutter 0.9, so at least this seems to work. Thanks for your help so far, and good luck with further development!

Matt Layman (mblayman) on 2010-01-23
Changed in entertainer:
status: In Progress → Fix Committed
Julian Aloofi (nailuj24) wrote :

I take this is fixed in trunk now then? Excellent, great work guys!

Matt Layman (mblayman) on 2010-04-11
Changed in entertainer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.