[SRU] Does not work on 64bit properly

Bug #262235 reported by Vadim Peretokin on 2008-08-28
18
Affects Status Importance Assigned to Milestone
Clutter
Fix Released
Medium
Entertainer Media Center
High
Paul Hummer
pyclutter (Ubuntu)
Undecided
Unassigned
Hardy
High
Unassigned

Bug Description

clutter.Color(R,G,B,A) on 64bit results in values of 0,0,0,255, making everything black. Projects that rely on this package fail to work on 64bit.
This bug was fixed in the 0.6.3 release of pyclutter. Projects that use python clutter fail to work completely, everything is just black. For example, Entertainer (https://bugs.launchpad.net/entertainer/+bug/260504)

SRU: I've got a patch from git and prepare for hardy.

Related branches

description: updated
description: updated
Paul Hummer (rockstar) wrote :

I'd like to see this fixed, as Entertainer doesn't yet work with clutter 0.8, and I can't continue to work with this bug in 0.6. I can get this into my PPA, but I'm not familiar with the distro processes to get it released. If a distro person could assist, I could fix this bug.

Paul Hummer (rockstar) wrote :

I have a fixed package in my PPA that I've tested and found that it fixes the problem. However, I'd like this to actually get this into Hardy (it being the LTS), but I'm unsure of how to do this. Can I solicit some distro team help?

Matt Layman (mblayman) wrote :

Even though I don't have a 64-bit processor, I've answered this problem on IRC and through lp questions enough times to know that it is true. Marking as high because it wipes out an entire range of potential users for Entertainer. According to an upstream comment from Emmanuele Bassi, this was fixed and released in 0.6.3

Changed in entertainer:
importance: Undecided → High
status: New → Confirmed
Changed in clutter:
status: Unknown → Fix Released

Marking as only affecting hardy pyclutter (intrepid's having this removed, or updating this, and entertainer isn't where the bug is)

Changed in pyclutter:
status: New → Won't Fix
Changed in entertainer:
status: Confirmed → Invalid
Changed in pyclutter:
importance: Undecided → High
status: New → Confirmed
Matt Layman (mblayman) wrote :

Entertainer may not be where the bug is in code, but it is an upstream bug that we want to watch because, without the fix, our 64 bit users can't use our application. The bug description still accurately describes Entertainer's behavior on 64 bit platforms in Hardy.

Changed in entertainer:
status: Invalid → Confirmed
Paul Hummer (rockstar) wrote :

Well, looks like this bug didn't get touched long enough for Entertainer to no longer support clutter 0.6.

Changed in entertainer:
assignee: nobody → rockstar
status: Confirmed → Invalid
Artur Rona (ari-tczew) on 2010-03-27
Changed in pyclutter (Ubuntu Hardy):
status: Confirmed → New
tags: added: patch
tags: added: hardy
Artur Rona (ari-tczew) on 2010-03-27
summary: - Does not work on 64bit properly
+ [SRU] Does not work on 64bit properly
description: updated
tags: added: sru
John Dong (jdong) wrote :

Hi Artur,

The patch for this bug looks good, but it's SRU practice to not add a patchsys to packages not using a patchsys. Please revise your branch and directly apply the patch. Once this is done, consider this an ACK from the SRU team.

John Dong (jdong) wrote :

New patch looks good. ACK -- proceed with sponsorship and upload!

Benjamin Drung (bdrung) wrote :

Broken date:
LINE: -- Artur Rona <email address hidden> Sat, Sun, 28 Mar 2010 23:57:19 +0200

Benjamin Drung (bdrung) wrote :

uploaded

Changed in pyclutter (Ubuntu Hardy):
status: New → Fix Committed

Accepted pyclutter into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Artur Rona (ari-tczew) wrote :

It works!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyclutter - 0.6.0-1ubuntu0.1

---------------
pyclutter (0.6.0-1ubuntu0.1) hardy-proposed; urgency=low

  * clutter/clutter-color.override:
    - Fix color problem on 64bit. (LP: #262235)
 -- Artur Rona <email address hidden> Fri, 02 Apr 2010 18:00:07 +0200

Changed in pyclutter (Ubuntu Hardy):
status: Fix Committed → Fix Released
Changed in clutter:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.