Encrypted Filesystem for Linux

Complete hang on aclocal

Reported by Felipe Contreras on 2008-03-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
EncFS
Fix Released
Undecided
Valient Gough

Bug Description

When I try to run ./autoregen.sh in a encrypted directory the filesystem hangs and I'm not able to use it anymore.

I'm attaching an strace with the hang, apparently it hangs when trying to read from a pipe.

Felipe Contreras (felipec) wrote :
Valient Gough (vgough) wrote :

I'm not able to reproduce this. Please provide additional data:

Encfs version, filesystem type (output of 'encfsctl info crypt-raw').

Changed in encfs:
status: New → Incomplete
Tomas Hoger (thoger) wrote :

It seems I have reported the same issue to the Red Hat Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=440483

Minimal test case that reproduces the issue for me is attached in that bug.

Valient Gough (vgough) wrote :

Thanks. Sounds like a problem with flock support. This has caused problems with other programs which uses flock. As per a discussion with Miklos, lock support has been removed from encfs development branch. New release needed.

Changed in encfs:
assignee: nobody → vgough
status: Incomplete → In Progress
Valient Gough (vgough) wrote :

fixed in 1.4.2 release

Changed in encfs:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.