Encrypted Filesystem for Linux

Can't Delete Folder - Corrupted FS?

Reported by Philip Paquette on 2007-11-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
EncFS
Fix Released
Undecided
rosa maria
encfs (Ubuntu)
Undecided
rosa maria

Bug Description

Binary package hint: encfs

Steps to reproduce:

> cd ~
> encfs ~/.test-encfs ~/test-encfs
Enter password: **********
> cd ~/test-encfs
> mkdir s.com
> mkdir s1.com
> mkdir s2.com
> cd s1.com
> mkdir f0
> cd f0
> touch file0.txt
> touch file2.txt
> cd ~/test-encfs/s2.com
> mkdir f0
> cd f0
> touch file1.txt
> touch file3.txt
> cd ~/test-encfs
> mv s1.com/* s.com/
> mv s2.com/* s.com/
ERROR -- mv: cannot move `s2.com/f0' to a subdirectory of itself, `s.com/f0'

NOW:
> ~/test-encfs$ ls -lhA s.com/f0/
total 0
-rw-r--r-- 1 philip philip 0 2007-11-05 10:30 file0.txt
-rw-r--r-- 1 philip philip 0 2007-11-05 10:30 file2.txt

==> file1.txt and file3.txt were not copied

> ls -lhA s2.com/f0/
total 0
> rm -R s2.com/
rm: cannot remove directory `s2.com//f0': Directory not empty
> cd s2.com/
> rm -R f0/
rm: cannot remove directory `f0/': Directory not empty
> ls -lhA f0/
total 0
> rm -R f0/*
rm: cannot remove `f0/*': No such file or directory
> sudo rm -R f0/
rm: cannot remove directory `f0/': Permission denied
> sudo chmod 777 f0/
chmod: cannot access `f0/': Permission denied

Using Gutsy, encfs 1.3.2-1-1

Philip Paquette (shooters) wrote :

Basically, create structure like this

s.com
s1.com
   |--- f0
         |--- file0.txt
         |--- file2.txt
s2.com
   |--- f0
         |--- file1.txt
         |--- file3.txt

mv all s1.com to s.com
mv all s2.com to s.com
now s2.com/f0 can't be deleted.

Philip Paquette (shooters) wrote :

Workaround:

> ls -il
to find the inode number of the folder
then navigate to the encrypted directory on the underlying fs (reiserfs in my case) and delete the encrypted directory...

The bug is caused because encfs doesn't see any files with "f0", but the files are actually there in the encrypted folder on the underlying fs...

Valient Gough (vgough) wrote :

Thanks for the test case. Fix has been checked in.

Changed in encfs:
status: New → Fix Committed
status: New → Fix Committed
Valient Gough (vgough) wrote :

Fix included in 1.4.0 release.

Changed in encfs:
status: Fix Committed → Fix Released
Changed in encfs:
status: Fix Committed → Fix Released
NoBugs! (luke32j) wrote :

I was seeing what may be the same problem, on up-to-date 13.10 on new computer.
After resume, the mouse wasn't moving unless I clicked the trackpad down, and pressing right click a couple times created a new folder on desktop by accident. When I deleted the folder, it showed up as just a file on the desktop, then I went to delete it again, and it gave an error message.

Changed in encfs:
assignee: nobody → rosa maria (rprosamaria383)
Changed in encfs (Ubuntu):
assignee: nobody → rosa maria (rprosamaria383)
George T (lives9) wrote :

I confirm NoBugs! (luke32j) statement. This bug shows on 13.10 again. Please reopen the bug. Also ask me if I can provide some additional information regarding the issue (was unable to reproduce this bug so far, it happens on its own occasionally).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions