Update be2net driver in 12.04

Bug #921793 reported by Ronald McCollam on 2012-01-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Emulex project
High
Chris Van Hoof
linux (Ubuntu)
High
Tim Gardner
Precise
High
Tim Gardner

Bug Description

Request to update the be2net driver in Precise via l-b-m (or cherry picks if possible) to the latest code available in 3.3

Ronald McCollam (fader) on 2012-01-25
description: updated
visibility: private → public
Chris Van Hoof (vanhoof) on 2012-03-29
Changed in emulex:
assignee: nobody → Chris Van Hoof (vanhoof)
status: New → Confirmed
summary: - Emulex driver locks up on 11.10
+ Update be2net driver in 12.04
Changed in emulex:
importance: Undecided → High
Chris Van Hoof (vanhoof) on 2012-03-29
description: updated
Changed in linux (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
Tim Gardner (timg-tpi) on 2012-03-29
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) wrote :

Applied these upstream cherry picks (except for the 2 that are VLAN related and commented out):

68aad78c5023b8aa82da99b47f9d8cf40e8ca453 sweep the floors and convert some .get_drvinfo routines to strlcpy
30128031d71741ef7d0e32c345e3bf02aa8a0704 be2net: init (vf)_if_handle/vf_pmac_id to handle failure scenarios
72f02485626b3e71955e54d227ede1b54021d571 be2net: stop checking the UE registers after an EEH error
434b3648e9a58600cea5f3a1a0a7a89048e4df61 be2net: don't log more than one error on detecting EEH/UE errors
6589ade019dcab245d3bb847370f855b56cdf6ad be2net: stop issuing FW cmds if any cmd times out
293c4a7d9b95d0beeb5df03c14bd35bc21f9e6f2 be2net: Fix TX queue create for Lancer
de49bd5a447887fa630c54bb2769102d50fbe40a be2net: add register dump feature for Lancer
af5875bdfed02a10a0c76bbd547753fea7979244 be2net: Add EEPROM dump feature for Lancer
5d5adb93d0efca8b47cc3e649a41ba650ff3d270 be2net: Fix VLAN promiscous mode for Lancer
daad6167d97b43cfc448cfe698784730b53ed3d6 be2net: Use V1 query link status command for lancer
590c391dd362479b27a67c8d797ce348c5798b93 be2net: Move to new SR-IOV implementation in Lancer
3bb62f4f95ba004048bafb460179b5db33aff787 be2net: Fix error recovery paths
d8110f62c020ebc49108de57510a1482bfcbe86a be2net: Add error handling for Lancer
65f8584e253f4676c8b39e976a10e918ec984b7c be2net: Use new hash key
e9008ee99c77207b2f6aee67e5f849b1e1400a11 be2net: Fix non utilization of RX queues
6626873980475f303367f7b709f4703b571cf854 be2net: netpoll support
#8e586137e6b63af1e881b328466ab5ffbe562510 net: make vlan ndo_vlan_rx_[add/kill]_vid return error value
02fe7027961969a052fbbe453304f329d4e9735a be2net: update some counters to display via ethtool
1ded132d4c3442aa3a619c94c245d7b5e0eb9731 be2net: workaround to fix a bug in BE
110b82bc6265a48c1a0bf198109bed325ed055e2 be2net: fix ethtool ringparam reporting
11ac75ed1eb9d8f5ff067fa9a82ebf5075989281 be2net: refactor/cleanup vf configuration code
ecedb6ae908e3a8a19942da921a3ffb1c5a0d6ab be2net: Add support for Skyhawk cards
93c86700c0ae3a1407b979073f423e62e29372c1 be2net: Fix INTx processing for Lancer
#80817cbf5ac13da76f3ee2b9259f26c09b385e84 be2net: fix be_vlan_add/rem_vid
94f434c2055db5fe20f10d4e0ec50ab395e1f62b be2net: fix range check for set_qos for a VF
b236916a68d923acff15787b5439d7d684c17ae5 be2net: query link status in be_open()
e5686ad82ca2aeed7a8f24ffca115c0b7478dec9 netdev: make net_device_ops const
df505eb804d5221c3164ebecd1286cb7fc7f49ba be2net: create RSS rings even in multi-channel configs
786f528119722f564a22ad953411374e06116333 ethtool: Null-terminate filename passed to ethtool_ops::flash_device

Chris Van Hoof (vanhoof) wrote :

Hi Tim -- I have received feedback from Emulex using your test kernels and so far everything is looking good, they'll have a more detailed update shortly.

Tim Gardner (timg-tpi) on 2012-03-30
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Chris Van Hoof (vanhoof) wrote :

Tim -- Direct testing by Emulex's development team has proved successful, they are however interested in backporting bits landing in 3.4, and I let them know that we can open that conversation once the 3.4 tree matures if needed.

--chris

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package linux - 3.2.0-22.35

---------------
linux (3.2.0-22.35) precise; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: hotkey quirks for various Zeptro Znote and Fujitsu Amilo
    laptops"
  * SAUCE: (no-up) elide some ioctl warnings which are known benign
    - LP: #972355

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (drop after 3.4) Quirk for enabling backlight hotkeys on Samsung
    N150P
    - LP: #875893

  [ Colin Ian King ]

  * SAUCE: PCI: Allow pcie_aspm=force to work even when FADT indicates it
    is unsupported
    - LP: #962038

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Kees Cook ]

  * SAUCE: SECCOMP: audit: always report seccomp violations
  * SAUCE: SECCOMP: adjust prctl constant

  [ Leann Ogasawara ]

  * [Config] Enable CONFIG_USBIP_CORE=m
    - LP: #900384
  * Rebase to v3.2.14
  * [Config] Updateconfigs after rebase to v3.2.14

  [ Stefan Bader ]

  * d-i: Fix module name for dm-raid45
    - LP: #969248

  [ Tim Gardner ]

  * SAUCE: remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * Revert "sched: tg->se->load should be initialised to tg->shares"
  * toshiba_acpi: make one-bit bitfields unsigned
    - LP: #810015
  * ACPI: EC: Add ec_get_handle()
    - LP: #810015
  * toshiba_acpi: Support alternate hotkey interfaces
    - LP: #810015
  * toshiba_acpi: Support additional hotkey scancodes
    - LP: #810015
  * toshiba_acpi: Refuse to load on machines with buggy INFO
    implementations
    - LP: #810015
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * sweep the floors and convert some .get_drvinfo routines to strlcpy
    - LP: #921793
  * be2net: init (vf)_if_handle/vf_pmac_id to handle failure scenarios
    - LP: #921793
  * be2net: stop checking the UE registers after an EEH error
    - LP: #921793
  * be2net: don't log more than one error on detecting EEH/UE errors
    - LP: #921793
  * be2net: stop issuing FW cmds if any cmd times out
    - LP: #921793
  * be2net: Fix TX queue create for Lancer
    - LP: #921793
  * be2net: add register dump feature for Lancer
    - LP: #921793
  * be2net: Add EEPROM dump feature for Lancer
    - LP: #921793
  * be2net: Fix VLAN promiscous mode for Lancer
    - LP: #921793
  * be2net: Use V1 query link status command for lancer
    - LP: #921793
  * be2net: Move to new SR-IOV implementation in Lancer
    - LP: #921793
  * be2net: Fix error recovery paths
    - LP: #921793
  * be2net: Add error handling for Lancer
    - LP: #921793
  * be2net: Use new hash key
    - LP: #921793
  * be2net: Fix non utilization of RX queues
    - LP: #921793
  * be2net: netpoll support
    - LP: #921793
  * be2net: update some counters to display via ethtool
    - LP: #921793
  * be2net: workaround to fix a bug in BE
    - LP: #921793
  * be2net: fix ethtool ringparam reporting
    - LP: #921793
  * be2net: refactor/cleanup vf configuration code
    - LP: #921793
...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Chris Van Hoof (vanhoof) on 2012-04-03
Changed in emulex:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers