Chat app, and Telepathy user interface

empathy crashed with SIGSEGV in _int_free()

Reported by Sarrvesh on 2012-03-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Critical
empathy (Ubuntu)
Medium
Unassigned

Bug Description

Tried configuring empathy for my gmail id. I was able to enter my gmail username and password. When I pressed "continue", empathy crashed. When I restarted empathy, it logged into my gmail account and displayed all the contacts who were online. After about 2 seconds, it crashed once again.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: empathy 3.3.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Fri Mar 2 21:56:09 2012
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: empathy
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb4f0360e: cmp 0xc(%eax),%ebp
 PC (0xb4f0360e) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%ebp" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_free () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libpango-1.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libpango-1.0.so.0
Title: empathy crashed with SIGSEGV in g_free()
UpgradeStatus: Upgraded to precise on 2012-03-02 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Sarrvesh (sarrfriend) wrote :

StacktraceTop:
 _int_free (av=0xb5030440, p=0xa4c49c8, have_lock=0) at malloc.c:4085
 standard_free (mem=0xa4c49d0) at /build/buildd/glib2.0-2.31.18/./glib/gmem.c:98
 g_free (mem=0xa4c49d0) at /build/buildd/glib2.0-2.31.18/./glib/gmem.c:252
 pango_layout_clear_lines (layout=0xa373b58) at /build/buildd/pango1.0-1.29.5/./pango/pango-layout.c:2799
 pango_layout_finalize (object=0xa373b58) at /build/buildd/pango1.0-1.29.5/./pango/pango-layout.c:231

Changed in empathy (Ubuntu):
importance: Undecided → Medium
summary: - empathy crashed with SIGSEGV in g_free()
+ empathy crashed with SIGSEGV in _int_free()
tags: removed: need-i386-retrace
Sarrvesh (sarrfriend) on 2012-03-02
description: updated
Bilal Shahid (s9iper1) wrote :

thanks for the bug report.
the stacktrace has enough info and we have debug symbols thats helps us to figure out the problem. so thanks again.
i am reporting this bug to upstream you subscribe to that and make comments.

visibility: private → public
Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in empathy:
importance: Unknown → Critical
status: Unknown → Incomplete
Bilal Shahid (s9iper1) wrote :

Could you please reproduce in valgrind and attach the log?

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Sarrvesh (sarrfriend) wrote :

Hi Bilal, I have never used Valgrind before. I tried installing vallgrind and ran the command "valgrind empathy". Valgrind then spewed out a huge list of things. Do you want to attach those things to this bug?

Bilal Shahid (s9iper1) wrote :
Sarrvesh (sarrfriend) wrote :

Hi Bilal,
   I have attached the log obtained through valgrind. Though empathy got killed, I am not sure if it was due to the same issue as this bug.

Changed in empathy:
status: Incomplete → Expired
Bilal Shahid (s9iper1) wrote :

please see the comment on upstream bug in which he has mentioned me tcomment 5 and answer him

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.