Please include support for RFC6189 (ZRTP)

Bug #816163 reported by Anand Kumria on 2011-07-25
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Empathy
Expired
Wishlist
empathy (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi,

It would be great if empathy support RFC6189 (ZRTP) across the various protocols which support it.

Typically SIP and XMPP/Jingle since they both use RTP; just as having OTR for messaging is useful, having ZRTP is useful for confidentially of voice communications as well.

Thanks,
Anand

Bilal Shahid (s9iper1) wrote :

thanks for the bug report
this is known by the developers and they are aware of it see this upstream
https://bugzilla.gnome.org/show_bug.cgi?id=589778

Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in empathy:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Andreas Moog (ampelbein) on 2012-01-21
Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Mozaic (mozaic) wrote :

http://xmpp.org/extensions/xep-0167.html#security
XEP-0167: Jingle RTP Sessions
"In order to secure the data stream, implementations SHOULD use encryption methods appropriate to the RTP data transport."
It's a Jitsi feature: https://jitsi.org/index.php/Documentation/ZrtpFAQ#faqFuss

Mozaic (mozaic) wrote :

Empathy is not in list of VOIP from Telecomix, why ??
Because emapthy don't use a secure connexion between client to client (like ZRTP)
source: http://cyphercat.eu/logiciels#VOIP

Changed in empathy:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.