Import pidgin logs

Bug #388035 reported by Jorge Castro on 2009-06-16
186
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Undecided
Unassigned
Telepathy Logger
Invalid
Wishlist
telepathy-logger (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Fahad

Bug Description

Binary package hint: empathy

It would be nice to have a migration path for those people who have years worth of logs in pidgin and want to move to empathy. There is an upstream bug but the git branch looks old, someone should have a look.

Changed in empathy:
status: Unknown → New
Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in empathy:
status: New → Invalid

Reassigning upstream bug since it was marked as a duplicate.

Changed in empathy:
status: Invalid → Unknown
Changed in empathy:
status: Unknown → Confirmed
A. Leon (aleon05) wrote :

I want this feature also! Please make it real.

enb (elitenoobboy) wrote :

Considering that empathy is now default in ubuntu instead of pidgin, this bug really should be fixed sooner rather than later, as it will keep most people from switching over.

Gavin Hamill (gdh) wrote :

Disappointing that no migration for logs was included for karmic :(

mzenzes (mzenzes) wrote :

second that...

A. Leon (aleon05) wrote :

As I recall good programs like Firefox, Chrome, Internet Explorer, Thunderbird, so on include good migration procedures. Please take not of this...

Can you imagine a message application (for example an email application) that do not migrate the history of your old messages ? No, I can not imagine that. How can Ubuntu has accepted this? For me, this is a showstopper. I uninstalled empathy and I've moved back to pidgin.

mzenzes (mzenzes) wrote :

Mayne this can help:

http://jalli.berlios.de/

Haven't tried it yet, since I will stay with Pidgin

Here is an discussion about not importing the log-files:

https://bugzilla.gnome.org/show_bug.cgi?id=579159

Original bug report: https://bugzilla.gnome.org/show_bug.cgi?id=579159

Some work has been done in Empathy to implement a read-only store for Pidgin. This should now be done in tp-logger.

Omer Akram (om26er) wrote :

The upstream bug report was marked invalid with a comment that its a bug in telepathy-logger https://bugs.freedesktop.org/show_bug.cgi?id=26907. We dont ship telepathy logger in ubuntu so should we mark this bug invalid?

Changed in empathy (Ubuntu):
status: Triaged → Incomplete

I just moved to lucid. This issue is the only thing preventing me from moving to telepathy also. Please create a possibility to import Pidgin/Purple logs.

Brian J. Cohen (brianjcohen) wrote :

It looks like this bug has been sent to the dungeon. I agree with the other commenters -- I'd be happy to move to Empathy, but I have YEARS of Gaim/Pidgin/Purple logs that would need to be carried over.

Brian J. Cohen (brianjcohen) wrote :

Update: the bug over at GNOME has been updated to indicate that this has actually been done, in tp-logger. Presumably this will make it downstream to Ubuntu after some time.

Changed in empathy:
status: Confirmed → Invalid
Omer Akram (om26er) wrote :

moved to telepathy logger

Changed in empathy:
importance: Unknown → Undecided
status: Invalid → New
status: New → Invalid
affects: empathy (Ubuntu) → telepathy-logger (Ubuntu)
Changed in telepathy-logger (Ubuntu):
status: Incomplete → Triaged
Changed in telepathy-logger:
importance: Unknown → Wishlist
status: Unknown → Confirmed
indy (davide-ricci82) wrote :

Currently,
http://jalli.berlios.de/
allows to import the logs one contact by one contact.
There is some bug that imports all the MSN logs as said by the other speaker (even your answers).
Moreover, it imports only the part of facebook logs written by you and not by the other speaker.

Changed in telepathy-logger:
importance: Wishlist → Unknown
status: Confirmed → Unknown
Changed in telepathy-logger:
importance: Unknown → Wishlist
Changed in telepathy-logger:
status: Unknown → Invalid
Sam Brightman (sambrightman) wrote :

What is the real status of this bug, why is bug watch updated messing with it so much and why is it invalid?

Toby Haynes (thaynes) wrote :

Telepathy provides a read-only Pidgin Log store in the 0.2.x series. No mechanism to convert the Pidgin logs to Telepathy logs is going to be built.

Fartash (fartash-faghri) wrote :

Where should we check to see when empathy is going to use this feature in telepathy?

indy (davide-ricci82) wrote :

Telepathy provides a read-only Pidgin Log store, but it groups the logs by user destroying the discussion:

Discussion with User 1 at 12:00:
User 1: Hello, how are you?
User 1: Really? At home? I believed you were on holydays. How's your sister

Discussion with user 2 at 12:01:
User 2: Fine, thank you, I am at home.
User 2: She's fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.