Chat app, and Telepathy user interface

Setting status to 'Hidden' changes status to 'Busy' instead

Reported by Philip Wyett on 2008-08-12
984
This bug affects 197 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Low
Unassigned
telepathy-gabble
Fix Released
Wishlist
empathy (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
telepathy-gabble (Ubuntu)
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
telepathy-haze (Ubuntu)
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: empathy

Using MSN, Yahoo and Jabber. Setting 'Hidden' sets your status as 'Busy'.

Reproduce:

 * Run Empathy. (your preferred method).
 * Use MSN (haze), Yahoo or Jabber.
 * Try to set status to 'Hidden' from drop down menu.

What happens:

 * Status is set to 'Busy'.

What should happen:

 * Status should be set to 'Hidden'.

Sebastien Bacher (seb128) wrote :

confirming the issue using the current intrepid version

Changed in empathy:
importance: Undecided → Low
status: New → Confirmed
Mike (mnorwood154-gmail) wrote :

Same is true using the AIM protocol on Hardy Heron.

Setting status to 'hidden' results in the users status being seen by other users as 'Busy' instead of only appearing to be offline.

Dereck Wonnacott (dereck) wrote :

Hidden seemed to work on my gtalk account, but MSN was marked Busy indeed.

Changed in empathy:
status: Confirmed → Triaged
will.ph (will.ph) wrote :

Confirmed in Intrepid with a gtalk and ym account.

will.ph (will.ph) wrote :

Update:
Hidden status works in MSN, but not in gtalk or YM.

Steps to duplicate the issue:
Launch Empathy.
Wait for it to connect to MSN, gtalk and YM.
Set status to Hidden. If connected to MSN, it will stay Hidden.
Click on Edit then go to Personal Information.
If Account selected is MSN, status says Hidden.
Change account to gtalk or YM, the status will say Busy.

summary: - Empathy. Setting 'Hidden' sets you as 'Busy'.
+ Setting status to 'Hidden' changes status to 'Busy' instead
Nicolò Chieffo (yelo3) on 2009-06-15
Changed in empathy (Ubuntu):
status: Triaged → Invalid
Changed in empathy:
status: Unknown → New
Laurent Bigonville (bigon) wrote :

Looks like empathy related according to cassidy

Changed in telepathy-haze (Ubuntu):
status: New → Invalid
Changed in telepathy-gabble (Ubuntu):
status: New → Invalid
Changed in empathy (Ubuntu):
status: Invalid → Confirmed
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Michael Janos (spikeybadooks) wrote :

confirmed using AIM on Jaunty

daigo (chr-baart) wrote :

Also confirmed on Jaunty using ICQ - plus: When I first click "Hidden", status is set to "Busy" - second click and the status shown above the contact list changes to "Hidden", but remains "Busy" in the panel.

brownknight (ramilclarin) wrote :

Also affects me. Using YM account - selecting Status Hidden sets status to Busy.

Willi (strangeq) wrote :

Why is the importance set to low? It is a very visible and irritating bug most users are sure to encounter.
If Empathy is going to be the standard IM program in Karmic, this ought to be fixed first. If not, expect some very annoyed users.

I use the lasted Karmic.

This is a very bad problem. As far as I know, Empathy is the only way I can use cam and voice with google talk in linux. I usually just use the gmail.com in a web browser to chat and select to be invisable, but I open Empathy to voice or video chat. As soon as I open Empathy I see this message on gmail.com's chat:

"Oops! You are not invisible because you're logged into Google Talk from another client, device, or location that doesn't support invisibility."

Google talk's API is completely open source. (http://code.google.com/apis/talk/)
Why is MSN's hidden/invisible supported but not google talk?

Thanks for all the hard work on Empathy. I am astonish by the features that do work. (cam/voice really great)

When it come to Google Talk, telepathy-gabble seems to be the problem.

At Gnome's bugzilla the bug is marked "Status: RESOLVED" and "Resolution: NOTGNOME" for Empathy.

Comment #5 @ http://bugzilla.gnome.org/show_bug.cgi?id=579650

"Will Thompson 2009-08-14 14:43:21 UTC

XMPP has many, many different ways to become invisible. The subset that
telepathy-gabble supports does not include the one used by Google Talk. So
MC/Empathy/something falls back to busy."

Changed in telepathy-gabble (Ubuntu):
status: Invalid → New

Bug was assigned to gnome-bugs #579650, but "Launchpad couldn't connect to GNOME Bug Tracker."
At gnome-bugs #579650, the but is marked "Status: RESOLVED" and "Resolution: NOTGNOME"

Changed in empathy:
importance: Unknown → Undecided
status: New → Invalid
Koen Verweij (kfverweij) wrote :

I have exactly the same behaviour as diago at comment #8 for MSN on updated Karmic, empathy 2.27.92 and I guess I'm using telepathy-haze (how do I know?)

Nicolas DERIVE (kalon33) wrote :

Koen Verweij : In the Accounts window, your account name is MSN if you use telepathy-butterfly, MSN-Haze if you use telepathy-haze (if you haven't change it). But when you create an account, you can choose between this two CM (marked as MSN and MSN-haze respectively).

Hope that it helps.

Koen Verweij (kfverweij) wrote :

Mine is actually named "New MSN account". New MSN accounts are called "New MSN account" too. There only is MSN and no MSN-haze to choose from. I have both telepathy-haze and telepathy-butterfly installed though.

Nicolas DERIVE (kalon33) wrote :

Koen Verwiej : Sure, I just tested it and this is a bug to my mind. Could you report a bug against empathy for this ? Give then its number to me and I will confirm it and transmit it to upstream bugtracker (for example by mailing me, click on my name to see my mail address on my profile page). After few tests, I got a reply for you : You're not using telepathy-haze, but telepathy-butterfly. Creating an account, it was the connection manager used on my system (I saw it in the list of running processes, but no telepathy-haze) so I suppose telepathy-haze is not listed anymore for msn accounts in empathy, and is replaced by telepathy-butterfly when haze was used (it does that with an old account which was set up with haze).

For the original bug, it may be empathy related, and seems fixed in the upcoming 2.28.0 release I just tested (using an msn account with telepathy-butterfly and a jabber account with telepathy-gabble).

Hope that it helps.

Changed in telepathy-gabble:
status: Unknown → Confirmed

This problem is now resolved for me in Karmic. Hidden status now working correctly.

DanN (drdannicolescu) wrote :

I still have the busy instead of hidden problem for the YM account and I am using Empathy 2.28.0.1 in Karmic Beta.

filip (bandit-s-fw) wrote :

I have also still the "busy instead of hidden" problem for my msn-account.
I can reproduce this on my haze and the normal account of msn.
I use an up-to-date karmic

filip (bandit-s-fw) wrote :

There has been a new update of empathy.
This fixes the problem for me.
I had a weird problem that empathy wouldn't connect anymore.
I have made a new msn-account in empathy (i reintroduced my data) and than it worked.

pivo (pivo-pobox) wrote :

With up to date karmic the invisible status doesn't work for my gmail account. Tried both account types jabber and gtalk and also with telepathy-haze installed instead of telepathy-gabble. Is there any changelog mentioning the relevant fix?

With the latest updates today (18-10-2009):

I still have to set my status to Hidden twice. After the first time,
it is changed to Busy, and then to Hidden.

If I change my status from user switcher, it's called
"indicator-applet-session" (Ubuntu -> Set status -> Invisible), the
status is changed to Busy, and does not become Hidden, no matter how
many times set from that menu.

But there's the worst thing: even when Empathy shows it's Hidden, ICQ
USERS ANYWAY SEE MY STATUS AS *BUSY*. If most people are like me,
after trying Empathy in new Ubuntu, they will become mad about this,
because this bug gives a feeling of being absolutely out of control,
and you even have to discover this yourself, because even being out of
control is not quite obvious.

shafin (mahdee-jameel) on 2009-10-18
Changed in empathy:
status: Invalid → Confirmed
Omer Akram (om26er) wrote :

yes this really a problem and hope it gets fixed before karmic

Tom Wright (twright-tdw) wrote :

On the one hand it did not work in pidgin either but it is still a really annoying limitation. At this stage though it probably could not be fixed without changes to the library supporting new features, which probably will not be happen this close to release (prove me wrong :-) )

Adam Gignac (mcivor) wrote :

Confirming on Karmic RC. It seemed to work when I installed it, but after the most recent update (as of Oct. 27) it is broken.

Adam Gignac (mcivor) wrote :

Whoops, forgot to mention I'm using an MSN account with telepathy-butterfly.

Tran Vinh Tan (vinhtantran) wrote :

Confirmed on Karmic 9.10, I'm using Yahoo Messenger

Emerson (martinseac) wrote :

confirmed on karmic with msn, yahoo and gmail

Nuno Brito (nuno-g-brito) wrote :

This happens to me in Ubuntu 9.10 when I try to login as "hidden" in an MSN account:
1) I start Empathy.
2) I open the combo box and select "Hidden".
3) I am logged in but the status is "Busy".
4) If I now select "Hidden" again then it works and my status becomes "Hidden".

Changed in empathy:
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Stefan Seidel (seidler2547) wrote :

@Andrew: Fix Released? Where is the fix? It still doesn't work for me on fresh Karmic install as of today. Although sometimes Empathy will acutally show "Hidden" as status, others see me in my GTalk account still as "Busy".

Mike G (bluplr) wrote :

Confirmed on Karmic with msn, just after updating and restarting system.

Amirreza (amir-r-borhani) wrote :

I also have the problem for yahoo ID in karmic koala!

Brian Curtis (bcurtiswx) wrote :

Gabble, since this feature isn't a part of gabble right now it won't make it into empathy.

Changed in telepathy-gabble (Ubuntu):
importance: Undecided → Medium
status: New → Won't Fix
Sebastien Bacher (seb128) wrote :

Why did you close the telepathy-gabble task? It's a valid bug with an upstream watch active too...

Changed in telepathy-gabble (Ubuntu):
status: Won't Fix → Triaged
importance: Medium → Low
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- This is a bug , not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
CedricMC (cedricmc) wrote :

Case #1
1.- Log in to some IM account (using Gtalk here).
2.- Change your status to "Hidden" via Empathy.
3.- Your status changes to "Hidden" on Empathy but your contacts still see you as "Busy".

Case #2
1.- Log in to some IM account (using Gtalk here).
2.- Change your status to "Hidden" via the status applet.
3.- Your status changes to "Busy" on Empathy and your contacts still see you as "Busy".

In both cases, one expects that the status changes to "Hidden" and to appear as disconnected.

PS: this comes from https://bugs.launchpad.net/bugs/490795

deuxcroix (deux-croix) wrote :

Confirmed in fresh install of Karmic Koala with Empathy 2.28.1.
Status appears as "Hidden" in status drop-down list, but the account will be seen as "Busy" in the contacts list. I added myself in my list for testing purposes, and I appear to be "Busy" instead of offline.
Steps to reproduce the bug are described upwards, they are the same, I am just adding another confirmation. It should be a class-C bug, but with "A" priority, because is one of the most used features an average user wants to work fine. I haven't figured yet if this is a system-wide bug with other implications at other software levels, or it is strictly about Empathy.
Hope it will be reopened if it's closed, otherwise users will switch to other IM clients such Pidgin a.o., and Empathy might lose the popularity it won with its embed in 9.10.

croftj (croftj) wrote :

For Gtalk, at least, I believe this is not an issue with Empathy but with the method Gtalk to implement invisibility, as Curtis Lee mentioned. Unfortunately, switching to Pidgin will not solve resolve this as there is currently a similar bug: http://developer.pidgin.im/ticket/5828.

ubuntolo (ovitaerc) wrote :

Just another confirmation of this bug.
Hope to see a fix soon!

Changed in empathy (Ubuntu):
status: Triaged → Confirmed
Vish (vish) on 2010-03-02
affects: hundredpapercuts → null
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) on 2010-07-08
Changed in telepathy-gabble (Ubuntu):
status: Triaged → Fix Committed
Omer Akram (om26er) on 2010-07-09
Changed in empathy:
importance: Undecided → Low
status: Confirmed → Invalid
Changed in empathy (Ubuntu):
status: Triaged → Invalid
57 comments hidden view all 137 comments
Omer Akram (om26er) wrote :

nomnex, MSN and yahoo have been working in invisible mode for me since the day Lucid released or even before. The problem was only with gtalk which is now fixed upstream. Facebook dont support invisible.

On Fri, 2010-07-09 at 08:56 +0000, Omer Akram wrote:
> nomnex, MSN and yahoo have been working in invisible mode for me since
> the day Lucid released or even before. The problem was only with gtalk
> which is now fixed upstream. Facebook dont support invisible.

Sebastian, Omer, thanks for the input. I am not sure to understand. The
empathy GUI dully marks me as hidden--as long as I click 2x on the
"Hidden" button (the fist selection is ineffective as reported in the
bug).

Do you mean the Facebook contacts can see me, even though my status is
marked as hidden on my end?

Omer Akram (om26er) wrote :

Sorry it seems that the actual bug was blocked by the linked upstream bug which is fixed but the actual issue still needs fixing.

Changed in telepathy-gabble:
status: Confirmed → Unknown
Changed in telepathy-gabble (Ubuntu):
status: Fix Committed → Triaged

*** Bug 29724 has been marked as a duplicate of this bug. ***

Changed in telepathy-gabble:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Changed in empathy (Ubuntu):
status: Invalid → Opinion
status: Opinion → Confirmed
frizzle21 (frederik-nnaji) wrote :

I have this problem in Maverick Beta, using Jabber only this time.
As long as Empathy doesn't inform me about the fact that it can't set my desired state of Presence, the bug remains valid for Empathy, too.
Set to confirmed, for that reason.

nUboon2Age (nuboon2age) wrote :

@Sebastian Bacher wrote:

"> How about the Lucid users? Backport? PPA?

What protocol do you have the issue with? Let's try to see how the fix work in maverick then consider lucid but it seems non trivial change for a stable update"

For an LTS there *needs to be a way* for people to upgrade to a fixed functionality. Please make this available as a backport, PPA or *something*. The 'Me Menu' is a major feature of Lucid and very visible on the desktop and right now the availability functions don't work at all in this friends machine i'm working on -- it seems permanently stuck on "available". For some people that is very worrisome because they don't want their IM accounts to say they are 'available' all the time. I can't say to my friend "you're out of luck -- get used to having this broken me menu in your face as long as you stick with Lucid". That's just not okay.

Guillaume Desmottes (cassidy) wrote :

I think this should be fixed in 0.10.0

Brian Curtis (bcurtiswx) wrote :

I just built gabble-0.10.0 and with it requiring telepathy-glib 0.11.16, and this bug is still valid.

alfabravoteam (alfabravoteam) wrote :

Confirmed bug in Maverick. The first time i tried "choosing invisible the second time" it kinda worked. Then, it didn't work anymore.

Tom Durrant (thdurrant) wrote :

I can confirm this in maverick as well, with stock empathy using gchat

manzur (sl-solaris) wrote :

+1
Ubuntu 10.10 Oct 12, 2010

Sunil Rana (sunil-rana) wrote :

+1
Ubuntu 10.10 Oct 22, 2010. I tried google chat.

Please do something.

xtrip (xtrip) wrote :

+1 Ubuntu 10.10 Oct 22, 2010.
It depends of combination of protocol i use/activate ...

Is it because a protocol that don't support hidden state is in use we can't use hidden state for all ?

hidden does not work for gtalk *only*

On Fri, Oct 22, 2010 at 9:39 PM, xtrip <email address hidden> wrote:

> +1 Ubuntu 10.10 Oct 22, 2010.
> It depends of combination of protocol i use/activate ...
>
> Is it because a protocol that don't support hidden state is in use we
> can't use hidden state for all ?
>
> --
> Setting status to 'Hidden' changes status to 'Busy' instead
> https://bugs.launchpad.net/bugs/257190
> You received this bug notification because you are subscribed to empathy
> in ubuntu.
>
> Status in Chat app, and Telepathy user interface: Invalid
> Status in NULL Project: Invalid
> Status in Jabber/XMPP connection manager: Confirmed
> Status in “empathy” package in Ubuntu: Confirmed
> Status in “telepathy-gabble” package in Ubuntu: Triaged
> Status in “telepathy-haze” package in Ubuntu: Invalid
>
> Bug description:
> Binary package hint: empathy
>
> Using MSN, Yahoo and Jabber. Setting 'Hidden' sets your status as 'Busy'.
>
> Reproduce:
>
> * Run Empathy. (your preferred method).
> * Use MSN (haze), Yahoo or Jabber.
> * Try to set status to 'Hidden' from drop down menu.
>
> What happens:
>
> * Status is set to 'Busy'.
>
> What should happen:
>
> * Status should be set to 'Hidden'.
>
>
>

tfultz (tfultz33) wrote :

On 10/22/2010 12:39 PM, xtrip wrote:
> +1 Ubuntu 10.10 Oct 22, 2010.
> It depends of combination of protocol i use/activate ...
>
> Is it because a protocol that don't support hidden state is in use we
> can't use hidden state for all ?
>
>
I only used one account: Yahoo. It wouldn't work. Still to busy. Still
same after upgrading to Lucid 10.04.1

Omer Akram (om26er) on 2010-10-29
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
rap (raphaelclarinete) wrote :

I can't understand. Gtalks' protocol does not support hidden status? So why in others clients it works perfectly?

Same happening with MSN protocol. Setting invisible on Empathy actually sets it to Busy status.

Omer Akram (om26er) wrote :

this issue is fixed in telepathy-gabble 0.11 in natty

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
Changed in telepathy-gabble (Ubuntu):
status: Triaged → Fix Released
Changed in telepathy-gabble:
importance: Wishlist → Unknown
status: Confirmed → Fix Released
summerishere (culpritdoctor) wrote :

confirmed for ubuntu 10.10 x64.

Mari (piratemari) wrote :

I have this issue. I do NOT use GTalk on Empathy, I only use AIM, MSN, and Y!M. When I set my status to invisible in empathy it sets me to busy. Repetitively. It never stays as invisible/hidden for more than a few seconds before it changes to busy again. And I do not even have the option to change it from the user panel once it sets it there, it shows me in my user panel as busy and upon attempting to go to invisible does absolutely nothing. I am using Lucid LTS, completely updated and everything. It's never bothered me before because I didn't use messenger often but I am using it much more now, and this is an absolute pain.

Changed in telepathy-gabble:
importance: Unknown → Wishlist

I've been seen this bug im Empathy for a long time and it continues nowadays. I think it's not a low importance bug because it's a bug in a basic functionality of the program. I'm using Ubuntu 10.10 64 bit. I can't understand why Empathy continues the default IM program in Ubuntu with bugs like this.

Rushi (rushik-1986) wrote :

This bug is still there in Natty 11.04. Tried with google chat.

Anderson (andersonbessa) wrote :

Rushi .. in fact this bug was corrected in Ubuntu Natty Narwhal 11.04.
Try to disable all other accounts (open Empathy, press F4 and turn off all other accounts). Let just your google account actived then try set your status as invisible.

Ankur Joshi (pharmankur) wrote :

If we are not able to use multiple accounts, then whats the fun in using
empathy ? better we will use web based IM then ...

Regards,
Ankur Joshi

On Sun, May 1, 2011 at 12:17 AM, Anderson <email address hidden> wrote:

> Rushi .. in fact this bug was corrected in Ubuntu Natty Narwhal 11.04.
> Try to disable all other accounts (open Empathy, press F4 and turn off all
> other accounts). Let just your google account actived then try set your
> status as invisible.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (635603).
> https://bugs.launchpad.net/bugs/257190
>
> Title:
> Setting status to 'Hidden' changes status to 'Busy' instead
>
> Status in Chat app, and Telepathy user interface:
> Invalid
> Status in NULL Project:
> Invalid
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “empathy” package in Ubuntu:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Fix Released
> Status in “telepathy-haze” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: empathy
>
> Using MSN, Yahoo and Jabber. Setting 'Hidden' sets your status as
> 'Busy'.
>
> Reproduce:
>
> * Run Empathy. (your preferred method).
> * Use MSN (haze), Yahoo or Jabber.
> * Try to set status to 'Hidden' from drop down menu.
>
> What happens:
>
> * Status is set to 'Busy'.
>
> What should happen:
>
> * Status should be set to 'Hidden'.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/empathy/+bug/257190/+subscribe
>

Anderson (andersonbessa) wrote :

You can use multiple accounts, but all account need to support the invisible status.
When you set the account "People nearby", invisible status will not gonna work because this account do not support invisible status,

Matt Giuca (mgiuca) wrote :

I agree, that's not ideal (one account does not support invisibility, and invisibility is disabled across all of Empathy). But that is not this bug -- this bug is already fixed.

Ankur/Rushi, I suggest you file a new bug about this problem, which can be voted on and fixed independently of this one (and would probably be considered less critical). Be sure to link to here so it's clear it isn't a duplicate of this one, and link from here to there so interested parties can follow the new bug.

@Anderson
quote: "in fact this bug was corrected in Ubuntu Natty Narwhal 11.04."

I am using Ubuntu 11.04, and my Empathy version is 2.34.0.

Even if Google is the only active account, I am not able to set it to invisible.

Omer Akram (om26er) wrote :

varun, is the same account also logged in with another version of
ubuntu or(other distro) on another computer?

On Sat, Jun 18, 2011 at 10:25 PM, varun <email address hidden> wrote:
> @Anderson
> quote: "in fact this bug was corrected in Ubuntu Natty Narwhal 11.04."
>
> I am using Ubuntu 11.04, and my Empathy version is 2.34.0.
>
> Even if Google is the only active account, I am not able to set it to
> invisible.
>
> --
> You received this bug notification because you are subscribed to empathy
> in Ubuntu.
> https://bugs.launchpad.net/bugs/257190
>
> Title:
>  Setting status to 'Hidden' changes status to 'Busy' instead
>
> Status in Chat app, and Telepathy user interface:
>  Invalid
> Status in NULL Project:
>  Invalid
> Status in Jabber/XMPP connection manager:
>  Fix Released
> Status in “empathy” package in Ubuntu:
>  Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
>  Fix Released
> Status in “telepathy-haze” package in Ubuntu:
>  Invalid
>
> Bug description:
>  Binary package hint: empathy
>
>  Using MSN, Yahoo and Jabber. Setting 'Hidden' sets your status as
>  'Busy'.
>
>  Reproduce:
>
>   * Run Empathy. (your preferred method).
>   * Use MSN (haze), Yahoo or Jabber.
>   * Try to set status to 'Hidden' from drop down menu.
>
>  What happens:
>
>   * Status is set to 'Busy'.
>
>  What should happen:
>
>   * Status should be set to 'Hidden'.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/empathy/+bug/257190/+subscriptions
>

Andrei Dziahel (develop7) wrote :

~andersonbessa:
> You can use multiple accounts, but all account need to support the invisible status.
Well, I've just experimented with chat accounts a bit, and discovered a workaround which works for me.
Preamble. So I have some jabber accounts (most of them are googletalk-hosted), one yahoo account and one salut account. When salut account is enabled, other jabber accounts change status to "busy" instead of "hidden". As I've disabled salut account, other jabber accounts started to change their status to "hidden".

So, workaround is following — disable salut, change status to "hidden", enable salut back (if you want to).

Should I file a bug like 'salut makes gabble accounts unable to set status "hidden"'?

Andrei Dziahel (develop7) wrote :

Ah, forgot to mention: I'm on Ubuntu Natty
% aptitude show empathy | grep '^Version:'
Version: 2.34.0-0ubuntu3.1

Monte (monte-cs) wrote :

Yes, definately, file it.
On Sep 17, 2011 4:35 AM, "Andrei Dziahel" <email address hidden> wrote:
> ~andersonbessa:
>> You can use multiple accounts, but all account need to support the
invisible status.
> Well, I've just experimented with chat accounts a bit, and discovered a
workaround which works for me.
> Preamble. So I have some jabber accounts (most of them are
googletalk-hosted), one yahoo account and one salut account. When salut
account is enabled, other jabber accounts change status to "busy" instead of
"hidden". As I've disabled salut account, other jabber accounts started to
change their status to "hidden".
>
> So, workaround is following — disable salut, change status to "hidden",
> enable salut back (if you want to).
>
> Should I file a bug like 'salut makes gabble accounts unable to set
> status "hidden"'?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/257190
>
> Title:
> Setting status to 'Hidden' changes status to 'Busy' instead
>
> Status in Chat app, and Telepathy user interface:
> Invalid
> Status in NULL Project:
> Invalid
> Status in Jabber/XMPP connection manager:
> Fix Released
> Status in “empathy” package in Ubuntu:
> Fix Released
> Status in “telepathy-gabble” package in Ubuntu:
> Fix Released
> Status in “telepathy-haze” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: empathy
>
> Using MSN, Yahoo and Jabber. Setting 'Hidden' sets your status as
> 'Busy'.
>
> Reproduce:
>
> * Run Empathy. (your preferred method).
> * Use MSN (haze), Yahoo or Jabber.
> * Try to set status to 'Hidden' from drop down menu.
>
> What happens:
>
> * Status is set to 'Busy'.
>
> What should happen:
>
> * Status should be set to 'Hidden'.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/empathy/+bug/257190/+subscriptions

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null

I Have this bug on Oneiric

anne tennae (anne-tennae) wrote :

same problem here, ubuntu 10.10 default/updated/whatever empathy. could use this, if it wasn't for the Final Fantasy 3 adium theme it would be a deal breaker.

consider putting all future development into final fantasy themes. thank you =P

no really this would be good to fix, is easy i would hope?

Helder (he7d3r) wrote :

I'm still seeing this on Empathy 3.2.0.1, Ubuntu 11.10.

stranger (dirlik) wrote :

I'm still experiencing this problem on Ubuntu 12.04 beta 1 (Empathy: 3.3.91)

ernesto (ernesto-bosch) wrote :

Still this problem on Ubuntu 12.04LTS and Empathy 3.4.1. Very annoying. Changing client.

Noe (noe-brucy) wrote :

Still this problem on Ubuntu 12.04LTS, this bug isn't fixed.

Rafał Ochmański (rmopl) wrote :

This bug is still present in Empathy 3.6.0.3 on Ubuntu 12.10.

Rafał Ochmański (rmopl) wrote :

and

Package: telepathy-gabble
Version: 0.16.1-2

Displaying first 40 and last 40 comments. View all 137 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.