empathy-auth-client crashed with SIGSEGV in auth_data_free()

Bug #1029258 reported by Josh Connolly on 2012-07-26
92
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Critical
empathy (Ubuntu)
Medium
Unassigned

Bug Description

Adding online accounts for Microsoft Exchange, Facebook and Google, error happened after Google addition

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: empathy 3.5.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu5
Architecture: amd64
Date: Thu Jul 26 01:12:11 2012
ExecutablePath: /usr/lib/empathy/empathy-auth-client
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcCmdline: /usr/lib/empathy/empathy-auth-client
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f69e0363fd4: mov (%rdi),%rdi
 PC (0x7f69e0363fd4) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? () from /usr/lib/empathy/libempathy-3.5.4.1.so
 ?? () from /usr/lib/empathy/libempathy-3.5.4.1.so
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/empathy/libempathy-3.5.4.1.so
 ?? () from /usr/lib/x86_64-linux-gnu/libtelepathy-glib.so.0
Title: empathy-auth-client crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: Upgraded to quantal on 2012-07-24 (1 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Josh Connolly (joshconnolly78) wrote :

StacktraceTop:
 auth_data_free (data=0x0) at empathy-goa-auth-handler.c:92
 auth_cb (user_data=0x0, source=0x1bc4310, result=<optimized out>) at empathy-goa-auth-handler.c:129
 auth_cb (source=0x1bc4310, result=<optimized out>, user_data=user_data@entry=0x0) at empathy-goa-auth-handler.c:111
 g_simple_async_result_complete (simple=0x1ce0810) at /build/buildd/glib2.0-2.33.6/./gio/gsimpleasyncresult.c:775
 sasl_status_changed_cb (channel=<optimized out>, status=status@entry=4, dbus_error=dbus_error@entry=0x1ccdfa0 "", details=details@entry=0x1cdce40, user_data=<optimized out>, self=<optimized out>) at empathy-sasl-mechanisms.c:92

Changed in empathy (Ubuntu):
importance: Undecided → Medium
summary: - empathy-auth-client crashed with SIGSEGV in
- g_simple_async_result_complete()
+ empathy-auth-client crashed with SIGSEGV in auth_data_free()
tags: removed: need-amd64-retrace
tags: added: running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

send to upstream here is the link
https://bugzilla.gnome.org/show_bug.cgi?id=680952

visibility: private → public
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Bilal Shahid (s9iper1) wrote :

bug got fixed in upstream and will be release in next trunk

Changed in empathy:
importance: Unknown → Critical
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.5.5-0ubuntu1

---------------
empathy (3.5.5-0ubuntu1) quantal; urgency=low

  * New upstream release
    - empathy-auth-client crashed with SIGSEGV in auth_data_free() (LP: #1029258)
  * debian/control
    - build depend on libsecret-1-dev
  * debian/patches/45_string_literal.patch
    - string literal formating fix
 -- Ken VanDine <email address hidden> Fri, 10 Aug 2012 13:33:29 -0400

Changed in empathy (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.