Possible Cegui compiltion error

Bug #1598500 reported by Piotr on 2016-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ember
Undecided
Unassigned

Bug Description

Cegui cant build toluappcegui-bin, for some reasone linking lualibs gives error.

Setup:
lua (version 5.3.3)
lua51 (this is the name pkg-config file)

All the needed files in the attachment.
Edit:
I've checked detailed make command - the linker links -llua5.1 and -lm and -ltolua which are the correct libraries.
This is really misleading.

Piotr (elminister) wrote :
Piotr (elminister) on 2016-07-03
description: updated
Erik Ogenvik (erik-ogenvik) wrote :

This isn't an error with Ember; it's something to do with CEGUI. You should check with them over at http://cegui.org.uk/

However, a limitation of tolua++ is that it only works with Lua 5.1.
The project is pretty much abandoned.
Until we find a substitute (or rather CEGUI does it, since we use the CEGUI bindings in order to script the UI) we'll have to live with the limitation of it only working with Lua 5.1.

Changed in ember:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments