The Worldforge Ember client

compilation error due to boost libraries update

Reported by Piotr on 2012-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ember
High
Erik Ogenvik

Bug Description

Hi,
recently I upgraded boost libs to 1.50+ which resulted in compilation error:
(ember branch - ogre_1_8)

-------------------------------------------------------------
/local/lib/libmercator-0.3.so /usr/local/lib/libAtlasObjects-0.6.so /usr/local/lib/libAtlasNet-0.6.so /usr/local/lib/libAtlasCodecs-0.6.so /usr/local/lib/libAtlasMessage-0.6.so /usr/local/lib/libAtlas-0.6.so /usr/local/lib/libwfmath-1.0.so /usr/local/lib/libwfut-0.2.so -lz -lsigc-2.0 -lcurl -lX11 /usr/local/lib/libCEGUIOgreRenderer.so -lOgreMain /usr/local/lib/libCEGUIBase.so -lfreetype -lpcre -ldl -llua -lm -lSDL -lpthread -pthread
/usr/bin/ld: ../../src/bindings/lua/liblua_ConnectorDefinitions.a(ConnectorDefinitions.o): undefined reference to symbol '_ZN5boost6system15system_categoryEv'
/usr/bin/ld: note: '_ZN5boost6system15system_categoryEv' is defined in DSO /usr/lib/libboost_system.so.1.50.0 so try adding it to the linker command line
/usr/lib/libboost_system.so.1.50.0: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[3]: *** [ember.bin] Błąd 1
make[3]: Opuszczenie katalogu `/home/piotr/projekty/worldforge/kod/ember/src/main'
make[2]: *** [all-recursive] Błąd 1
make[2]: Opuszczenie katalogu `/home/piotr/projekty/worldforge/kod/ember/src'
make[1]: *** [all] Błąd 2
make[1]: Opuszczenie katalogu `/home/piotr/projekty/worldforge/kod/ember/src'
make: *** [all-recursive] Błąd 1
-------------------------------------------------------------

I attached the config.log file in case of need.

Piotr (elminister) wrote :
Erik Ogenvik (erik-ogenvik) wrote :

This seems to be a new issue with boost 1.50. http://www.ogre3d.org/forums/viewtopic.php?f=2&t=71037
Ember should probably also perform detection and inclusion of libboost_system for versions of boost > 1.50. I'll take a closer look.

Changed in ember:
assignee: nobody → Erik Ogenvik (erik-ogenvik)
importance: Undecided → High
status: New → Confirmed
Erik Ogenvik (erik-ogenvik) wrote :

I've now added a fix which I think should work to the boost_1_50_0 branch (which is based on the ogre_1_8 branch). Could you test and see if it fixes your issue?

Piotr (elminister) wrote :

The same error occured (exactly the same).

Erik Ogenvik (erik-ogenvik) wrote :

Could you post the result of config.log and the Makefile which is generated in the root directory?

Piotr (elminister) wrote :

config.log

Piotr (elminister) wrote :
Erik Ogenvik (erik-ogenvik) wrote :

I've pushed another commit. Can you try it? If it fails, could you send me config.log again?

Erik Ogenvik (erik-ogenvik) wrote :

Ok, I've pushed yet another fix. Could you take a look?

Piotr (elminister) wrote :

Success , :D
It's working! Thank you Erik!

Erik Ogenvik (erik-ogenvik) wrote :

I've now added the patch to the ogre_1_8 branch and removed the boost_1_50_0 branch.

Changed in ember:
status: Confirmed → Fix Committed
Erik Ogenvik (erik-ogenvik) wrote :

Reopened as this still seems to affect WebEmber.

Changed in ember:
status: Fix Committed → Confirmed
Erik Ogenvik (erik-ogenvik) wrote :

Closing again as I misunderstood the reported issue.

Changed in ember:
status: Confirmed → Fix Committed
Changed in ember:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers