libMagickWand.so.4 & libMagickCore.so.4 libraries missing with latest ImaeMagick update..

Bug #1282851 reported by Martin Cigorraga on 2014-02-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Emacs-snapshot
Undecided
Unassigned

Bug Description

Hello Damien:

can you please rebuild Emacs against the latest ImageMagick version? As I upgrade ImageMagick (I use it on a daily basis, just like Emacs) I've found that Emacs stopped working throwing with the following error message:
"emacs: error while loading shared libraries: libMagickWand.so.4: cannot open shared object file: No such file or directory"

Thank you very much for contributing this must-have PPA!
Best regards.

description: updated
affects: emacs-snapshot → emacs24 (Ubuntu)
Damien Cassou (cassou) wrote :

Dear Martin,

could you please report your bug to https://bugs.launchpad.net/emacs-snapshot/ (which is my official issue tracker) instead of here (which is Ubuntu's)?

Then, could you please execute these lines and write the result in your bug report?

$ apt-cache policy emacs24
$ apt-cache policy libmagickwand5
$ lsb_release -c

Finally, could you please tell me all the steps to reproduce your problem starting with "emacs -Q"

Changed in emacs24 (Ubuntu):
status: New → Invalid
affects: emacs24 (Ubuntu) → emacs-snapshot

Here it goes (and sorry for the mess!):

## Before symlinking the libraries, see comment at bottom ##
j:0 ~ > apt-cache policy emacs24
emacs24:
  Installed: 24.3+1-2~ppa1~precise1
  Candidate: 24.3+1-2~ppa1~precise1
  Version table:
 *** 24.3+1-2~ppa1~precise1 0
        500 http://ppa.launchpad.net/cassou/emacs/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

j:0 ~ > apt-cache policy libmagickwand5
N: Unable to locate package libmagickwand5

j:0 ~ > lsb_release -c
Codename: luna <--- (Precise Pangolin)

j:0 ~ > emacs -Q
emacs: error while loading shared libraries: libMagickWand.so.4: cannot open shared object file: No such file or directory

Now, it's weird I can't find anywhere here at Launchpad the comment I posted right next to my above mentioned report where I stated that symlinking "ln -s /usr/lib/libMagickWand.so.5 /usr/lib/libMagickWand.so.4" and "ln -s /usr/lib/libMagickCore.so.5 /usr/lib/libMagickCore.so.4" (as seen on this VectorLinux forum post: http://forum.vectorlinux.com/index.php?topic=15913.msg100288#msg100288) solves the issue!

## After symlinking above libraries ##
j:0 ~ > emacs -Q
;; This buffer is for notes you don't want to save, and for Lisp evaluation.
;; If you want to create a file, visit that file with C-x C-f,
;; then enter the text in that file's own buffer.

(That is, opens Emacs in a buffer as expected...)

Please let me know if I can be of further assistance.
Cheers!

summary: - 24.3+1-2~ppa1~precise1 package
+ libMagickWand.so.4 & libMagickCore.so.4 libraries missing with latest
+ ImaeMagick update..
Damien Cassou (cassou) wrote :

Please report the bug on the correct issue tracker as stated on my previous comment.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers