Rename slingshot to slingshot-launcher

Bug #993044 reported by ttosttos on 2012-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cerbere
Fix Released
Undecided
Cody Garver
Gala
Fix Released
Undecided
Cody Garver
Slingshot
Fix Released
Undecided
Cody Garver
Wingpanel
Fix Released
Low
Cody Garver
elementary OS
Fix Released
Undecided
Cody Garver

Bug Description

A subset of the core apps should be identified as core system apps and be built with unique names to prevent app conflicts that could render the system unusable or confuse user. A prefix (e.g. pantheon-slingshot or elementary-slingshot) could be used for name differentiation. As an example, Ubuntu repositories have a slingshot game available today. If an user accidentally or purposely installs the game, elementary slingshot app would be overwritten. The following core apps would candidates to be flagged as core system apps: slingshot, wingpanel, cerbere, contractor, switchboard.

Related branches

Packages are not allowed to overwrite each other unless they explicitly request it. E.g. our "slingshot-launcher" package doesn't conflict with "slingshot" from Ubuntu repos because "slingshot" is a game and it's installed in /usr/games/.

Well, somebody following your logic made slingshots conflict on packaging level, but I've fixed that yesterday and the fix will land to the PPA in an hour or so. I'll check if there are any file collisions (e.g. in .desktop files) and fix them if I encounter any.

ttosttos (ttosttos) wrote :

As of the Luna unstable 20120427, running 'apt-get install slingshot' had the very undesirable effect of launching a game when clicking on "Applications" on Wingpanel. No error, no warning presented to the user. While this game is just an example, we should think more generally to see how likely are conflicts.

Why would you run 'apt-get install slingshot' on a daily build in the first place?

Oh, I see the problem now. Thanks!
Hmm... I guess Wingpanel should try launching full path. This is weird because /usr/games is the last entry in PATH environment variable, at least on my elementaryfied Precise.

summary: - Uniquely name core system apps
+ Use full paths to binaries internally

Could you please run "echo $PATH" in terminal and post output?

ttosttos (ttosttos) wrote :

ttosttoss@aburra:~$ echo $PATH
/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
ttosttoss@aburra:~$

Maybe the game isn't really installing under /usr/games ?

Thanks! Please check if you still have "slingshot-launcher" package installed. It could get removed by installing "slingshot" in some older builds.

Daniel Fore (danrabbit) wrote :

marking as incomplete until we can find out if this is still happening with the latest packaging.

Changed in elementaryos:
status: New → Incomplete

Should be done regardless of packaging. Just a common sense and robustness improvement.

Changed in elementaryos:
status: Incomplete → Confirmed
Cody Garver (codygarver) on 2012-07-08
summary: - Use full paths to binaries internally
+ Rename slingshot to slingshot-launcher
Changed in slingshot:
status: New → In Progress
Changed in wingpanel:
status: New → In Progress
Changed in cerbere:
status: New → In Progress
assignee: nobody → Cody Garver (codygarver)
Changed in slingshot:
assignee: nobody → Cody Garver (codygarver)
Changed in wingpanel:
assignee: nobody → Cody Garver (codygarver)
Daniel Fore (danrabbit) on 2012-07-09
Changed in cerbere:
milestone: none → luna-beta1
Cody Garver (codygarver) on 2012-07-11
Changed in elementaryos:
assignee: nobody → Cody Garver (codygarver)
Changed in gala:
assignee: nobody → Cody Garver (codygarver)
status: New → Fix Released
milestone: none → luna-beta1
Changed in slingshot:
status: In Progress → Fix Committed
Changed in wingpanel:
status: In Progress → Fix Committed
Changed in elementaryos:
status: Confirmed → Fix Committed
Changed in cerbere:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-07-11
Changed in slingshot:
milestone: none → luna-beta1
Changed in wingpanel:
milestone: none → luna-beta1
Changed in elementaryos:
milestone: none → luna-beta1
Daniel Fore (danrabbit) on 2012-07-11
Changed in cerbere:
status: Fix Committed → Fix Released
alexander (shootnix-i) wrote :

After update wingpanel slingshot launcher doesn't run, just opened window in /usr/share/application.

Cody Garver (codygarver) wrote :

dconf reset -f /org/pantheon/desktop/

Correction: dconf reset -f /org/pantheon/desktop/wingpanel

Victor Martinez (victored) wrote :

Since this change affects cerbere, slingshot, etc, resetting the entire /desktop/ path is more appropriate, as Cody suggested.

Cerbere is not even in /org/pantheon/desktop/ and resetting the whole desktop/ is an overkill anyway.

So the correct commands are:
dconf reset -f /org/pantheon/desktop/wingpanel
dconf reset -f /org/pantheon/cerbere

David Gomes (davidgomes) on 2012-09-29
Changed in wingpanel:
importance: Undecided → Low
Daniel Fore (danrabbit) on 2012-11-09
Changed in slingshot:
status: Fix Committed → Fix Released
Changed in elementaryos:
status: Fix Committed → Fix Released
Changed in wingpanel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers