Super + Space should launch slingshot

Reported by Daniel Fore on 2012-03-09
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
elementary OS
Medium
Cassidy James

Bug Description

Slingshot should be launched with Super + Space, but it's not.

Daniel Fore (danrabbit) on 2012-03-09
Changed in elementaryos:
milestone: none → luna-beta1
tags: added: defaults
Daniel Fore (danrabbit) on 2012-03-11
Changed in elementaryos:
importance: Undecided → Medium
status: New → Confirmed

I've added that to session defaults. However, it will work only in Metacity (not in Compiz) unless "commands" plugin in Compiz is activated. Enabling it is up to Cassidy with his Compiz profile now.

Changed in elementaryos:
status: Confirmed → In Progress
tags: added: compiz
Changed in elementaryos:
assignee: nobody → Cassidy James (cassidyjames)
Alex Korobkin (korobkin) wrote :

Btw, this Super+Space combination conflicts with Gnome+Do and other apps, and should be user-configurable. Right now something in Unity silently eats it at the session start. and making it unusable by other applications.

Tested in the latest 12.04 beta x64.

please hack this into compiz profile

Changed in elementaryos:
status: In Progress → Confirmed
Eduard Gotwig (gotwig) wrote :

if you simply add the command slingshot to the commands plugin in compiz, it works for compiz...

Alex Korobkin (korobkin) wrote :

It is a workaround, not a fix. Unity should stop stealing Super+Space shortcut for the issue to be fixed.

Cody Garver (codygarver) on 2012-06-18
Changed in elementaryos:
status: Confirmed → Fix Committed
Pranav (pranavkaranjkar) wrote :

I am just another user of luna daily build. I was wondering if this feature has been dropped since you guys moved away from compiz and started using Gala?

Cody Garver (codygarver) wrote :

Super + Space still launches Slingshot in Gala.

Pranav (pranavkaranjkar) wrote :

Then, I think its just not working for me. Maybe when I will do a fresh beta install, it will work

Colin Shirran (colinshirran90) wrote :

I'm currently using the daily build and trying to help you guys with bugs.

Just wondering why you haven't simply chose to use the super button to open slingshot? I suppose the reflex is just a throwback from Unity but it seems a lot simpler and easier when searching for an application.

I wanted to make this as a suggestion but I felt that perhaps there is a specific reason and wasn't sure where to ask. I hope here is ok.

Thanks in advance.

Cody Garver (codygarver) wrote :

You can review the key command specs here https://docs.google.com/document/d/1jUtWkfqlwDydaO-B67F9PsOhE66AZ2y5N_uDRW9pOuQ/edit

The reason for not using Super alone escapes me, maybe it was because it would launch Slingshot when you're trying to use a Super+<SomethingElse> key combo.

Regarding using just "Super", here's the list of pros and cons I've collected so far:

Arguments pro:
- Every single computer user who knows that the application launcher can be triggered from the keyboard also knows that Super is the default key for that.
- Easier to trigger

Arguments con:
- Modifier keys are not supposed to do anything on their own (however, Alt switches focus to menubar in Windows and GNOME apps, so we might want to make Alt focus the toolbar or open the AppMenu for accessibility reasons).
- Can be triggered accidentally and block input to apps.
- Dan has a crippled keyboard that does not have a compose key, but he needs one, so he makes Super key act as Compose key on his machines. Hence he doesn't support the idea of using Super for menu.

what about waiting for the Super button to be released to launch slinghshot (as it happens in window)?

Changed in elementaryos:
status: Fix Committed → Fix Released
Jordan Bates (saudrapsmann) wrote :

This is terrible. Please, please undo it.

No sane OS or DE works like this -- not even Gnome Shell.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers