Create a simple launcher to initiate Gala workspaces overview

Reported by Sergey "Shnatsel" Davidoff on 2012-03-04
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
elementary OS
Status tracked in 0.3-isis
0.2-luna
Wishlist
Unassigned
0.3-isis
Wishlist
Unassigned

Bug Description

Compiz expo is one of those really fancy and really useful things that we have going on. But at the moment, its impossible to discover. I think having a regular launcher would make it really easy for people to stumble upon this functionality. Unity already has that.

Changed in elementaryos:
importance: Undecided → Wishlist
status: New → Triaged
assignee: nobody → Sergey "Shnatsel" Davidoff (shnatsel)

I'll probably use xdotool to make it work instead of D-bus; I still haven't figured out where's metacity's keybinding is stored. Is it hardcoded or what?

Changed in elementaryos:
milestone: none → luna-beta1
Daniel Fore (danrabbit) wrote :

No Compiz = no Compiz plugins.

Changed in elementaryos:
status: Triaged → Invalid
milestone: luna-beta1 → none
summary: - Create a simple launcher to initiate Compiz expo
+ Create a simple launcher to initiate Gala workspacees overview
Changed in elementaryos:
status: Invalid → New
milestone: none → luna-beta1
status: New → Confirmed

Since Gala revision 181, the command to be executed in the .desktop file would be:
  dbus-send --type=method_call --dest=org.pantheon.gala /org/pantheon/gala org.pantheon.gala.PerformAction int32:1

Changed in elementaryos:
assignee: Sergey "Shnatsel" Davidoff (shnatsel) → nobody
Changed in elementaryos:
assignee: nobody → Sergey "Shnatsel" Davidoff (shnatsel)

Okay, here's a stub for .desktop file. We need to sort out three things:
1) It needs a dedicated icon. Assigning DanRabbit.
2) Name and comment should be checked for decency
3) We need to specify Gettext domain for l10n purposes; so we need to decide to which package/app it will belong and translate it from there. Gala is currently not translatable.

Sample .dockitem for Plank
Place in ~/.config/plank/dock1/launchers/

Changed in elementaryos:
status: Confirmed → In Progress
assignee: Sergey "Shnatsel" Davidoff (shnatsel) → Daniel Fore (danrabbit)
Keith Adair (kjzz12) wrote :

So I'd like to push a little bit of discussion on the name of the dock item. Workspace Overview seems like the default name these days on Linux systems. But in Elementary, as we no longer use the dots on Plank to represent which apps are running, this indicator will be the only way a user knows which apps are running and where. It's ALMOST akin to this:
http://www.simplehelp.net/2010/11/29/how-to-close-open-apps-on-your-ipad-iphone-or-ipod-touch/
As such, I feel like the the name ought to reflect that. My current name for the dock item on MY plank is "Running Apps," but that does not reflect the workspaces aspect. "Apps and Workspaces," perhaps? But maybe that's too unwieldy.

Ideas?

Minor updates to the .desktop file, didn't tackle anything from the list above

Daniel Fore (danrabbit) wrote :

1 & 2. I guess we need to decide a sane name for this functionality before we can come up with a good icon name. I think we plan to have a kind of expose mode like Mission Control right? So it wouldn't make 100% sense just to call it a Workspace Manager/Switcher. Maybe "Task Switcher"?

3. I guess since it's a Gala functionality and depends on Gala, it should probably be shipped as a part of Gala ;)

summary: - Create a simple launcher to initiate Gala workspacees overview
+ Create a simple launcher to initiate Gala workspaces overview
Eduard Gotwig (gotwig) wrote :

I don't want that this is part of plank. Plank should only contain applications.

Cassidy James (cassidyjames) wrote :

This would be called "Workspace Overview" or "Spaces Overview". I don't know that we want it by default though.

Thomas Berends (thomasberends) wrote :

Maybe the name "Observatory" ?
The 'overview' really is an observatory for your apps/workspaces. Workspaces are like different galaxies, with different starts (apps).

Fabian Thoma (agent00tai) wrote :

This will not ship in beta 1 but maybe in beta two, so I retargeted this Bug ;)

Changed in elementaryos:
milestone: luna-beta1 → luna-beta2
Cassidy James (cassidyjames) wrote :

To reiterate for clarity, it's called "Workspace Overview".

Daniel Fore (danrabbit) on 2012-12-08
Changed in elementaryos:
assignee: Daniel Fore (danrabbit) → nobody
Cody Garver (codygarver) on 2012-12-24
Changed in elementaryos:
milestone: luna-beta2 → luna-beta3
Cody Garver (codygarver) on 2013-05-13
Changed in elementaryos:
milestone: luna-beta3 → luna-rc1

The above dock items work, but they bounce, which is distracting and annoying.
We need to know if:
1) Is that acceptable? Can we include them?
2) If not, are hacks in Plank, e.g. no-bounce property or some simple docklet patches acceptable?

I'm trying to figure out if this work item really desired and a release blocker.

Changed in elementaryos:
status: In Progress → Incomplete
Viktor Basso (viktor-basso) wrote :

We can use "Keywords" from the Desktop Entry Specification.
http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html
"A list of strings which may be used in addition to other metadata to describe this entry. "

By adding keywords to the .desktop launcher like:
Keywords=NoBounce;

The plank developers can use that as a variable to not animate the bounch of a launcher. I think this solution would not "taint" the .desktop launcher files in any way if used on other desktop environments.

Cody Garver (codygarver) on 2013-07-24
Changed in elementaryos:
milestone: luna-rc1 → none
Daniel Fore (danrabbit) wrote :

Here's a temporary icon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers