Memory leak, a lot of memory is freed if I run nautilus

Bug #798039 reported by Erasmo Marín on 2011-06-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
High
Unassigned
0.2-luna
Fix Released
High
Unassigned

Bug Description

I have installed Elementary Luna from a clean natty install with the transformation script, and I have a very important memory leak.

I discovered that If i run nautilus, the memory is freed, A LOT of memory is freed, i mean, sometimes the system is wasting something like 1,1 gb of RAM, and if I run nautilus, there is like 600 mb freed.

Also I get this error:

**
Eel:ERROR:eel-preferences.c:107:preferences_gconf_value_get_bool: assertion failed: (value->type == GCONF_VALUE_BOOL)
Aborted

Changed in elementaryos:
importance: Undecided → High
Cory (cory-coryclaxon) wrote :

I have a similar bug, but without the memory leaks. No matter what I try I cannot get nautilus to open and errors out with "Eel:ERROR:eel-preferences.c:107:preferences_gconf_value_get_bool: assertion failed: (value->type == GCONF_VALUE_BOOL)" as described above. Does anyone know a workaround or a fix?

blitux (dev-pabloquiroga) wrote :

The error is because some variables on gconf (i don't know why) are not Booleans, but strings.

I solved the problem with gconf-editor, changing some keys data type on apps/nautilus. They show the value "FALSE" or "TRUE". Create a new key with the same name but with boolean type, and you will be replacing the old keys.

I just did it, but can't remember what keys I have changed, but they are related with nautilus elementary (two of them are rgba_colormap on app/nautilus/preferences and volumes_visible on apps/nautilus/desktop)

Cory (cory-coryclaxon) wrote :

If could find what you exactly did, I would be happy. Because, for right now, I'm much happier with Nuatilus than Marlin.

Cory (cory-coryclaxon) wrote :

Update: I figured it out, I changed everything from FALSE/True to Boolean's and unchecked the Places Sidebar thing (I forgot the gconf name).

Thanks a lot for the investigation, guys!
I've fixed this in v0.2.2, please run "gconftool-2 --recursive-unset apps/nautilus", then "nautilus -q" and see if the bug reappears.

Marking "Fix released", please report if the bug reappears.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers