No Alt+F2 dialog available

Bug #794454 reported by Sergey "Shnatsel" Davidoff
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
elementary OS
Won't Fix
Low
Unassigned
0.1-jupiter
Won't Fix
Undecided
Unassigned
0.2-luna
Won't Fix
Low
Unassigned

Bug Description

No Alt+F2 dialog available in Jupiter and dailies of Luna. This means that I can't run a command without leaving a terminal window hanging around.

Revision history for this message
donald iljazi (1lj4z1-deactivatedaccount-deactivatedaccount-deactivatedaccount-deactivatedaccount-deactivatedaccount) wrote :

maybe assign another key something like alt+r or super+r (r for run). and for the terminal something like alt+t or super+t (t for terminal). i am using it this way and seems very convenient instead of remembering random f keys ;p

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Ctrl+Alt+t already summons terminal.

Revision history for this message
Gusions (gusions) wrote :

It will possible to set alt+f2 to launch Switchboard in future?

Revision history for this message
Allen Lowe (lallenlowe) wrote : Re: [Bug 794454] Re: No Alt+F2 dialog available

we should make alt+f2 launch gmrun

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

See the related blueprint for available options.

Revision history for this message
Timo Reimerdes (timorei) wrote :

Probably one of the best solutions would be synapse. It's very powerfull and bloated by default, imho. But with a nice skin and configuration this might actually be something usable.

Revision history for this message
Erasmo Marín (erasmo-marin) wrote :

Synapse is awesome, because autocompletation feature, its a good option at my opinion, but very statical.

I have installed synapse, but I cant set the alt+f2 combination... its taken...

Changed in elementaryos:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Timo Reimerdes (timorei) wrote :

I tried a lot of solutions and finally settled for "xfrun4" contained in the package "xfce4-utils".
It's just perfect, small and fast, has a simple history and live auto-completion.

I'm running it through the compiz command keybindings.

Revision history for this message
Danielle Foré (danrabbit) wrote :

I'm leaning towards marking this a duplicate of bug #950427

alt + F2 is just a crappy shortcut and we already have Slingshot as an app-launcher (and it does commands).

Revision history for this message
Timo Reimerdes (timorei) wrote :

While Alt+F2 isn't the most intuitive of shortcuts (as most of them are) it performs an essential part in my and many others workflow.

Ctrl+Space is ok, too.

I don't mind getting used to a new keybind, just that there is a way to quickly launch an app without: keyboard(work) -> mouse (panel/entry) -> keyboard (appname).

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Super+Space is default for Launching slingshot as it is; however, a mode oriented at running commands and showing command history on clicking Alt+F2 will be greatly appreciated. https://blueprints.launchpad.net/slingshot/+spec/command-mode

Revision history for this message
Danielle Foré (danrabbit) wrote :

Slingshot includes the ability to execute commands and launching with a keyboard combination is already planned. I don't see any reason that the specific combination "alt+f2" is required.

Marking as won't fix.

Changed in elementaryos:
status: Triaged → Won't Fix
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Alt+F2 should trigger https://blueprints.launchpad.net/slingshot/+spec/command-mode which is different from the normal app-centric slingshot view. Reopening as incomplete for further discussion.

Changed in elementaryos:
status: Won't Fix → Incomplete
Revision history for this message
Danielle Foré (danrabbit) wrote :

Remarking as won't fix since this is a Slingshot issue and not an elementary OS issue.

Changed in elementaryos:
status: Incomplete → Won't Fix
milestone: luna-beta1 → none
Mr. Fail (bittimassi)
no longer affects: ubuntu
Revision history for this message
Mr. Fail (bittimassi) wrote :

Affects Elementary OS Isis.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints