The Plank icon in the dock needs to be hidden

Reported by Avi Romanoff on 2011-06-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
elementary OS
Undecided
Unassigned

Bug Description

Just what it says on the tin. I believe this can be done with a configuration keyfile.

Related branches

I'd prefer upstream to make this change and not mess with ugly config tweaks myself :)

tags: added: ebuild
Changed in elementaryos:
status: New → Confirmed

Uh, do you mean get upstream to implement an easy toggle for the icon? Because for sure they're not going to get rid of the icon.

On Jun 5, 2011, at 3:09 AM, "Sergey \"Shnatsel\" Davidoff" <email address hidden> wrote:

> I'd prefer upstream to make this change and not mess with ugly config
> tweaks myself :)
>
> ** Tags added: ebuild
>
> ** Changed in: elementaryos
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/792895
>
> Title:
> The Plank icon in the dock needs to be hidden
>
> Status in elementary OS:
> Confirmed
>
> Bug description:
> Just what it says on the tin. I believe this can be done with a
> configuration keyfile.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/elementaryos/+bug/792895/+subscribe

Gusions (gusions) wrote :

It's simple to do. Remove the plank.dockitem in /.config/plank/launchers !

I'd rather prevent its creation than remove it. Removing it is hackish. We need to figure out when and under what circumstances plank.dockitem is created. Its creation is not in /etc/skel/ and not in packaging scripts. We need to ask Plank devs about it.

Avi Romanoff (aroman) wrote :

I agree with shnatsel. I have reported the feature request in upstream Plank.

On Jun 5, 2011, at 7:25 AM, "Sergey \"Shnatsel\" Davidoff" <email address hidden> wrote:

> I'd rather prevent its creation than remove it. Removing it is hackish.
> We need to figure out when and under what circumstances plank.dockitem
> is created. Its creation is not in /etc/skel/ and not in packaging
> scripts. We need to ask Plank devs about it.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/792895
>
> Title:
> The Plank icon in the dock needs to be hidden
>
> Status in elementary OS:
> Confirmed
>
> Bug description:
> Just what it says on the tin. I believe this can be done with a
> configuration keyfile.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/elementaryos/+bug/792895/+subscribe

Changed in elementaryos:
status: Confirmed → Fix Committed
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers