Unable to install steam because of missing 32-bit libraries

Bug #1622391 reported by Stevan on 2016-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
elementary OS
New
Undecided
Unassigned

Bug Description

Hi after running sudo apt-get install steam i get this error:

eading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 steam:i386 : Depends: libgl1-mesa-dri:i386 but it is not going to be installed
              Depends: libgl1-mesa-glx:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

There is no way how to install this 2 dependencies, i tried everything and after 5 hrs of googling bug report has to be made.

I have nVidia 376.44 drivers installed and elementary tweaks, everything else is stock (fresh install today). Updated everything via AppCenter

Zisu Andrei (matzipan) wrote :

Sounds like you're trying to install the i386 version of Steam. Elementary is amd64 only.

Changed in elementaryos:
status: New → Invalid
Stevan (xwm) wrote :

There is no 64bit version of steam for Linux. Steam is highly popular. It would be madness to decide to drop a possibility to install steam.

Cody Garver (codygarver) wrote :

What does it say if you try `apt-get install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386`

Changed in elementaryos:
status: Invalid → New
wolf (w+lf) wrote :

I installed Steam in Loki with your original command on my first go. Have you tried just purging Steam and reinstalling it?

Stevan (xwm) wrote :

Wolf, yes i did, always end up on same error when i tried to install it. I even tried "sudo dpkg --add-architecture i386" but still i couldnt install those 2 libs.

Cody Garver, it says that packed is moved or it doesnt have install candidate

wolf (w+lf) on 2016-10-19
summary: - Unable to install steam
+ Unable to install steam because of missing 32-bit libraries
wolf (w+lf) wrote :

Related: http://elementaryos.stackexchange.com/q/8807/5565

Here's what I found:

One of [these](https://ubuntuforums.org/showthread.php?t=2233005) should do the trick. Test if it opens after each one and report back?

1. `sudo apt install steam`
2. `sudo apt install libgl1-mesa-glx-lts-utopic:i386`
3. `sudo apt-get install --reinstall libgl1-mesa-dri:i386`

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers