Grub2 menu is unreadable on a HiDPI (4k) screen

Bug #1537378 reported by rambolino on 2016-01-23
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
elementary OS
Confirmed
Undecided
Unassigned

Bug Description

I recently bought the Dell Precision 5510 with a HiDPI 4k (3840x2160) screen, and installed elementary OS 0.3.2 (Freya) on it. When booting up after the installation, grub2 chooses the native resolution of the screen which happens to be 3840x2160, and this makes the boot menu text completely unreadable.

The installer should configure Grub2 with a sane graphics mode based on screen size and resolution.

Daniel Fore (danrabbit) on 2016-06-06
Changed in elementaryos:
status: New → Confirmed
Sviatoslav Sydorenko (webknjaz) wrote :

Any solution so far?

Zisu Andrei (matzipan) wrote :

Hello Sviatoslav,

Have you tried changing the GRUB resolution? https://askubuntu.com/questions/54067/how-do-i-safely-change-grub2-screen-resolution

An alternative might be to use rEFInd instead of GRUB. Have you tried that?

Aidan Samuel (aidan-samuel) wrote :

I've had success rendering larger fonts, as described here:
https://unix.stackexchange.com/questions/31672/can-grub-font-size-be-customised

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints