Flickering and screen distortion with new HWE and multi-monitor on Freya

Bug #1435861 reported by Guy Van Sanden on 2015-03-24
90
This bug affects 21 people
Affects Status Importance Assigned to Milestone
elementary OS
New
Undecided
Unassigned

Bug Description

I installed the new HWE to test on my Freya install, the Xorg is causing heavy screen flickering and sometimes distortion on several animations and on new notifications.

I didn't have that with the old HWE stack, it only happens when connecting an external monitor.

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.371+418~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.16.0-33.44~14.04.1-generic 3.16.7-ckt7
Uname: Linux 3.16.0-33-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Tue Mar 24 14:38:01 2015
InstallationDate: Installed on 2014-08-11 (224 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Guy Van Sanden (gvs) wrote :
Guy Van Sanden (gvs) wrote :

Strangely, when I switch monitors a couple of times, it sometimes disappears, comes back on reboot...

Karut (kraeutermann) wrote :

I have the same issue. Comes and goes like you say. Without the HWE though.

Guy Van Sanden (gvs) wrote :

This is there on a clean install of Freya-release

Guy Van Sanden (gvs) wrote :

Doing this suggested by a redditor takes away most flickering, some tearing is left though:

sudo apt-get install mesa-utils
sudo mkdir /etc/X11/xorg.conf.d/
echo -e 'Section "Device"\n Identifier "Intel Graphics"\n Driver "Intel"\n Option "AccelMethod" "sna"\n Option "TearFree" "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf
sudo reboot

I am using thinkpad x200 recently upgraded to freya after that facing issues flickering of screen at some place in screen. This happens mostly when I connect the external monitor and use with x200 to make dual monitor. I have never faced such issue using luna with dual monitor.
Would appreciate If anybody has fix for it please post in comments.

laci357 (laci357) wrote :

Same issue here on Asus U33JC with Nvidia GeForce 310M.
As long as Xorg is used, flickering is an issue.
As soon as I select the Nvidia driver 331.113, the flickering is gone, but unfortunately the Worskpace feature is gone as well (cannot add new workspace).

It would be great if this issue was fixed so that the default Xorg works as supposed to (just like it does in Elementary Luna)

laci357 (laci357) wrote :

Actually the issue of not being able to add another workspace while using Nvidia driver 331.113 can be easily resolved by a few clicks:
- look up Nvidia X Server Settings via the Applications menu
- in the PRIME Profiles choose: Intel (Power Saving Mode)
- log out and log back in and you are good to go and use workspaces again ;-)

Andres Mendez (shiruken-f) wrote :

Thinkpad x201 here. Alt-tabbing between windows will cause the screen to flicker violently for me, and trying to switching to the workspace after the left/right most, also causes the "bounce" animation to flicker.

No flickering when notification popups come up, or when hovering over the taskbar.

David Lukeš (dafydd-lukes) wrote :

Dell Optiplex 390 desktop here. I confirm the flickering issue (on login, while alt-tabbing, during hot corner multi-tasking overview), and I also confirm that the workaround mentioned above in https://bugs.launchpad.net/elementaryos/+bug/1435861/comments/5 works for me :) Thanks!

Xijun Wang (xijunw) wrote :

Fujitsu S7211 laptop with intel GMA X3100 here. I confirm the flickering issue on login.
I also confirm that the workaround mentioned above in comments #5 works for me :)
Thanks !

ghoppa (ghoppa) wrote :

Dell inspiron 15 laptop here. Comment #5 worked for me too, finally! Thanks a lot!

Stiffler (stefan-binder17) wrote :

Dell inspiron 15 latop and the Commet #5 works great. Thanks!

Gabriel Pepe (gp2notime) wrote :

Since release I was having the same problem the I find comment #5 and worked for me like a charm, thanks Guy Van Sanden

Vesa Sinisalo (vesa-sinisalo) wrote :

HP Pavilion G7000 with Intel GM965.
Workaround does it. Very much thank You!

Abner Diaz (abnerdiaz04) wrote :

Guy Van Sanden (gvs) Bro thanks. Now my computer runs awesome.

waqas (yurmuki) wrote :

This is awesome man. This fixed my all time big issue. Now I am more enjoying Freya.... Thank you so much for this fix. Please add in Elementary repo so that people get it by default.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers