Can't update/install dropbox, causes "unlock mutex error"

Bug #1418489 reported by DicconSpain on 2015-02-05
132
This bug affects 26 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Undecided
Unassigned

Bug Description

dropbox update
Attempt to unlock mutex that was not locked
Aborted (core dumped)

Maybe related to:
Debian Bug report logs - #763724
nautilus-dropbox: Attempt to unlock mutex that was not locked // Aborted (core dumped)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763724

See also:

Bug 1138146 - dropbox crashes in F21 due to the glib mutex issue

https://bugzilla.redhat.com/show_bug.cgi?id=1138146

This bug states:

"I think this gnome bug explains the issue:
  https://bugzilla.gnome.org/show_bug.cgi?id=735428

There is a fix for this in gtk+:
  https://github.com/GNOME/gtk/commit/79c3ff3c4ed74bbcc820dac2d5180fa4d48d55ec"

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.359+403~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Thu Feb 5 11:04:27 2015
InstallationDate: Installed on 2014-12-17 (49 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
SourcePackage: elementary-meta
SuspiciousXErrors: [WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

DicconSpain (dicconspain) wrote :
harris (harrismrubin) on 2015-02-13
Changed in elementaryos:
status: New → Confirmed
Jonas (idobrinescu) wrote :

Very much the same bug prevents me to update dropbox with the official deb package (1.6.2).

Needed to revert to nautilus-dropbox 1.6.1-1 via Software center -- which works fine, but only in the background, without indicator, and of course refusing to update after the command `dropbox update`

I have a paid dropbox for business account and manage a whole team. Fortunately only Elementary OS experiences the bug.

Gabriel_P (gabp) on 2015-02-26
summary: - dropbox update causes unlock mutex error
+ Can't update/install dropbox, causes "unlock mutex error"
Gabriel_P (gabp) wrote :

This bug prevented me to install Dropbox 64-bit.

dehein (dehein) wrote :

Have found a way to let it start the download of the Dropbox package. Someone should report this on the official forums of Dropbox maybe.

You execute
DISPLAY= dropbox start -i

that way it only shows in console that it is doing. Will update if everything went fine

dehein (dehein) wrote :

Only helps in downloading Dropbox. It still does not start correctly.

dehein (dehein) wrote :

Well after a reboot. The gui showed only so to be able to login. No appindicator. But it works now via commandline. so use dropbox status and it shows it is working.

This is not Dropbox-specific. I got the same error trying to start RadioTray (installed from the repo).

Jonas (idobrinescu) wrote :

Apparently someone finally figured this out here:
http://www.srw2d.com/getting-dropbox-notification-working-in-elementary-os-freya/

1. Start dropbox with this command
dropbox stop && env XDG_CURRENT_DESKTOP=Unity dropbox start

2. Go to settings and turn off "Start Dropbox on system startup"

3. Go to system settings -> Applications , from the tab up top select "Startup" and add a command from the + button at the bottom left and there will be an input where you can enter in a command below and press enter to save.
env XDG_CURRENT_DESKTOP=Unity dropbox start

Worked for me. I finally have the dropbox indicator working. :))

Jonas (idobrinescu) on 2015-04-09
Changed in elementaryos:
status: Confirmed → Fix Released
Gareth (gmccumskey) wrote :

This is marked as fix released and yet I am still having the same issue after making sure I was fully up to date....

Diego Ponciano (diegoponciano) wrote :

I jsut tried installing Dropbox on a updated Freya, got this error.
It seems the fix wasn't released in Elementary yet.

Gabriel_P (gabp) wrote :

I'm still getting this issue. Dropbox is a *very* important software for *many* people. The fix was released more than a month ago, how long until we get it?

SNX (pctech271) wrote :

I was able to get dropbox working with the icon, here is what I did:

Download Dropbox via www.Dropbox.com
 - Use Ubuntu 64 Bit Version

Install Dropbox via Software Center
 - To Fix gtk2 issues download and install https://apps.ubuntu.com/cat/applications/gtk2-engines-pixbuf/
   via Software Center

 - To Fix - Failed to Load "canberra-gtk-module" install librayr via Terminal
    sudo apt-get install libcanberra-gtk*

Now When one starts dropbox through Terminal via "dropbox start" they see
- Dropbox Daemon is not running please use "dropbox start -i"
Note* - Instead of typing in dropbox start -i, type: DISPLAY= dropbox start -i

This will bring up a window where the Dropbox GUI appears (once downloaded/installed) on both desktop
and wingpanel. Next
- Sign in with your account (Dont Close out of any windows open)
- open terminal and type the follwoing command: dropbox stop && env XDG_CURRENT_DESKTOP=Unity dropbox start
- you should now see the dropbox icon on the top wingpanel
- right click on the dropbox icon > Preferences > Turn off Start Dropbox on system startup
- now navigate to system settings > applications > startup > and add: env XDG_CURRENT_DESKTOP=Unity dropbox start

restart and it should be working

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers