empathy segfault when started

Bug #1416487 reported by Clément HERTLING on 2015-01-30
70
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Empathy
New
Undecided
Unassigned
elementary OS
New
Undecided
Unassigned

Bug Description

When I start empathy on my system, I get some GTK/Glib errors, and then a segfault (and obviously it doesn't start).
I'm not using any special gtk theme or anything. Here's the terminal output :

$ empathy

(empathy:5521): Gtk-CRITICAL **: gtk_entry_set_icon_activatable: assertion 'GTK_IS_ENTRY (entry)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(empathy:5521): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_entry_get_text: assertion 'GTK_IS_ENTRY (entry)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_set_size_request: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'GTK_IS_WIDGET (widget)' failed

(empathy:5521): Gtk-CRITICAL **: _gtk_widget_get_preferred_size_and_baseline: assertion 'GTK_IS_WIDGET (widget)' failed
[1] 5521 segmentation fault empathy
$

So this is quite problematic.
Tell me if you need anything else

dmesg log :
[ 2243.708752] empathy[5182]: segfault at 18 ip 00007f9c2a94ee37 sp 00007fffa72632b0 error 4 in libgtk-3.so.0.1400.8[7f9c2a63d000+69b000]
[ 2243.708843] Core dump to |/usr/share/apport/apport 5182 11 0 5182 pipe failed

Sean Seago (speedkreature) wrote :

"Me too."
Elementary OS 0.3

lmkdev (laminko) wrote :

"Me too."
Elementary OS Freya

Luka Napotnik (luka-napotnik) wrote :

Empathy chrashes on elementarty 0.3 for me as well. I've attached a gdb session output when empathy crashed, including the stack trace, thread info and locals info in the first frame.

Hope it helps ...

shakalandy (shakalandy) wrote :

Same over here. Problem with "Online Accounts" of Ubuntu?

Try this:

sudo apt-get remove empathy
sudo apt-add-repository ppa:gnome3-team/gnome3-staging
sudo apt-get update
sudo apt-get install empathy
sudo add-apt-repository --remove ppa:gnome3-team/gnome3-staging

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers