os-patch-casper-trusty fails to build in OS patches PPA

Bug #1293364 reported by Cody Garver on 2014-03-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Medium
Unassigned

Bug Description

Kirill Antonik (ntnk) wrote :

As I can see the casper package cannot be built because the "elementary OS" name contains a space that makes "sed" command in Makefile think it's the end of the script and not use the rest of the command after this space, because the quotes were closed earlier. So the easiest solution is to remove them so the line would look like this:
sed -i -e 's/\(BUILD_SYSTEM="\).*"/\1$(BUILD_SYSTEM)"/g' casper.conf
instead of
sed -i -e 's/\(BUILD_SYSTEM="\).*"/\1'$(BUILD_SYSTEM)'"/g' casper.conf

Cody Garver (codygarver) wrote :

Thanks a lot, Kirill, you fixed the build.

Changed in elementaryos:
assignee: nobody → Kirill Antonik (irapter)
assignee: Kirill Antonik (irapter) → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers