Have shotwell watch for new files

Bug #1261094 reported by Daniel Fore on 2013-12-15
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Photos
Fix Released
Low
Cody Garver
elementary OS
Invalid
Low
Cody Garver

Bug Description

We should probably have Shotwell watch the Pictures folder by default. Especially with introducing Snap, I think those photos should automatically appear in Shotwell.

Related branches

Phillip Sz (phillip-sz) on 2013-12-28
Changed in elementaryos:
status: New → Confirmed
Cody Garver (codygarver) on 2014-01-09
Changed in elementaryos:
importance: Undecided → Low
assignee: nobody → Cody Garver (codygarver)
status: Confirmed → In Progress
Daniel Fore (danrabbit) on 2014-01-24
Changed in pantheon-photos:
importance: Undecided → Low
milestone: none → 0.16
status: New → Confirmed
Cody Garver (codygarver) on 2014-01-28
Changed in pantheon-photos:
status: Confirmed → In Progress
assignee: nobody → Cody Garver (codygarver)
Changed in elementaryos:
milestone: isis-beta1 → none
status: In Progress → Invalid
RabbitBot (rabbitbot-a) on 2014-01-31
Changed in pantheon-photos:
status: In Progress → Fix Committed
Tristan Petersen (tristang4) wrote :

I downloaded the patch and tested it out. I could not seem to get pictures to automatically import no matter what I tried. What am I missing here?

Daniel Fore (danrabbit) wrote :

Tristan, this only modifies the default setting. It won't overwrite any settings you already have. What this does is check the "Watch library directory for new files" setting. So if you add pictures to that folder Shotwell will import it

Tristan Petersen (tristang4) wrote :

Daniel, I did change my current setting from false to true to test and it still didn't seem to work for me. My library directory is listed as ~/Pictures in my preferences. When I drag a picture into that folder, it doesn't import into shotwell for me.

Jim Nelson (yorba-jim) wrote :

Is the photo a duplicate of an existing photo? Shotwell doesn't import duplicates into its library.

Daniel Fore (danrabbit) on 2014-12-29
Changed in pantheon-photos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers