Move contracts out of lp:contractor and into their own package(s)

Bug #1171606 reported by Cody Garver on 2013-04-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Contractor
Fix Released
Low
Sergey "Shnatsel" Davidoff
elementary OS
Fix Released
Low
elementary OS team

Bug Description

Contracts don't belong in lp:contractor

Related branches

Cody Garver (codygarver) on 2013-04-22
Changed in contractor:
status: New → Triaged
importance: Undecided → Low
Victor Martinez (victored) wrote :

It would be good to have a separate launchpad project too. Maybe lp:elementary-contracts, though applications intended to run on elementary OS should ship their own contracts in the future.

Cody Garver (codygarver) wrote :

I have attached 2 branches to this bug.

One drops contracts from lp:contractor and will be the last branch to be merged.

The other is all the contracts I could find lying around to package. It still needs 2 authors in its debian/copyright and a review from shnatsel about the package naming structure.

shnatsel, get back to me about this when you can.

Changed in elementaryos:
status: Confirmed → In Progress

I'd rather have a package called non-upstreamed-contracts and throw every contract there, then remove them as they're getting upstreamed. This will require clever package versioning to work cleanly, but we can afford that.

It will also require proper existence and executability watches in Contractor (bug 912413) as well as support for TryExec key (bug 1171835) and, in the long run, OnlyShowIn key. So I'd say Contractor is not really ready for this yet.

Changed in elementaryos:
milestone: luna-beta3 → none

Also it's not a release blocker, so I'm untargeting it from beta3.

tags: added: technical-debt

Oh, and don't forget localization!

Cody Garver (codygarver) on 2013-04-29
Changed in contractor:
status: Triaged → In Progress
assignee: nobody → Cody Garver (codygarver)
Victor Martinez (victored) wrote :

I've linked a branch that removes the Contractor Gettext domain (should be merged after merging Cody's branch).

Here's also another branch that makes the default contracts use external Gettext domains: lp:~elementary-apps/contractor/default-contracts.

I'm hoping somebody from the OS team will take the contracts from that branch, add packaging, and push them to lp:~elementary-os/contractor/default-contracts or lp:~elementary-os/contractor/non-upstreamed-contracts.

We have no real blockers for this since the result is equivalent.

Don't forget to *disable* Launchpad translations for the project after completing this!

I'd rather split that branch further into "file-roller-contracts" and "gnome-core-contracts" packages.

And as soon as we get TryExec support I'd throw all not upstreamed contracts in one package, but that's a whole separate story...

Changed in contractor:
milestone: none → isis-beta1
Changed in contractor:
assignee: Cody Garver (codygarver) → Sergey "Shnatsel" Davidoff (shnatsel)
Changed in contractor:
status: In Progress → Fix Released
Changed in elementaryos:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2014-06-26
Changed in elementaryos:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
milestone: none → freya-beta1
Daniel Fore (danrabbit) on 2014-12-29
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers