Drop USC, pick up AppCenter

Bug #1153104 reported by Cody Garver on 2013-03-10
148
This bug affects 35 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Medium
Cody Garver

Bug Description

Because coolness.

When AppCenter goes 0.1 (any day now) we want to replace Ubuntu Software Center with it.

This also means picking up gdebi for this cycle so no one gets pissed off about Steam being seemingly impossible to install.

What to do:
* Drop USC from seeds
* Add gdebi to seeds
* Add appcenter to seeds
* Blacklist gdebi in slingshot

Cody Garver (codygarver) on 2013-03-10
Changed in elementaryos:
status: Confirmed → Triaged
Changed in slingshot:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Cody Garver (codygarver)
milestone: none → luna-beta2

It's sexy, but I doubt the "any day now" part. Looking at how I've filed 3 bugs from one screenshot that were not previously known and how building the database segfaulted for half of people in IRC who tried it, I assume AppCenter is not sufficiently tested.

This would better be a blueprint - turns out there's a lot of work items to take care of.
This is just from the top of my head:
 * Teach Congrego to generate the database during building the ISO. Probably will require work on AppCenter too.
 * Make AppCenter update its database when the repository list changes (I'll report a bug about this).
 * Investigate if USC has any important role in the system (it probably does). See how hard will it be to provide the same from AppCenter. (apturl and updating xapian db are probably tied to it, maybe more).

abrsdk (abrsdk) wrote :

i don't see the need of gdebi, you can just use dpkg from the command line

Cody Garver (codygarver) wrote :

People are going to download the Steam .deb from the official website and have no idea what's going on when it's not associated with any app.

Cameron Norman (cameronnemo) wrote :

Hey, Shnatsel, I think USC might be part of the propietary (additional) drivers GUI installer.

gdebi must be installed.
Yesterday, for example, i was helping a friend with his installation of elementaryos, and while i was typing dpkg commands his dad said me: "uhmm, very well, are you programming now?"

it is not elementary.

maybe...can we create a more "elementary os" interface for it?
it should be fast.

I don't think Jockey relies on USC because it appeared way before USC did. I would be surprised if it depended on USC somehow because it works on a lower level anyway.

Tavecchio Luca (tavecchio-luca) wrote :

i've installed appcenter and gdebi, run appcenter -r, and then remove usc... eveyrthing is working fine right now.

Jaap Broekhuizen (jaapz-b) wrote :

Though AppCenter looks really promising already, it doesn't seem to be ready for a release yet. Didn't we already cross the feature freeze for a long time now? If we're going to add AppCenter, we probably should add Audience too for example...

AppCenter is really cool and all, but i think the focus should be with getting luna beta 2 out of the door. Now we're just creating more work for ourselves while we really can't deal with the amount of work that has to be done even without AppCenter.

Cody Garver (codygarver) on 2013-03-12
Changed in elementaryos:
milestone: luna-beta2 → 0.3-beta1
Changed in elementaryos:
milestone: 0.3-beta1 → none
Changed in slingshot:
milestone: luna-beta2 → none
Changed in slingshot:
status: In Progress → Incomplete
Cody Garver (codygarver) on 2013-04-16
no longer affects: elementaryos/0.2-luna
Cody Garver (codygarver) on 2013-08-24
no longer affects: slingshot
Cody Garver (codygarver) on 2014-04-08
no longer affects: elementaryos/0.3-isis
Changed in elementaryos:
milestone: none → isis+1-beta1
assignee: Cody Garver (codygarver) → nobody
Sascha Heuterer (theanachron) wrote :

How can I test installation of AppCenter?

quassy (quassy) wrote :

For the time being, wouldn't adopting Lubuntu Software Center be a better option for Freya than USC?

Jason Anderson (ertain) wrote :

How does one actually build and install AppCenter? I've tried it in the past, and I couldn't get it to build. Also, there isn't a repository for it, nor can I find it in the Freya repositories.

Daniel Fore (danrabbit) on 2015-11-15
Changed in elementaryos:
milestone: loki-beta1 → loki-alpha1
status: Confirmed → Fix Committed
assignee: nobody → Cody Garver (codygarver)
Daniel Fore (danrabbit) on 2016-09-15
Changed in elementaryos:
status: Fix Committed → Fix Released
milestone: loki-alpha1 → loki-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints