Music titles in SoundMenu too small

Bug #1080076 reported by Andreas on 2012-11-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Indicator Display Objects
In Progress
Wishlist
Lars Karlitski
elementary OS
Invalid
Undecided
Unassigned
ido (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned

Bug Description

[Impact]
The artist/title/album labels in the sound menu are often hard to read because they get ellipsized fairly quickly (i.e., for relatively short labels). Also, the menu is visually unbalanced in languages with longer strings (making the menu wider), because the playback controls are hardcoded with a ~100px left margin.

The fix for this bug makes the font size a bit smaller, according to the design spec for the sound menu. It also makes sure that labels with a width of about 25 characters are always shown in full, independent of the font size. The playback controls are centered.

[Test Case]
Play a song in Rhythmbox that has an track name (or artist or album name) that is longer than about 20 characters. Open the sound menu and see that the long label is ellpsized.

[Regression Potential]
If the fix to this bug is faulty, it might lead to weird menu sizes (too small or too large). The playback controls used hard-coded coordinates for drawing and hit detection. Rendering or selection bugs might occur.

[Original Description]
When looking at the currently running track in SoundMenu (clementine music player), the space for the title of the track and album are too small, because the album art is directly next to it. Both titles are truncated and thus almost unreadable, when longer than about 10 characters.

Is it possible to put the album artwork in a different column? Or make the SoundMenu wider?

Related branches

Andreas (andreas-weiden) wrote :

Would like to add a screenshot, however, see Bug #1080075, https://bugs.launchpad.net/elementaryos/+bug/1080075

Julián Unrrein (junrrein) wrote :

Andreas, you can use a screenshot app (like xfce4-screenshoter) to get what you are looking for.

Andreas (andreas-weiden) wrote :

Thanks for the hint, just took a screenshot the way you recommended

Cody Garver (codygarver) wrote :

I'm not sure there's anything that can be done about this. Maybe retarget it to indicator-sound package.

Andreas (andreas-weiden) on 2012-12-22
Changed in elementaryos:
status: New → Invalid
Lars Karlitski (larsu) on 2014-04-11
Changed in indicator-sound:
status: New → Triaged
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Wishlist
Matthew Paul Thomas (mpt) wrote :

The menu as a whole should be a bit wider, and the track info should use the caption font size rather than the label font size.

Lars Karlitski (larsu) on 2014-04-23
Changed in indicator-sound:
status: Triaged → In Progress
assignee: Matthew Paul Thomas (mpt) → Lars Uebernickel (larsu)
tags: removed: wishlist
affects: indicator-sound → ido
Changed in ido (Ubuntu):
status: New → In Progress
importance: Undecided → Low
Lars Karlitski (larsu) on 2014-04-23
description: updated
Chris Halse Rogers (raof) wrote :

This would be a UI change, which pre-release would need a UI freeze exception. It's not a string change, which would affect translations, but I'm not sure to what extent we care about making documentation screenshots inconsistent.

I'll take this up with the rest of Ubuntu SRU.

Sebastien Bacher (seb128) wrote :

@Chris: thanks for considering that SRU!

Some cycles ago we had discussions about the difference between UI changes and fixes (mostly when Unity was still changing late in the cycle).

I think the agreement was that small tweaks to things like margins, alignments, colors are bugfixes. We don't need to documentation to match the UI at the pixel, but we need things to be structured the same so the documentation make sense (e.g if controls are moved, added, removed, etc that outdate the instructions and is an UI freeze exception topic)

Does that make sense?

Chris Halse Rogers (raof) wrote :

That does make sense, and I lean towards acceptance. I'll wait for the rest of the SRU team to be able to express their preference, though, as this is the first time I can recall dealing with this :).

Adam Conrad (adconrad) wrote :

I'm with Seb on this one (and I think I was involved in the discussions he's alluding to about Unity alignment and colour fixes). This is a real usability issue and, frankly, if there are screenshots documenting the current behaviour, they're ugly and we don't want them anyway. :P

I'm all for a hearty +1 on this, as long as the people testing it throw a rather varied playlist at it, with and without album art, and with varying title/artist lengths, to make sure it doesn't suffer any weird rendering regressions.

Hello Andreas, or anyone else affected,

Accepted ido into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ido/13.10.0+14.04.20140423-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ido (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
status: Triaged → Fix Committed
tags: added: verification-needed
Adolfo Jayme (fitojb) wrote :

The fix works for me!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+14.04.20140423-0ubuntu1

---------------
ido (13.10.0+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Make long track infos better readable By (a) making the width of the
    menu slightly larger and (b) reducing the font size. Also removes
    the hard-coded width of 200px in favor of a width based on font size
    (25 characters) and center the playback widget horizontally. (LP:
    #1080076)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 17:03:35 +0000

Changed in ido (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ido has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ido - 13.10.0+14.04.20140423-0ubuntu1

---------------
ido (13.10.0+14.04.20140423-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Make long track infos better readable By (a) making the width of the
    menu slightly larger and (b) reducing the font size. Also removes
    the hard-coded width of 200px in favor of a width based on font size
    (25 characters) and center the playback widget horizontally. (LP:
    #1080076)
 -- Ubuntu daily release <email address hidden> Wed, 23 Apr 2014 17:03:35 +0000

Changed in ido (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers