No UEFI support

Reported by Shiz on 2012-11-15
70
This bug affects 16 people
Affects Status Importance Assigned to Milestone
elementary OS
High
Ivo Nunes

Bug Description

The elementary OS live CD has a total lack of out-of-the-box UEFI support. It will always boot via the traditional BIOS boot method.

Fortunately, Ubiquity (at least on Ubuntu and Linux Mint) has full support for UEFI, handling EFI partitioning and installing grub-efi if it detected the live CD was booted via UEFI. Thus, the only change required would be to add a UEFI boot method to the live CD.

Shiz (shiz) on 2012-11-15
description: updated
Ivo Nunes (ivonunes) on 2012-11-15
Changed in elementaryos:
status: New → In Progress
assignee: nobody → Ivo Nunes (ivonunes)
RabbitBot (rabbitbot-a) wrote :

Ubuntu's scripts to generate it are in lp:~ubuntu-cdimage/debian-cd/ubuntu branch, tools/boot/<release>/boot-amd64 directory

B.B. Lauret (bblauret) wrote :

Is this getting prioritised before release of Luna? New PCs have often a EFI booting Windows. If you want to install elementary OS alongside, it has to boot in EFI too:

"if the other systems (Windows Vista/7/8, GNU/Linux...) of your computer are installed in EFI mode, then you must install Ubuntu in EFI mode too" (https://help.ubuntu.com/community/UEFI)

Changed in elementaryos:
milestone: none → luna-beta2

The script that generates the "efi" folder is not self-contained; it relies on other tools to add things to the CD. And we don't have a half of those things. AFAIK all the Congrego code to generate CD contents is written by Ivo more or less from scratch; with all due respect to his work, perhaps we should migrate to using Ubuntu scripts for the sake of not maintaining a vastly different implementation.

Cody Garver (codygarver) on 2013-01-01
Changed in elementaryos:
status: In Progress → Confirmed
importance: Undecided → High
Cody Garver (codygarver) wrote :

Check out bug #1075181, just got an update of GRUB supporting UEFI. For 12.04.2.

Daniel Fore (danrabbit) on 2013-01-07
Changed in elementaryos:
milestone: luna-beta2 → luna-beta3
Ivo Nunes (ivonunes) on 2013-03-05
Changed in elementaryos:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2013-03-05
Changed in elementaryos:
milestone: luna-beta3 → luna-beta2
Eduard Gotwig (gotwig) wrote :

I don't think that this is true. I am going to retest with Ubuntu. If it works, I am going to reopen this bug.

Eduard Gotwig (gotwig) wrote :

I had to install the BIOS updates for my Zenbook. Now all works good. Luna does support UEFI =)

Maybe you will find the question stupid, but how have you installed your BIOS updates? And how the machine do react when booting Luna trough UEFI?

Cody Garver (codygarver) on 2013-04-12
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers