Nvidia Drivers Cause LightDM to Crash

Reported by Daniel Nadeau on 2012-11-15
246
This bug affects 46 people
Affects Status Importance Assigned to Milestone
elementary OS
Critical
Unassigned

Bug Description

After installing the nvidia drivers from the "restricted extras" menu (after adding the correct PPAs) you are given the option to install the Nvidia Proprietary Drivers.

These drivers install successfully, but upon restart, cause LightDM to crash consistently. You are not able to get to the login screen, as LightDM crashes before this happens. However, you can drop to shell and do things like purge the Nvidia drivers from the system.

This also happens to newly installed systems because (as of beta1) the proprietary driver is installed along with the OS but is not configured properly (bug 1079812)

ProblemType: Bug
DistroRelease: elementary OS 0.2
Package: elementary-desktop (not installed)
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
CrashDB: elementary_meta
Date: Wed Nov 14 20:36:50 2012
InstallationMedia: elementary OS 0.2 "Luna" - Beta 1 amd64 (20121114)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Cody Garver (codygarver) wrote :

From another bug:

"When I select the normal entry for elementary, after it gets past the plymouth screen, it gets stuck at checking system v compatability. I can do ctrl+alt+f1 or reboot from there. However, if I boot up with the elementary recovery option and select normal boot from the list of options, it boots up to the login screen without a problem. I did not have this issue with the daily builds when I was using those as well as Ubuntu 12.04.

I am using the nVidia proprietary driver that elementary installs with."

Cody Garver (codygarver) wrote :

From another bug:

"After installing elementary os it doesn't boot. After I choose elementary os from GRUB loader it shows some text and freezes. It doesn't even go to a login screen.

I suspect there could be a problem with support for my graphics card (geforce gt 540M with nvidia optimus technology) but even after installing bumblebee (logged in with shift+alt+f2) nothing changed."

Changed in elementaryos:
importance: Undecided → Critical
milestone: none → luna-beta2
Charlie Carter (bloup) wrote :

I have this problem, too. I have an Nvidia GTX GeForce 560 GPU.

Daniel Nadeau (daniel-nadeau01) wrote :

I tried the suggested fix of:

sudo jockey-text -e xorg:nvidia_current

from the root shell. It came back with something along the lines of "cannot find this driver". Using

sudo jockey-text --list

shows the list of drivers, containing kmod:nvidia_current (instead of xorg:nvidia_current) and the other experimentals. However, nvidia_current does say (free, ENABLED, not in use), while the experimentals say (proprietary, DISABLED, not in use), and my Ethernet driver says (free, ENABLED, in use).

Using

sudo jockey-text -e kmod:nvidia_current

Does not come back with the same "cannot find this driver" text, however it still does not allow LightDM to work/function after reboot.

Charlie Carter (bloup) on 2012-11-19
Changed in elementaryos:
status: New → Confirmed
Carroarmato0 (carroarmato0) wrote :

I found a workaround for normal Ubuntu. I found out that there's a missing dependency when installing the proprietary nvidia driver. Basically the linux-headers-generic was missing which caused the nvidia driver to not install properly. Try installing the headers and then re-installing the nvidia driver. Hope that works.

Jarrod Bagwell (jarrodbagwell) wrote :

I tried installing the linux-headers-generic for both linux mint 13 and for elementary. In both cases the installation of the proprietary driver still causes a crash to shell.

Jarrod Bagwell (jarrodbagwell) wrote :

I know that the installation of other DM's can get around the problem. However, If one is going for a "pure" elementary OS experience this has to be fixed still using LightDM.

Charlie Carter (bloup) wrote :

For what it's worth, I found this thread: http://ubuntuforums.org/showthread.php?t=1965824

I don't know if it helps, it certainly seems similar. I can't try this at the moment, but if someone else can, you should try starting LightDM as root the way cyberwizzard describes to see if the two bugs are likely the same.

Changed in elementaryos:
status: Confirmed → Triaged
description: updated
description: updated
RibShark (ribshark) wrote :

Finally managed to workaround this problem!

First, if elementary is not yet installed properly, install it again, deselecting the optional extras while installing. It should install properly.
Now make sure your kernel is up to date.
Now follow the instructions at (https://wiki.ubuntu.com/Bumblebee) to install bumblebee.
Then I used these (http://www.webupd8.org/2012/12/use-nvidia-experimental-drivers-310.html) instructions to install the experimental drivers. [May not be necessary, but just saying what I did).
Also may not be necessary, but I installed primus (http://www.webupd8.org/2012/11/primus-better-performance-and-less.html) as well.

Rebooted and everything was working fine!

Charlie Carter (bloup) wrote :

I don't understand why Bumblebee changes anything though. I don't really know a lot about Bumblebee, but this problem occurs regardless of Optimus.

RibShark (ribshark) wrote :

AFAIK, it is because proprietary drivers don't have support for optimus, and require bumblebee to function correctly. Unfortunately, due to a separate bug, it was impossible to install bumblebee without crashing after second boot until the latest kernel update (that's why I said to update the kernel).

Charlie Carter (bloup) wrote :

I know, but I thought only mobile cards had to deal with Optimus.

RibShark (ribshark) wrote :

They do.... OK, consider the workaround to be a workaround for optimus users ONLY.

_Tharok_ (tharok) wrote :

I think I have fixed this on my computer... I blacklisted nouveau in /etc/modprobe.d/blacklist.conf (the nvidia drivers already did this in nvidia-graphic-drivers.conf but just to be sure...). Then I have removed the nouveau drivers, reinstalled nvidia-current and updated initramfs (sudo update-initramfs -u -v). When I rebooted lightdm was working but when I log in it just keep restarting himself, so I went to TTY1, killed lightdm and executed it from command line to see what was happening. The problem was that .Xauthority had a wrong owner. I just chown it to the proper user and now everything is working.

I don't know if all the steps are necessary because reinstalling the nvidia drivers also rebuild the initramfs (or I think so...). Anyway, my system is 100% operative now.

Cody Garver (codygarver) wrote :

I tried everything tharok described on my optimus laptop and nothing changed. Gonna try again when a kernel 3.5 iso comes out.

Daniel Fore (danrabbit) on 2012-12-23
Changed in elementaryos:
milestone: luna-beta2 → luna-beta3

The investigation so far suggests that this is an upstream issue. Could anyone affected please test the latest Ubuntu image from http://cdimage.ubuntu.com/precise/daily-live/current/ and check if this problem is present there as well?

Charlie Carter (bloup) wrote :

Can't right now, but I did install Xubuntu 12.04 on my computer not too long ago and the proprietary drivers worked fine. But it's best to double check.

OptiChip on FreeNode tested Ubuntu 12.04 daily build on the following GPU:
01:00.0 VGA compatible controller: NVIDIA Corporation GT216 [Quadro FX 880M] (rev a2)
And it works. So looks like it's our bug after all.

Charlie Carter (bloup) wrote :

Are we sure that's just a workaround? That almost sounds like it might be what is causing the bug in the first place.

Unless, by workaround you just mean without committing. But it sounds like there is a driver conflict that can be resolved by disabling one of the conflicting drivers.

RibShark (ribshark) wrote :

"That almost sounds like it might be what is causing the bug in the first place."

That explains why installing bumblebee fixed the problem for me, because it blacklists nouveau by default.

Charlie Carter (bloup) wrote :

Well, in that case, if someone gets the chance, here are a few tests that I think might be worth running on an official 12.04 image:

Check if the Nouveau driver is being used by default.

Install the proprietary driver.

Check the video drivers again.

I am pretty confident in how I think this will play out, so in the meantime, I think I'll go read a little bit about Jockey.

I just got a confirmation that blacklisting Nouveau on the installed system makes it work properly.

Ivo says that Ubiquity installs the proprietary driver to the non-live system as of Ubuntu 12.04.

I'm pretty sure blacklisting didn't work for me, I'll test again this weekend.

Sent from my iPhone

On Jan 9, 2013, at 2:25 PM, "Sergey \"Shnatsel\" Davidoff"
<email address hidden> wrote:

> I just got a confirmation that blacklisting Nouveau on the installed
> system makes it work properly.
>
> Ivo says that Ubiquity installs the proprietary driver to the non-live
> system as of Ubuntu 12.04.
>
> --
> You received this bug notification because you are subscribed to
> elementary OS.
> https://bugs.launchpad.net/bugs/1078977
>
> Title:
> Nvidia Drivers Cause LightDM to Crash
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1078977/+subscriptions

Charlie Carter (bloup) wrote :

I will too.

Charlie Carter (bloup) wrote :

Sorry I never managed to test it on my end. Cody, what about you?

Cody Garver (codygarver) wrote :

I'm waiting on a USB drive I ordered to arrive. Although, I have been assured this could not possibly be changed by 3.5, but I'm going to try it anyway.

You know what we haven't tried yet? Using a different greeter, e.g. lightdm-gtk-greeter, unity-greeter.

Ace (hakarune) wrote :

I fixed mine by:

sudo add-apt-repository ppa:bumblebee/stable

sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

Reboot

Dragoon Aethis (dragoonaethis) wrote :

Just installed Elementary with drivers screwed up, and updating everything + installing Bumblebee (look @up) did the job pretty well. Also as far as I know, nouveau isn't problematic. It supports Optimus (kind of, doesn't really work but also doesn't conflict with anything), while Nvidia drivers doesn't. Installing them on Optimus computers without Bumblebee gives you unusable distro.

Solution: Check whenever Elementary is running on Optimus system + Ubiquity is installing optional extras. Ask user what to do (during OS installation) and explain what will happen in each case:
 - Install latest drivers and Bumblebee with a script during first boot. Instead of starting LightDM, Gala, Pantheon and everything, OS should just install needed stuff, then set LightDM and company to start on every boot, as it normally should.
 - Install just Nvidia drivers. Note that this WILL screw up everything, user should know about it.
 - Install Nouveau. Pointless, as they suck, but that might suit some people. Zero problems. (They really suck. Maybe this shouldn't be even offered.)
 - Don't install anything. Just Intel GPU driver, which effectively shuts down Nvidia GPU.

I also have a Nvidia 540M. In the BIOS I changed from "Switchable" to "Integrated" graphics to avoid draining my battery (Windows has drivers that can switch between the two). I still experienced the freezing problem intermittently. I didn't install anything so it should be running just the generic Intel GPU driver.

The freezing problem is an Intel-only GPU lockup unrelated to this problem. See bug 1157786 for information on Intel GPU lockups.

Changed in elementaryos:
status: Triaged → Fix Committed

Also, this bug is believed to be fixed in the latest unstable ISO images.

Kevin Fish (kevin-ian-fish) wrote :

Tried the following:

- Purged all nvida drivers
- Purged bumblebee
- Reinstalled bumblebee with nvidia drivers and correct headers
No effect

- Purged all nvida drivers
- Purged bumblebee
- Reinstalled bumblebee with nvidia drivers and correct headers
- Installed primus and 32 bit libs
No effect

- Purged all nvida drivers
- Purged bumblebee
- Reinstalled bumblebee with nvidia drivers and correct headers
- Installed experimental nVidia drivers
No effect

- Purged all nvida drivers
- Purged bumblebee
- Reinstalled bumblebee with nvidia drivers and correct headers
- Installed experimental nVidia drivers
- Installed primus and 32 bit libs
No effect

Nouveau drivers are also blacklisted.

Only thing I can think of now is to revert to a previous kernel version (currently on 3.8.2 to address the Intel GPU lockup error)

Kevin Fish (kevin-ian-fish) wrote :

Reverting to 3.2.0-39 has no effect

Cody Garver (codygarver) on 2013-04-12
Changed in elementaryos:
status: Fix Committed → Fix Released

Am I correct in assuming that, with the status having been moved to "Fix Released", it is presumably relatively safe now to install the Nvidia proprietary drivers on the most up-to-date version of the Public Beta 1?
Apologies for any bother, and much thanks and congratulations on this critical fix, by the way!

Cody Garver (codygarver) wrote :

Use a recent daily ISO and let us know!

Alright.
I'm afraid I'm a bit slow at times, and I haven't had any coffee this morning; are the daily ISOs the same ISOs that are made available via the Beta 1 Announcement page, or are they made available via somewhere else?
Apologies. :S

If it helps any Optimus users, I would only boot to a black screen. I had to back out to a TTY and sudo apt-get remove nvidia* and sudo apt-get purge nvidia* in order to get it to properly boot (seems they install themselves when the "Install updates" is checked off in the installer).

From there, I installed Bumblebee using the above comments and got it working.

Cody Garver (codygarver) wrote :

Here's the ISO link: http://sourceforge.net/projects/elementaryos/files/unstable/

I'm almost certain this does not fix Optimus. I'm on an Optimus machine right now so I really wish it did.

Thanks very much for the link.

And, no, I don't see how it /could/ fix Optimus, as that's simply a lack of support in the current drivers for it.
I think however, with the rising popularity of Linux as a more general-use system, Steam for Linux, the steambox, and increasing support from Nvidia, I think we could possibly see Nvidia drivers supporting Optimus within Linux, in perhaps even a year or two.

Either way, if this at least fixes the LightDM conflict, that will make running Elementary OS even on a desktop, far, far more doable and pleasant from a performance-wise perspective.

Okay. Well, I was going to install it on a seperate hard-drive on my desktop, so as to test whether the fix is valid..., but-
When trying to begin the install process, etc, with the daily ISO you linked me, I get the following error, and can't seem to get past it:

/casper/initrd.img: file not found

Any ideas?
Was the download perhaps corrupted?
I thought it might have been a burning error, but I burnt it twice, on two different OSs, and same thing occurred, both times.
I apologize if this is the wrong place to discuss this.

Cody Garver (codygarver) wrote :

Use unetbootin.

Sent from my iPhone

On Apr 12, 2013, at 8:40 PM, phillip stuerzl <email address hidden> wrote:

> Okay. Well, I was going to install it on a seperate hard-drive on my desktop, so as to test whether the fix is valid..., but-
> When trying to begin the install process, etc, with the daily ISO you linked me, I get the following error, and can't seem to get past it:
>
> /casper/initrd.img: file not found
>
>
> Any ideas?
> Was the download perhaps corrupted?
> I thought it might have been a burning error, but I burnt it twice, on two different OSs, and same thing occurred, both times.
> I apologize if this is the wrong place to discuss this.
>
> --
> You received this bug notification because you are subscribed to
> elementary OS.
> https://bugs.launchpad.net/bugs/1078977
>
> Title:
> Nvidia Drivers Cause LightDM to Crash
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1078977/+subscriptions

Ah. Understood. Makes sense.
Will-do.
Thankyou.

Update:

As far as I can tell, to confirm, bug has been in fact fully fixed. Nvidia drivers are fully functional, and do not crash LightDM on boot.
Great bit of progress.

Any idea when this will get pushed to the stable update tree?
This current daily build is a bit sketchy as far as updating, and accessing repositories, among a few other strange things.

Much thanks, for everyone's work on this bug.
You guys are doing great.
I'll stop posting in this bug.
Apologies.

Nick Walke (tubaguy50035) wrote :

I seem to be having the same issue when I try to install to a virtual machine. Any workaround?

Cody Garver (codygarver) on 2013-05-13
Changed in elementaryos:
milestone: luna-beta3 → 0.3-beta1
milestone: 0.3-beta1 → luna-rc1
sidux (sidux) wrote :

same issue here after instaling latest unstable distro, i tried to install bumblebee, purge all nvidia drivers and bumblebee and nothing worked i can't even return to previous stat

sidux (sidux) wrote :

i resolved my issue by installing pantheon-greeter from daily repos and setting greeter-session=pantheon-greeter in /etc/lightdm/lightdm.conf

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers