QT can't detect GTK style

Bug #1074721 reported by Benoît Barberousse on 2012-11-03
32
This bug affects 8 people
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Medium
Unassigned

Bug Description

qtgtkstyle cannot detect the elementary gtk style, defaults to shitty qt style.

Francesco Lodovici (kde3kko) wrote :

Same here. I can reproduce the bug easily by installing and running qt4-qtconfig from terminal. The application loads fine and works, but the theme is not consistent and a message in the terminal complains about QGtkStyle not able to load the gtk theme.
Here's a screenshot:

Francesco Lodovici (kde3kko) wrote :

Update:
Running the following command in a terminal and restarting the session fixes the problem for most qt applications (skype still doesn't work, i believe this is something related to it being i386 while i am on x86_64):

gconftool-2 --set --type string /desktop/gnome/interface/gtk_theme Elementary

source:
https://bbs.archlinux.org/viewtopic.php?pid=1067521

Francesco Lodovici (kde3kko) wrote :

Update #2:

Installing ia32-libs from ubuntu repos also fixes the qt theming issues for 32bit applications on x86_64.

Francesco's first fix worked for me as well. I imagine developers will
implement the fix?

On Fri, Nov 16, 2012 at 4:49 AM, Francesco Lodovici <
<email address hidden>> wrote:

> Update #2:
>
> Installing ia32-libs from ubuntu repos also fixes the qt theming issues
> for 32bit applications on x86_64.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1074721
>
> Title:
> QT can't detect GTK style
>
> Status in elementary OS:
> New
>
> Bug description:
> qtgtkstyle cannot detect the elementary gtk style, defaults to shitty
> qt style.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1074721/+subscriptions
>

--
Benoît Barberousse
512.981.6578

Changed in elementaryos:
status: New → Confirmed
tags: added: defaults

I've applied the fix to elementary OS default settings. Thanks! Keep 'em coming ;)

Changed in elementaryos:
status: Confirmed → Fix Committed

Thanks for the commit

Changed in elementaryos:
milestone: none → luna-beta2
Cody Garver (codygarver) on 2013-01-01
Changed in elementaryos:
status: Fix Committed → Fix Released
David Gomes (davidgomes) on 2013-01-04
Changed in elementaryos:
importance: Undecided → Medium
Carlin Mangar (openshift) wrote :

I have experienced this issue with Draftsight V1R7. ia32-libs are removed from trusty, so you will need to dig up a few things and install in i386, but the biggest fix was having libgnomeui-0:i386 installed. This fixes issues with Qt apps in 32 bit detecting the theme you placed in GTK2.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers