"flash" cannot be installed in Midori

Reported by Damien on 2012-10-28
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Midori
Undecided
Unassigned
elementary OS
Undecided
Unassigned

Bug Description

Currently if you go to a website using flash (ie youtube) you are told to go to Adobe webiste to download it. When doing that and selecting the Ubuntu version, the apt link is automatically opened but the Software Center gives a "not found" error on the “adobe-flashplugin” package.

Searching for "flash" in the software center gives "flashplugin-installer" as a first result, which is good. But it doesn't seem to add flash support to midori after a restart of the app. I am apprently supposed to to something like this http://wiki.xfce.org/midori/faq#flash_doesn_t_work but this is too technical for me.

There are really three distinct bugs in this report, I wasn't sure if I had to file three bug reports or just one under the "flash doesn't work" blanket.

- you are told to go to adobe.com to download flash but elementary OS is not listed on their website. There should be a warning on the page using flash advising to go get the flash plugin in the software center.

- If people still go to adobe.com to get their flash, there should be a dummy “adobe-flashplugin” package redirecting to the correct package.

- Midori should check wherever the flash packages installs its plugin to use it instead of having the user manually inputing the location.

All this was done using the live-cd.

Damien (youpla-b) on 2012-10-28
summary: - "flash" doesn't work out of the box in Midori
+ "flash" cannot be installed in Midori
description: updated
Yusuf Elkilani (yusufelkilani) wrote :

I have this as well.

Damien (youpla-b) wrote :

I finally managed to get flash working.

I installed flash from the software center, which creates /usr/lib/mozilla/plugins/flashplugin-alternative.so (I found out later that it's a a symlink to /etc/alternatives/mozilla-flashplugin itself a symlink to /usr/lib/flashplugin-installer/libflashplayer.so . We're spinning round.)

As Xfce Wiki says the file name should be libflashplayer.so, I did ln -s ./flashplugin-alternative.so ./libflashplayer.so

I tried to do as Xfce Wiki said, blindly: run in a terminal export MOZ_PLUGIN_PATH="/usr/lib/mozilla/plugins" && midori . That didn't work.

Finally I tried sudo apt-get install nspluginwrapper . That last thing made it working. The rest of the line is not a correct terminal command and I have no idea how to fix it.

SO in order to have flash working in elementary OS you need to run the following command lines:

sudo apt-get install flashplugin-installer
sudo ln -s /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/mozilla/plugins/libflashplayer.so (maybe not needed?)
sudo apt-get install nspluginwrapper

and it should work. Because I've been tinkering with some esoteric command lines that did or did not work, there may be some missing steps.

That's way too much to do to get flash working. Please fix it.

Joan Jimenez (joajimenez) wrote :

Tried the Damien proposed fix. Did not work.

David Gomes (davidgomes) on 2012-11-17
Changed in elementaryos:
status: New → Invalid
Christian Dywan (kalikiana) wrote :

This my be confusing, but this is completely up to the distribution. If installing Flash and Midori as packaged on ElementaryOS is not enough, it's a bug. Somebody needs to narrow down what exactly is wrong with the packaging.

Changed in midori:
status: New → Invalid
Changed in elementaryos:
status: Invalid → Confirmed
Christian Dywan (kalikiana) wrote :

Damien, the incorrect terminal command was due to a markup error, I corrected it. The last command is this:
nspluginwrapper -v -a -n -i

Eduard Gotwig (gotwig) wrote :

kalikiana: No, it just doesn't works for me as well. I followed the tutorial of Damien

CruelAngel (hendricha) wrote :

tried with nspluginwrapper, does not show flash plugin in the list

Damian's solution worked fine for me, but as Christian said you need to add the command nspluginwrapper -v -a -n -i

Damien (youpla-b) wrote :

I noticed a new extension in Midori's preferences called "Shockwave Flash (netscape plugins)". It might help people having problems with Flash.

laurent (m2k-networx) wrote :

I assume the nspluginwrapper way only works on 32-bit architectures?

Christian Dywan (kalikiana) wrote :

nspluginwrapper works on 64-bit, a viable clue is the fact that it's packaged for 64-bit ;-)
As of 0.4.8 Flash can individually be enabled or disabled, there's no functional change as far as broken installations go however.

WRAYC (wrayc) wrote :

Yes this fix does work: Follow the step written then simply add last command "nspluginwrapper -v -a -n -i"

1. sudo apt-get install flashplugin-installer
2. sudo ln -s /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/mozilla/plugins/libflashplayer.so (maybe not needed?)
3. sudo apt-get install nspluginwrapper
4. nspluginwrapper -v -a -n -i

voila.

Thank you so much

David Wu (daviwu) wrote :

I can confirm that the steps
(1. sudo apt-get install flashplugin-installer
2. sudo ln -s /usr/lib/mozilla/plugins/flashplugin-alternative.so /usr/lib/mozilla/plugins/libflashplayer.so (maybe not needed?)
3. sudo apt-get install nspluginwrapper
4. nspluginwrapper -v -a -n -i)

does NOT work on the 64bit iso... it gives the following error

$ nspluginwrapper -v -a -n -i
Auto-install plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
*** NSPlugin Viewer *** ERROR: /usr/lib/mozilla/plugins/flashplugin-alternative.so: wrong ELF class: ELFCLASS64
*** NSPlugin Viewer *** ERROR: /usr/lib/mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS64

Chris Timberlake (game64) wrote :

David Wu: Even with the ELF Class errors, the plugin still works. I can confirm on Midori with a 64bit ISO. Updated to the latest. Running those commands does work and enable flash support although there is ELF errors.

Nabil Ilman (nekomuslim) wrote :

I've installed the 64-bit version of Beta 2 and inputted the given commands in the Terminal, ending up with the same ELF class errors experienced by the last two posters. However, as opposed to what Chris wrote; I could not play videos on YouTube with this browser.

Nabil Ilman (nekomuslim) wrote :

Flash seems to have worked on my 64-bit system after:

1. Installing the ia32-libs package.

2. Following the fix stated for the 64-bit version on the Midori FAQ page (http://midoribrowser.org/faqs/).

 (Can someone confirm, please? I ask because I didn't really have solving this bug in mind when I installed said package, and i'm sure that was the only thing I did before trying the fix.)

Carlos Sousa (carlosadssousa) wrote :

I think i fixed it in elementary 64
1. Download from adobe flash (tar.gz) and extract
2. Install nspluginwrapper
3. make a directory named plugins in home/.../.mozilla
4. copy libflashplayer.so previous extracted from download adobe flash (tar.gz) for ./mozilla/plugins
5. nspluginwrapper -v -a -n -i
et voila

razor (razorxpress) wrote :

Yes it worked for me too.

 I downloaded the 32 bit version of flash player from this link (http://get.adobe.com/flashplayer/completion/?installer=Flash_Player_11.2_for_other_Linux_%28.tar.gz%29_32-bit) and did what Carlos Sousa (carlosadssousa) suggests in above post.

Only after running the last command, it started working.

zeeeeee (miesogeno) wrote :

Finally I got it working.
Although I have Luna 64 bit, I needed to install the 32 bit flash version.
after that, run the final line in Carlos Sousa suggestion (already followed every other line one thousand times) and enable it in Midori preferences (extensions tab).

Thanks for the tip razor.

Cody Garver (codygarver) wrote :

This is actually multiple Midori bugs that are being compiled into a blueprint.

Changed in elementaryos:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions