Khmer fonts not included

Bug #1048130 reported by Adam Wood
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
elementary OS
Fix Released
Low
Otto Robba

Bug Description

There are not Khmer fonts included in the Jupiter distribution of Elementary. KhmerOS offers a number of good fonts as well as Google's Webfonts service. These need to be included, as well as full support for Khmer if it is expected for translations to go forward in the OS.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Sounds good to me. Could you point out any specific fonts we could include?

Changed in elementaryos:
status: New → Confirmed
status: Confirmed → Opinion
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

I take it the fonts-khmeros and fonts-khmeros-core are the packages in question.

According to http://www.khmeros.info/modules/khmeros_fonts.html, the computer-screen-oriented fonts are not complete yet. I have to defer the decision to designers; if they deem these fonts good enough, we'll include them.

Changed in elementaryos:
status: Opinion → New
assignee: nobody → elementary UX Team (elementary-design)
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

The issues is not exclusive to Khmer fonts so I've filed a more generic blueprint: https://blueprints.launchpad.net/elementaryos/+spec/better-i18n-font-support

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

Great. Those packages you mentioned are the ones. They are standards-compliant and the most frequently used for OS-level rendering. However, they are not the nicest looking. I prefer the ones on Google Webfonts found here:

http://www.google.com/webfonts

Select "Khmer" under the "script" selector. Hanuman is the most readable to me, but these are all nice fonts from my experience. By "nice" I mean that they render correctly in all words. I am not a designer, so I can't speak to how they look on the screen, except that I can read them :-). I think, though, since Khmer font typography is still in its infancy, it would be better to have some fonts in Khmer, even if they aren't optimized, than to have none at all.

BTW, I have started translating some of the applications in Elementary into Khmer.

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

One more thing. Just beware that the khmeros.info site is often out of date, way out of date at times. I thought of another site that has a list of all available khmer fonts, both unicode and legacy. Though, of course, we must stick with unicode. At least it will give the designers a better selection, though what I said above still applies.

http://selapa.net/khmerfonts/

Revision history for this message
Danielle Foré (danrabbit) wrote :

I'm definitely not opposed to expanding the number of languages we support OOTB. I'm assuming it would be possible to automagically switch to one of these fonts if a user selects Khmer as their language?

I'm not sure that any of our designers read Khmer or know what it's supposed to typically look like. So I think I'd let the decision of *which* font(s) to include fall on people that know what the characters should look like.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

So, shall we put up a journal post with call for font suggestions for languages that are not covered by Droid family? Or make a hot-or-not for localized fonts out of Google Web Fonts Directory?

Revision history for this message
Danielle Foré (danrabbit) wrote :

Sergey, I think it would probably end up being more productive to go trough the elementary translators mailing list. Otherwise I imagine we'll get a lot of erroneous suggestions from people who don't know what their talking about.

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

@DanielFore I was under the impression that the designers wanted to ensure that the fonts looked good on the screen, already given that they rendered correctly.
@Sergey If there are other languages with this issue then that would be a good idea to do the first idea. However as for the second, the Google Webfonts don't support that many languages. Many, many scripts are not listed there. It just happens to have good Khmer fonts. Of course, I would be glad to select fonts that are good quality if ths issue is isolated to only Khmer.

Cody Garver (codygarver)
Changed in elementaryos:
milestone: none → luna-beta2
importance: Undecided → Low
Revision history for this message
Otto Robba (otto-ottorobba) wrote :

I can take a look into this, include a few cyrillic, greek, khmer and other languages alternatives. I can test the rendering, a few things on spacing, line quality and whatnot... I could select a few weights and they should be enough to help a user with the basics, at least.

If a list of translators willing to help is made available I could pass the list of fonts through them before they are approved for being imbued into the OS.

Revision history for this message
Cody Garver (codygarver) wrote :

That would be really good Otto. The translators have their own mailing list here: https://launchpad.net/~elementary-translators

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Cyrillic seems to be covered by Droid Sans, or at least the subset that's used in Russian.

Changed in elementaryos:
status: New → Confirmed
Changed in elementaryos:
assignee: elementary UX Team (elementary-design) → Otto Robba (otto-ottorobba)
status: Confirmed → In Progress
Revision history for this message
Otto Robba (otto-ottorobba) wrote :

Not a fan of having droid sans the only font covering cyrillic - currently we've got khmer, chinese and other languages covered by ttf-unifont but that doesn't quite cut it. I'm trying to create a group of fonts that should, at least, provide a decent basis for most languages.

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

I am a speaker of Khmer and I have reviewed a number of the fonts in question for Khmer, including the ones from Google Web Fonts. I think the Khmer Mondulkiri font for Khmer is probably the best. It can be downloaded here from SIL.
http://scripts.sil.org/CMS/scripts/page.php?&item_id=Mondulkiri

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

Revision: Khmer Busra is a little better than Khmer Mondulkiri in the way it displays on the screen. It appears to have the same support as the first one I mentioned, but looks nicer on screen. You can find it in the same link, with bold, italic, and bold-italic.

Revision history for this message
Cody Garver (codygarver) wrote :

Otto, provide package names and/or download links to the fonts you prefer.

Adam, where can I find a download for Khmer Busra?

Revision history for this message
Adam Wood (gospeltocambodia) wrote : Re: [Bug 1048130] Re: Khmer fonts not included

@Cody, here is the
link<http://scripts.sil.org/CMS/scripts/page.php?&item_id=Mondulkiri>for
the Khmer Bursa font. There should be four styles.

On Wed, Jan 2, 2013 at 4:56 AM, Cody Garver <email address hidden> wrote:

> Otto, provide package names and/or download links to the fonts you
> prefer.
>
> Adam, where can I find a download for Khmer Busra?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1048130
>
> Title:
> Khmer fonts not included
>
> Status in elementary OS:
> In Progress
>
> Bug description:
> There are not Khmer fonts included in the Jupiter distribution of
> Elementary. KhmerOS offers a number of good fonts as well as Google's
> Webfonts service. These need to be included, as well as full support
> for Khmer if it is expected for translations to go forward in the OS.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1048130/+subscriptions
>

Revision history for this message
Cody Garver (codygarver) wrote :

I have packaged the 10 font files that seemed to be Bursa as fonts-khmer-busra in the daily PPA.

Adam, could you make sure I got all the desired fonts? There were 2 extra in the original download but I did not include them because I didn't know what the name the package otherwise.

Otto, please test out the fonts and let us know if you agree they should be the Khmer fonts shipped with elementary OS.

Thanks guys.

Revision history for this message
Cody Garver (codygarver) wrote :

And I just realized I mistitled the package.. so wait a little bit before you try to install them. And use the correct package name fonts-khmer-bursa.

Revision history for this message
Cody Garver (codygarver) wrote :

fonts-khmer-bursa is now in the PPA and ready to be tested.

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

I have looked at the package and it appears the at the SIL website the bold
font is missing, though it is supposed to be part of the package. The
Mondulkiri package has all the fonts (4 fonts). Sorry for the run around. I
didn't realize that a font was missing. If you can just use the Mondulkiri
package, that would be easiest.

On Wed, Jan 2, 2013 at 12:38 PM, Cody Garver <email address hidden> wrote:

> fonts-khmer-bursa is now in the PPA and ready to be tested.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1048130
>
> Title:
> Khmer fonts not included
>
> Status in elementary OS:
> In Progress
>
> Bug description:
> There are not Khmer fonts included in the Jupiter distribution of
> Elementary. KhmerOS offers a number of good fonts as well as Google's
> Webfonts service. These need to be included, as well as full support
> for Khmer if it is expected for translations to go forward in the OS.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1048130/+subscriptions
>

Revision history for this message
Cody Garver (codygarver) wrote :

fonts-khmer-mondulkiri is now in the PPA

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

Khmer fonts look good to me.

On Wed, Jan 2, 2013 at 3:06 PM, Cody Garver <email address hidden> wrote:

> fonts-khmer-mondulkiri is now in the PPA
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1048130
>
> Title:
> Khmer fonts not included
>
> Status in elementary OS:
> In Progress
>
> Bug description:
> There are not Khmer fonts included in the Jupiter distribution of
> Elementary. KhmerOS offers a number of good fonts as well as Google's
> Webfonts service. These need to be included, as well as full support
> for Khmer if it is expected for translations to go forward in the OS.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1048130/+subscriptions
>

Revision history for this message
Eduard Gotwig (gotwig) wrote :

it it ready to "include" it, and mark this bug as fixed or is more testing required?

Revision history for this message
Cody Garver (codygarver) wrote :

It is ready to be included but it would be nice to have Otto's opinion since he started the investigation.

Revision history for this message
Adam Wood (gospeltocambodia) wrote :

Yes, Khmer fonts are working correctly. Go ahead and include it.

Adam

On Thu, Jan 3, 2013 at 5:58 PM, Eduard Gotwig <email address hidden>wrote:

> it it ready to "include" it, and mark this bug as fixed or is more
> testing required?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1048130
>
> Title:
> Khmer fonts not included
>
> Status in elementary OS:
> In Progress
>
> Bug description:
> There are not Khmer fonts included in the Jupiter distribution of
> Elementary. KhmerOS offers a number of good fonts as well as Google's
> Webfonts service. These need to be included, as well as full support
> for Khmer if it is expected for translations to go forward in the OS.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1048130/+subscriptions
>

Cody Garver (codygarver)
Changed in elementaryos:
status: In Progress → Fix Released
Revision history for this message
Otto Robba (otto-ottorobba) wrote :

I'm sorry for not tending to this bug and thank those that did - I bit more than I could chew, I apologize.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.